]> git.pld-linux.org Git - packages/bcfg2.git/commitdiff
- initial spec, taken from bcfg2 main repo and PLDized
authorSÅ‚awomir Paszkiewicz <paszczus@pld-linux.org>
Wed, 10 Feb 2010 09:02:24 +0000 (09:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bcfg2.spec -> 1.1

bcfg2.spec [new file with mode: 0644]

diff --git a/bcfg2.spec b/bcfg2.spec
new file mode 100644 (file)
index 0000000..13f9ec7
--- /dev/null
@@ -0,0 +1,138 @@
+Summary:       Configuration management system
+Name:          bcfg2
+Version:       1.0.1
+Release:       0.1
+License:       BSD
+Group:         Applications/System
+URL:           http://trac.mcs.anl.gov/projects/bcfg2
+Source0:       ftp://ftp.mcs.anl.gov/pub/bcfg/%{name}-%{version}.tar.gz
+# Source0-md5: 6fbf36acc5cc58b2504a25c25cad3921
+%description
+Bcfg2 helps system administrators produce a consistent, reproducible,
+and verifiable description of their environment, and offers
+visualization and reporting tools to aid in day-to-day administrative
+tasks. It is the fifth generation of configuration management tools
+developed in the Mathematics and Computer Science Division of Argonne
+National Laboratory.
+
+It is based on an operational model in which the specification can be
+used to validate and optionally change the state of clients, but in a
+feature unique to bcfg2 the client's response to the specification can
+also be used to assess the completeness of the specification. Using
+this feature, bcfg2 provides an objective measure of how good a job an
+administrator has done in specifying the configuration of client
+systems. Bcfg2 is therefore built to help administrators construct an
+accurate, comprehensive specification.
+
+Bcfg2 has been designed from the ground up to support gentle
+reconciliation between the specification and current client states. It
+is designed to gracefully cope with manual system modifications.
+
+Finally, due to the rapid pace of updates on modern networks, client
+systems are constantly changing; if required in your environment,
+Bcfg2 can enable the construction of complex change management and
+deployment strategies.
+
+%package -n bcfg2-server
+Summary:       Bcfg2 Server
+Group:         Networking/Daemons
+Requires:      bcfg2
+Requires:      python-ssl
+
+%description -n bcfg2-server
+Bcfg2 helps system administrators produce a consistent, reproducible,
+and verifiable description of their environment, and offers
+visualization and reporting tools to aid in day-to-day administrative
+tasks. It is the fifth generation of configuration management tools
+developed in the Mathematics and Computer Science Division of Argonne
+National Laboratory.
+
+It is based on an operational model in which the specification can be
+used to validate and optionally change the state of clients, but in a
+feature unique to bcfg2 the client's response to the specification can
+also be used to assess the completeness of the specification. Using
+this feature, bcfg2 provides an objective measure of how good a job an
+administrator has done in specifying the configuration of client
+systems. Bcfg2 is therefore built to help administrators construct an
+accurate, comprehensive specification.
+
+Bcfg2 has been designed from the ground up to support gentle
+reconciliation between the specification and current client states. It
+is designed to gracefully cope with manual system modifications.
+
+Finally, due to the rapid pace of updates on modern networks, client
+systems are constantly changing; if required in your environment,
+Bcfg2 can enable the construction of complex change management and
+deployment strategies.
+
+%prep
+%setup -q
+
+%build
+export CFLAGS="%{rpmcflags}"
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+        --optimize=2 \
+        --root=$RPM_BUILD_ROOT
+
+%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_postclean
+
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT%{_sbindir}
+install -d $RPM_BUILD_ROOT%{_initrddir}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/default
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
+install -d $RPM_BUILD_ROOT%{_libdir}/bcfg2
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/bcfg2* $RPM_BUILD_ROOT%{_sbindir}
+install debian/bcfg2.init $RPM_BUILD_ROOT%{_initrddir}/bcfg2
+install debian/bcfg2-server.init $RPM_BUILD_ROOT%{_initrddir}/bcfg2-server
+install debian/bcfg2.default $RPM_BUILD_ROOT%{_sysconfdir}/default/bcfg2
+install debian/bcfg2-server.default $RPM_BUILD_ROOT%{_sysconfdir}/default/bcfg2-server
+install debian/bcfg2.cron.daily $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/bcfg2
+install debian/bcfg2.cron.hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/bcfg2
+install tools/bcfg2-cron $RPM_BUILD_ROOT%{_libdir}/bcfg2/bcfg2-cron
+
+%clean
+[ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT || exit 2
+
+%files -n bcfg2
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/bcfg2
+%{py_sitescriptdir}/Bcfg2/*.py*
+%{py_sitescriptdir}/Bcfg2/Client/*
+%{_mandir}/man1/*
+%{_mandir}/man5/*
+%{_initrddir}/bcfg2
+%config(noreplace) %{_sysconfdir}/default/bcfg2
+%{_sysconfdir}/cron.hourly/bcfg2
+/etc/cron.daily/bcfg2
+%{_libdir}/bcfg2/bcfg2-cron
+
+%post -n bcfg2-server
+/sbin/chkconfig --add bcfg2-server
+
+%files -n bcfg2-server
+%defattr(644,root,root,755)
+
+%{_initrddir}/bcfg2-server
+
+%{py_sitescriptdir}/Bcfg2/Server
+
+%{_datadir}/bcfg2
+%config(noreplace) %{_sysconfdir}/default/bcfg2-server
+%attr(755,root,root) %{_sbindir}/bcfg2-admin
+%attr(755,root,root) %{_sbindir}/bcfg2-build-reports
+%attr(755,root,root) %{_sbindir}/bcfg2-info
+%attr(755,root,root) %{_sbindir}/bcfg2-ping-sweep
+%attr(755,root,root) %{_sbindir}/bcfg2-repo-validate
+%attr(755,root,root) %{_sbindir}/bcfg2-reports
+%attr(755,root,root) %{_sbindir}/bcfg2-server
+
+%{_mandir}/man8/*.8*
+%dir %{_libdir}/bcfg2
This page took 0.088755 seconds and 4 git commands to generate.