]> git.pld-linux.org Git - packages/bcc.git/commitdiff
- added format patch to fix build with -Werror=format-security auto/th/bcc-0.16.19-1 auto/ti/bcc-0.16.19-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 22:02:09 +0000 (00:02 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 22:02:09 +0000 (00:02 +0200)
bcc.spec
dev86-format.patch [new file with mode: 0644]

index 09e1b0a64ea59f8845e5995bdbadda9cb62fbdf8..9308a15b560c9863a729a2de415828251b7812ce 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -17,6 +17,7 @@ Patch6:               dev86-nostrip.patch
 Patch7:                dev86-print-overflow.patch
 Patch8:                dev86-make.patch
 Patch9:                dev86-copt.patch
+Patch10:       dev86-format.patch
 URL:           http://www.debath.co.uk/
 Requires:      bin86 >= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,6 +54,7 @@ są odwzorowywane do jednego z innych typów całkowitych.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 mv -f bootblocks/README README.bootblocks
 mv -f copt/README README.copt
diff --git a/dev86-format.patch b/dev86-format.patch
new file mode 100644 (file)
index 0000000..60f0b67
--- /dev/null
@@ -0,0 +1,22 @@
+--- dev86-0.16.19/copt/copt.c.orig     2012-10-26 23:51:09.735174869 +0200
++++ dev86-0.16.19/copt/copt.c  2012-10-26 23:55:09.276050428 +0200
+@@ -803,7 +803,7 @@
+       exit(1);
+   }
+   if (headstr != NULL) {
+-      fprintf(fp, headstr);
++      fprintf(fp, "%s", headstr);
+       fprintf(fp, "\n");
+   }
+   for (lp = infile; lp != NULL; lp = lp->next)
+--- dev86-0.16.19/ar/ar.c.orig 2012-08-13 21:15:47.000000000 +0200
++++ dev86-0.16.19/ar/ar.c      2012-10-26 23:59:23.414647129 +0200
+@@ -2036,7 +2036,7 @@
+      struct mapelt *mapelt;
+ {
+   fprintf (stderr, "%s: ", program_name);
+-  fprintf (stderr, string);
++  fprintf (stderr, "%s", string);
+   if (mapelt->info.offset != 0)
+     fprintf (stderr, "%s(%s)", archive, mapelt->info.name);
+   else
This page took 0.076873 seconds and 4 git commands to generate.