]> git.pld-linux.org Git - packages/bcc.git/commitdiff
- updated to 0.16.19
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 21:22:04 +0000 (23:22 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 21:22:04 +0000 (23:22 +0200)
- updated opt,fortify patches
- removed obsolete long patch

Dev86src-opt.patch
bcc.spec
dev86-0.16.17-fortify.patch
dev86-long.patch [deleted file]

index 34e9e10c943d9efe968bb6bf94ba1d97b098e9c3..f1b8ce33436777f72f86ab70e0265315ddefff43 100644 (file)
@@ -21,17 +21,21 @@ diff -Nur dev86-0.16.0.orig/libbsd/Make.defs dev86-0.16.0/libbsd/Make.defs
  IFDEFNAME= ifdef
  
  # Some makes take the last of a list as the default ...
---- dev86-0.16.8/makefile.in.orig      Tue Aug 27 21:57:45 2002
-+++ dev86-0.16.8/makefile.in   Tue Aug 27 22:00:41 2002
-@@ -40,7 +40,7 @@
- WALL  =-Wall -Wstrict-prototypes
- CC    =%CC%
+--- dev86-0.16.19/makefile.in.orig     2012-10-25 21:27:25.627775623 +0200
++++ dev86-0.16.19/makefile.in  2012-10-25 21:29:26.577770547 +0200
+@@ -40,10 +40,10 @@
+        -Wcast-qual -Wcast-align -Wconversion -Waggregate-return \
+        -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls \
+        -Wnested-externs -Winline 
 -CFLAGS        =$(GCCFLAG) $(WALL) -O2 -g
 +CFLAGS        =$(GCCFLAG) $(WALL) $(OPT)
+ #else
+ WALL  =-Wall -Wstrict-prototypes
+-CFLAGS        =$(GCCFLAG) -O2 -fno-strict-aliasing
++CFLAGS        =$(GCCFLAG) $(OPT) -fno-strict-aliasing
  #endif
  
- #ifndef GNUMAKE
+ #endif
 --- dev86-0.16.8/dis88/Makefile.orig   Fri Jul 31 15:01:40 1998
 +++ dev86-0.16.8/dis88/Makefile        Tue Aug 27 22:38:03 2002
 @@ -25,7 +25,7 @@
index f1a610868f5d78f4f8a11c08f95aa8a561e27133..09e1b0a64ea59f8845e5995bdbadda9cb62fbdf8 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,23 +1,22 @@
 Summary:       Bruce's C compiler
 Summary(pl.UTF-8):     Kompilator C Bruce'a
 Name:          bcc
-Version:       0.16.18
-Release:       2
+Version:       0.16.19
+Release:       1
 License:       GPL
 Group:         Development/Languages
 Source0:       http://www.debath.co.uk/dev86/Dev86src-%{version}.tar.gz
-# Source0-md5: f2e06b547397383b2b2650b9c4fd9bab
+# Source0-md5: 442e98e1afa23fe00d40c5a996385942
 Patch0:                Dev86src-noroot.patch
 Patch1:                Dev86src-opt.patch
 Patch2:                dev86-0.16.17-fortify.patch
 Patch3:                dev86-pic.patch
 Patch4:                dev86-64bit.patch
 Patch5:                dev86-noelks.patch
-Patch6:                dev86-long.patch
-Patch7:                dev86-nostrip.patch
-Patch8:                dev86-print-overflow.patch
-Patch9:                dev86-make.patch
-Patch10:       dev86-copt.patch
+Patch6:                dev86-nostrip.patch
+Patch7:                dev86-print-overflow.patch
+Patch8:                dev86-make.patch
+Patch9:                dev86-copt.patch
 URL:           http://www.debath.co.uk/
 Requires:      bin86 >= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -54,7 +53,6 @@ są odwzorowywane do jednego z innych typów całkowitych.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 
 mv -f bootblocks/README README.bootblocks
 mv -f copt/README README.copt
index 715d0c4ca68786538e280481ca5ef719b9aa580b..7732b5ea434f1229b879f737a4b9f07489f0a690 100644 (file)
@@ -1,14 +1,14 @@
---- dev86-0.16.17/bcc/bcc.c
-+++ dev86-0.16.17/bcc/bcc.c
-@@ -19,6 +19,7 @@
- #ifdef __STDC__
+--- dev86-0.16.19/bcc/bcc.c.orig       2012-08-13 20:58:29.000000000 +0200
++++ dev86-0.16.19/bcc/bcc.c    2012-10-25 21:33:14.224427660 +0200
+@@ -20,6 +20,7 @@
+ #include <limits.h>
  #include <stdlib.h>
  #ifndef MSDOS
 +#include <limits.h>
  #include <unistd.h>
  #endif
  #else
-@@ -596,12 +597,17 @@
+@@ -600,12 +601,17 @@
     }
  }
  
     char buf[MAXPATHLEN];
     char ** prefix;
     char * saved_cmd;
-@@ -1308,11 +1314,7 @@
+@@ -1312,17 +1318,7 @@
  
        for(d=s=ptr; d && *s; s=d)
        {
+-#ifndef __BCC__
+-#ifdef PATH_MAX
+-         char buf[PATH_MAX];
+-#else
 -#ifdef MAXPATHLEN
           char buf[MAXPATHLEN];
 -#else
 -         char buf[1024];
+-#endif
+-#endif
 -#endif
  
         free(temp);
diff --git a/dev86-long.patch b/dev86-long.patch
deleted file mode 100644 (file)
index 34cde19..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -up dev86-0.16.17/ld/x86_aout.h.long dev86-0.16.17/ld/x86_aout.h
---- dev86-0.16.17/ld/x86_aout.h.long   2003-01-28 23:17:14.000000000 +0100
-+++ dev86-0.16.17/ld/x86_aout.h        2009-02-19 11:37:10.000000000 +0100
-@@ -11,10 +11,11 @@
- /* If the host isn't an x86 all bets are off, use chars. */
- #if defined(i386) || defined(__BCC__) || defined(MSDOS)
- typedef long Long;
--#define __OUT_OK 1
- #else
--typedef char Long[4];
-+#include <stdint.h>
-+typedef int32_t Long;
- #endif
-+#define __OUT_OK 1
- struct        exec {                  /* a.out header */
-   unsigned char       a_magic[2];     /* magic number */
This page took 0.099099 seconds and 4 git commands to generate.