]> git.pld-linux.org Git - packages/bcc.git/blobdiff - bcc.spec
- converted to UTF-8
[packages/bcc.git] / bcc.spec
index a8ca225c3286e142b894bbcf032bef90b612ea86..90edb82bbc4e7b56de017da41d883f2dc26dd441 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,20 +1,19 @@
 Summary:       Bruce's C compiler
-Summary(pl):   Kompilator C Bruce'a
+Summary(pl.UTF-8):   Kompilator C Bruce'a
 Name:          bcc
-Version:       0.16.13
-Release:       1
+Version:       0.16.17
+Release:       2
 License:       GPL
 Group:         Development/Languages
+#Source0Download: http://www.cix.co.uk/~mayday/
 Source0:       http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
-# Source0-md5: baa3bbf202ebc921526b98c5a20a3158
+# Source0-md5: e7bbfdbe61c2fb964994a087e29b0087
 Patch0:                Dev86src-noroot.patch
-Patch1:                Dev86src-nobcc.patch
-Patch2:                Dev86src-opt.patch
-Patch3:                Dev86src-errno.patch
-URL:           http://www.cix.co.uk/~mayday/
+Patch1:                Dev86src-opt.patch
+URL:           http://homepage.ntlworld.com/robert.debath/
 Requires:      bin86
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 ExclusiveArch: %{ix86}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # don't try to strip Linux-8086 objects
 %define                no_install_post_strip   1
@@ -25,18 +24,22 @@ compiler compile time options allow 80386 or 6809 versions. The
 compiler understands traditional K&R C with just the restriction that
 bit fields are mapped to one of the other integer types.
 
-%description -l pl
-Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
+%description -l pl.UTF-8
+Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
-rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
-s± odwzorowywane do jednego z innych typów ca³kowitych.
+rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
+są odwzorowywane do jednego z innych typów całkowitych.
 
 %prep
 %setup -q -n dev86-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
+
+mv -f bootblocks/README README.bootblocks
+mv -f copt/README README.copt
+mv -f dis88/README README.dis88
+mv -f elksemu/README README.elksemu
+mv -f unproto/README README.unproto
 
 %build
 CC="%{__cc}" \
@@ -52,53 +55,48 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install-all \
        DIST=$RPM_BUILD_ROOT
 
-install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
+# FFU (dis88/Makefile is not ready)
+#      MANDIR=%{_mandir}
+
 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
 
 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
 
-# move header files out of %{_includedir} and into %{_libdir}/bcc/include
-mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
-
+# these are separated in bin86 package
+rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
+rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
 # move man pages where they belong
 install -d $RPM_BUILD_ROOT%{_mandir}
-rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
-# these are separated in bin86 package
-rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
 
 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
 
-mv -f bootblocks/README README.bootblocks
-mv -f copt/README README.copt
-mv -f dis88/README README.dis88
-mv -f elksemu/README README.elksemu
-mv -f unproto/README README.unproto
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc Changes Contributors README*
-%attr(755,root,root) %{_bindir}/bcc
 %attr(755,root,root) %{_bindir}/ar86
-%attr(755,root,root) %{_bindir}/as86_encap
+%attr(755,root,root) %{_bindir}/bcc
 %attr(755,root,root) %{_bindir}/dis86
-%attr(755,root,root) %{_bindir}/objdump86
+%attr(755,root,root) %{_bindir}/elksemu
+%attr(755,root,root) %{_bindir}/makeboot
 %attr(755,root,root) %{_bindir}/nm86
+%attr(755,root,root) %{_bindir}/objdump86
 %attr(755,root,root) %{_bindir}/size86
-%{_libdir}/liberror.txt
 %dir %{_libdir}/bcc
-%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
+%attr(755,root,root) %{_libdir}/bcc/as86_encap
 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
+%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
 %attr(755,root,root) %{_libdir}/bcc/copt
 %attr(755,root,root) %{_libdir}/bcc/unproto
-%{_libdir}/bcc/i86
 %{_libdir}/bcc/i386
 %{_libdir}/bcc/include
 %{_libdir}/bcc/kinclude
-%attr(755,root,root) %{_bindir}/elksemu
+%{_libdir}/bcc/crt*.o
+%{_libdir}/bcc/lib*.a
+%{_libdir}/bcc/rules.*
 %{_mandir}/man1/*
This page took 0.088236 seconds and 4 git commands to generate.