]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- noted new URL
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.21
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://v3.sk/~lkundrak/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  6b96fe9d2d1c546842a4d1c7ef387e4c
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         %{name}-lib64.patch
15 Patch5:         dev86-noelks.patch
16 Patch6:         dev86-nostrip.patch
17 Patch7:         dev86-make.patch
18 Patch8:         %{name}-libx32.patch
19 URL:            http://v3.sk/~lkundrak/dev86/
20 Requires:       bin86 >= %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # don't try to strip Linux-8086 objects
24 %define         _noautostrip    .*%{_libdir}/bcc/.*\\.[ao]
25
26 %description
27 Bcc is a simple C compiler that produces 8086 assembler, in addition
28 compiler compile time options allow 80386 or 6809 versions. The
29 compiler understands traditional K&R C with just the restriction that
30 bit fields are mapped to one of the other integer types.
31
32 %description -l pl.UTF-8
33 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
34 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
35 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
36 są odwzorowywane do jednego z innych typów całkowitych.
37
38 %prep
39 %setup -q -n dev86-%{version}
40 %patch0 -p1
41 %patch1 -p1
42 %patch2 -p1
43 %patch3 -p0
44 %if "%{_lib}" == "lib64"
45 %patch4 -p1
46 %endif
47 %ifnarch %{ix86}
48 %patch5 -p1
49 %endif
50 %patch6 -p1
51 %patch7 -p1
52 %if "%{_lib}" == "libx32"
53 %patch8 -p1
54 %endif
55
56 %{__mv} bootblocks/README README.bootblocks
57 %{__mv} copt/README README.copt
58 %{__mv} dis88/README README.dis88
59 %{__mv} elksemu/README README.elksemu
60 %{__mv} unproto/README README.unproto
61
62 %build
63 CC="%{__cc}" \
64 %{__make} -j1 all other \
65         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
66 5
67 quit
68 !FooBar!
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -j1 install-all \
74         DIST=$RPM_BUILD_ROOT \
75         LIBDIR=%{_libdir}/bcc \
76         INCLDIR=%{_libdir}/bcc \
77         LOCALPREFIX=%{_prefix} \
78         MANDIR=%{_mandir}
79
80 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
81
82 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
83 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
84
85 # these are separated in bin86 package
86 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
87 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{as,ld}86.1*
88
89 %ifnarch %{ix86}
90 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/elks*.1
91 %endif
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc Changes Contributors README*
99 %attr(755,root,root) %{_bindir}/ar86
100 %attr(755,root,root) %{_bindir}/bcc
101 %attr(755,root,root) %{_bindir}/dis86
102 %ifarch %{ix86}
103 %attr(755,root,root) %{_bindir}/elksemu
104 %endif
105 %attr(755,root,root) %{_bindir}/makeboot
106 %attr(755,root,root) %{_bindir}/nm86
107 %attr(755,root,root) %{_bindir}/objdump86
108 %attr(755,root,root) %{_bindir}/size86
109 %dir %{_libdir}/bcc
110 %attr(755,root,root) %{_libdir}/bcc/as86_encap
111 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
112 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
113 %attr(755,root,root) %{_libdir}/bcc/copt
114 %attr(755,root,root) %{_libdir}/bcc/unproto
115 %{_libdir}/bcc/i386
116 %{_libdir}/bcc/include
117 %{_libdir}/bcc/kinclude
118 %{_libdir}/bcc/crt*.o
119 %{_libdir}/bcc/lib*.a
120 %{_libdir}/bcc/rules.*
121 %{_mandir}/man1/bcc.1*
122 %{_mandir}/man1/dis86.1*
123 %ifarch %{ix86}
124 %{_mandir}/man1/elks.1*
125 %{_mandir}/man1/elksemu.1*
126 %endif
This page took 0.0801 seconds and 3 git commands to generate.