]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- new URL
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.17
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 #Source0Download: http://www.cix.co.uk/~mayday/
9 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
10 # Source0-md5:  e7bbfdbe61c2fb964994a087e29b0087
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-opt.patch
13 URL:            http://homepage.ntlworld.com/robert.debath/
14 Requires:       bin86
15 ExclusiveArch:  %{ix86}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # don't try to strip Linux-8086 objects
19 %define         no_install_post_strip   1
20
21 %description
22 Bcc is a simple C compiler that produces 8086 assembler, in addition
23 compiler compile time options allow 80386 or 6809 versions. The
24 compiler understands traditional K&R C with just the restriction that
25 bit fields are mapped to one of the other integer types.
26
27 %description -l pl
28 Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
29 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
30 rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
31 s± odwzorowywane do jednego z innych typów ca³kowitych.
32
33 %prep
34 %setup -q -n dev86-%{version}
35 %patch0 -p1
36 %patch1 -p1
37
38 mv -f bootblocks/README README.bootblocks
39 mv -f copt/README README.copt
40 mv -f dis88/README README.dis88
41 mv -f elksemu/README README.elksemu
42 mv -f unproto/README README.unproto
43
44 %build
45 CC="%{__cc}" \
46 %{__make} all other \
47         OPT="%{rpmcflags}" <<!FooBar!
48 5
49 quit
50 !FooBar!
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install-all \
56         DIST=$RPM_BUILD_ROOT
57
58 # FFU (dis88/Makefile is not ready)
59 #       MANDIR=%{_mandir}
60
61 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
62
63 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
64 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
65
66 # these are separated in bin86 package
67 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
68 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
69 # move man pages where they belong
70 install -d $RPM_BUILD_ROOT%{_mandir}
71 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
72
73 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
74 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes Contributors README*
82 %attr(755,root,root) %{_bindir}/ar86
83 %attr(755,root,root) %{_bindir}/bcc
84 %attr(755,root,root) %{_bindir}/dis86
85 %attr(755,root,root) %{_bindir}/elksemu
86 %attr(755,root,root) %{_bindir}/makeboot
87 %attr(755,root,root) %{_bindir}/nm86
88 %attr(755,root,root) %{_bindir}/objdump86
89 %attr(755,root,root) %{_bindir}/size86
90 %dir %{_libdir}/bcc
91 %attr(755,root,root) %{_libdir}/bcc/as86_encap
92 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
93 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
94 %attr(755,root,root) %{_libdir}/bcc/copt
95 %attr(755,root,root) %{_libdir}/bcc/unproto
96 %{_libdir}/bcc/i386
97 %{_libdir}/bcc/include
98 %{_libdir}/bcc/kinclude
99 %{_libdir}/bcc/crt*.o
100 %{_libdir}/bcc/lib*.a
101 %{_libdir}/bcc/rules.*
102 %{_mandir}/man1/*
This page took 0.049314 seconds and 3 git commands to generate.