]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
perl -pi -e "s/pld-list\@pld.org.pl/feedback\@pld.org.pl/"
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompiler C Bruce'a
3 Name:           bcc
4 Version:        0.16.0
5 Release:        3
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-nobcc.patch
13 Patch2:         Dev86src-bccpaths.patch
14 Patch3:         Dev86src-opt.patch
15 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 ExclusiveArch:  %{ix86}
17 Requires:       bin86
18
19 %description
20 Bcc is a simple C compiler that produces 8086 assembler, in addition
21 compiler compile time options allow 80386 or 6809 versions. The
22 compiler understands traditional K&R C with just the restriction that
23 bit fields are mapped to one of the other integer types.
24
25 %description -l pl
26 Bcc jest prostym kompilatorem C produkuj±cym pliki asemblerowe 8086,
27 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
28 rozumie tradycyjne K&R C z takim ograniczeniem, ¿e pola bitowe
29 s± odwzorowywane do jednego z innych typów ca³kowitych.
30
31 %prep
32 %setup -q -n dev86-%{version}
33 %patch0 -p1
34 %patch1 -p1
35 %patch2 -p1
36 %patch3 -p1
37
38 %build
39 CC="%{__cc}" %{__make} OPT="%{rpmcflags}" <<!FooBar!
40 5
41 quit
42 !FooBar!
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DIST=$RPM_BUILD_ROOT
49
50 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
51 #rm -rf $RPM_BUILD_ROOT/lib/
52 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
53
54 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
55 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
56
57 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
58 mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
59
60 # move man pages where they belong
61 install -d $RPM_BUILD_ROOT%{_mandir}
62 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
63
64 gzip -9nf README MAGIC Contributors bootblocks/README copt/README \
65         dis88/README elksemu/README unproto/README bin86/README-0.4 \
66         bin86/README bin86/ChangeLog
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc *.gz */*.gz
74 %dir %{_libdir}/bcc
75 %dir %{_libdir}/bcc/i86
76 %dir %{_libdir}/bcc/i386
77 %dir %{_libdir}/bcc/include
78 %dir %{_libdir}/bcc/kinclude
79 %attr(755,root,root) %{_bindir}/bcc
80 #%attr(755,root,root) %{_bindir}/as86
81 %attr(755,root,root) %{_bindir}/as86_encap
82 #%attr(755,root,root) %{_bindir}/ld86
83 %attr(755,root,root) %{_bindir}/objdump86
84 %attr(755,root,root) %{_bindir}/nm86
85 %attr(755,root,root) %{_bindir}/size86
86 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
87 %attr(755,root,root) %{_libdir}/bcc/copt
88 %attr(755,root,root) %{_libdir}/bcc/unproto
89 %{_libdir}/bcc/i86/*
90 %{_libdir}/bcc/i386/*
91 %{_libdir}/liberror.txt
92 %{_libdir}/bcc/include/*
93 %{_libdir}/bcc/kinclude/*
94 %attr(755,root,root) %{_bindir}/elksemu
95 %{_mandir}/man1/*
This page took 0.058255 seconds and 3 git commands to generate.