]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- new URLs, updated to 0.16.18
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.18
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.debath.co.uk/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  f2e06b547397383b2b2650b9c4fd9bab
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         dev86-64bit.patch
15 Patch5:         dev86-noelks.patch
16 Patch6:         dev86-long.patch
17 Patch7:         dev86-nostrip.patch
18 Patch8:         dev86-print-overflow.patch
19 Patch9:         dev86-make.patch
20 URL:            http://www.debath.co.uk/
21 Requires:       bin86 >= %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # don't try to strip Linux-8086 objects
25 %define         _noautostrip    .*%{_libdir}/bcc/.*\\.[ao]
26
27
28 %description
29 Bcc is a simple C compiler that produces 8086 assembler, in addition
30 compiler compile time options allow 80386 or 6809 versions. The
31 compiler understands traditional K&R C with just the restriction that
32 bit fields are mapped to one of the other integer types.
33
34 %description -l pl.UTF-8
35 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
36 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
37 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
38 są odwzorowywane do jednego z innych typów całkowitych.
39
40 %prep
41 %setup -q -n dev86-%{version}
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3 -p0
46 %if "%{_lib}" == "lib64"
47 %patch4 -p1
48 %endif
49 %ifnarch %{ix86}
50 %patch5 -p1
51 %endif
52 %patch6 -p1
53 %patch7 -p1
54 %patch8 -p1
55 %patch9 -p1
56
57 mv -f bootblocks/README README.bootblocks
58 mv -f copt/README README.copt
59 mv -f dis88/README README.dis88
60 mv -f elksemu/README README.elksemu
61 mv -f unproto/README README.unproto
62
63 %build
64 CC="%{__cc}" \
65 %{__make} -j1 all other \
66         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
67 5
68 quit
69 !FooBar!
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -j1 install-all \
75         DIST=$RPM_BUILD_ROOT \
76         LIBDIR=%{_libdir}/bcc \
77         INCLDIR=%{_libdir}/bcc \
78         LOCALPREFIX=%{_prefix} \
79         MANDIR=%{_mandir}
80
81 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
82
83 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
84 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
85
86 # these are separated in bin86 package
87 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
88 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{as,ld}86.1*
89
90 %ifnarch %{ix86}
91 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/elks*.1
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc Changes Contributors README*
100 %attr(755,root,root) %{_bindir}/ar86
101 %attr(755,root,root) %{_bindir}/bcc
102 %attr(755,root,root) %{_bindir}/dis86
103 %ifarch %{ix86}
104 %attr(755,root,root) %{_bindir}/elksemu
105 %endif
106 %attr(755,root,root) %{_bindir}/makeboot
107 %attr(755,root,root) %{_bindir}/nm86
108 %attr(755,root,root) %{_bindir}/objdump86
109 %attr(755,root,root) %{_bindir}/size86
110 %dir %{_libdir}/bcc
111 %attr(755,root,root) %{_libdir}/bcc/as86_encap
112 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
113 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
114 %attr(755,root,root) %{_libdir}/bcc/copt
115 %attr(755,root,root) %{_libdir}/bcc/unproto
116 %{_libdir}/bcc/i386
117 %{_libdir}/bcc/include
118 %{_libdir}/bcc/kinclude
119 %{_libdir}/bcc/crt*.o
120 %{_libdir}/bcc/lib*.a
121 %{_libdir}/bcc/rules.*
122 %{_mandir}/man1/bcc.1*
123 %{_mandir}/man1/dis86.1*
124 %ifarch %{ix86}
125 %{_mandir}/man1/elks.1*
126 %{_mandir}/man1/elksemu.1*
127 %endif
This page took 0.050817 seconds and 3 git commands to generate.