]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- rel 6
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.17
5 Release:        6
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  e7bbfdbe61c2fb964994a087e29b0087
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         dev86-0.16.17-make382.patch
15 Patch5:         dev86-64bit.patch
16 Patch6:         dev86-noelks.patch
17 Patch7:         dev86-long.patch
18 Patch8:         dev86-nostrip.patch
19 Patch9:         dev86-print-overflow.patch
20 URL:            http://homepage.ntlworld.com/robert.debath/
21 Requires:       bin86
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # don't try to strip Linux-8086 objects
25 # TODO: use _noautostrip
26 %define         no_install_post_strip   1
27
28 %description
29 Bcc is a simple C compiler that produces 8086 assembler, in addition
30 compiler compile time options allow 80386 or 6809 versions. The
31 compiler understands traditional K&R C with just the restriction that
32 bit fields are mapped to one of the other integer types.
33
34 %description -l pl.UTF-8
35 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
36 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
37 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
38 są odwzorowywane do jednego z innych typów całkowitych.
39
40 %prep
41 %setup -q -n dev86-%{version}
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3 -p0
46 %patch4 -p0
47 %ifarch %{x8664}
48 %patch5 -p1
49 %patch6 -p1
50 %endif
51 %patch7 -p1
52 %patch8 -p1
53 %patch9 -p1
54
55 mv -f bootblocks/README README.bootblocks
56 mv -f copt/README README.copt
57 mv -f dis88/README README.dis88
58 mv -f elksemu/README README.elksemu
59 mv -f unproto/README README.unproto
60
61 %build
62 CC="%{__cc}" \
63 %{__make} -j1 all other \
64         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
65 5
66 quit
67 !FooBar!
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -j1 install-all \
73         DIST=$RPM_BUILD_ROOT \
74         LIBDIR=%{_libdir}/bcc \
75         INCLDIR=%{_libdir}/bcc \
76         LOCALPREFIX=%{_prefix}
77
78 # FFU (dis88/Makefile is not ready)
79 #       MANDIR=%{_mandir}
80
81 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
82
83 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
84 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
85
86 # these are separated in bin86 package
87 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
88 %{__rm} $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
89 # move man pages where they belong
90 install -d $RPM_BUILD_ROOT%{_mandir}
91 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
92
93 %ifnarch %{x8664}
94 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
95 %else
96 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,objdump86}}
97 %endif
98 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc Changes Contributors README*
106 %attr(755,root,root) %{_bindir}/ar86
107 %attr(755,root,root) %{_bindir}/bcc
108 %attr(755,root,root) %{_bindir}/dis86
109 %ifnarch %{x8664}
110 %attr(755,root,root) %{_bindir}/elksemu
111 %endif
112 %attr(755,root,root) %{_bindir}/makeboot
113 %attr(755,root,root) %{_bindir}/nm86
114 %attr(755,root,root) %{_bindir}/objdump86
115 %attr(755,root,root) %{_bindir}/size86
116 %dir %{_libdir}/bcc
117 %attr(755,root,root) %{_libdir}/bcc/as86_encap
118 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
119 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
120 %attr(755,root,root) %{_libdir}/bcc/copt
121 %attr(755,root,root) %{_libdir}/bcc/unproto
122 %{_libdir}/bcc/i386
123 %{_libdir}/bcc/include
124 %{_libdir}/bcc/kinclude
125 %{_libdir}/bcc/crt*.o
126 %{_libdir}/bcc/lib*.a
127 %{_libdir}/bcc/rules.*
128 %{_mandir}/man1/*
This page took 0.04844 seconds and 3 git commands to generate.