]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- added format patch to fix build with -Werror=format-security
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.19
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.debath.co.uk/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  442e98e1afa23fe00d40c5a996385942
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-opt.patch
12 Patch2:         dev86-0.16.17-fortify.patch
13 Patch3:         dev86-pic.patch
14 Patch4:         dev86-64bit.patch
15 Patch5:         dev86-noelks.patch
16 Patch6:         dev86-nostrip.patch
17 Patch7:         dev86-print-overflow.patch
18 Patch8:         dev86-make.patch
19 Patch9:         dev86-copt.patch
20 Patch10:        dev86-format.patch
21 URL:            http://www.debath.co.uk/
22 Requires:       bin86 >= %{version}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # don't try to strip Linux-8086 objects
26 %define         _noautostrip    .*%{_libdir}/bcc/.*\\.[ao]
27
28
29 %description
30 Bcc is a simple C compiler that produces 8086 assembler, in addition
31 compiler compile time options allow 80386 or 6809 versions. The
32 compiler understands traditional K&R C with just the restriction that
33 bit fields are mapped to one of the other integer types.
34
35 %description -l pl.UTF-8
36 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
37 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
38 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
39 są odwzorowywane do jednego z innych typów całkowitych.
40
41 %prep
42 %setup -q -n dev86-%{version}
43 %patch0 -p1
44 %patch1 -p1
45 %patch2 -p1
46 %patch3 -p0
47 %if "%{_lib}" == "lib64"
48 %patch4 -p1
49 %endif
50 %ifnarch %{ix86}
51 %patch5 -p1
52 %endif
53 %patch6 -p1
54 %patch7 -p1
55 %patch8 -p1
56 %patch9 -p1
57 %patch10 -p1
58
59 mv -f bootblocks/README README.bootblocks
60 mv -f copt/README README.copt
61 mv -f dis88/README README.dis88
62 mv -f elksemu/README README.elksemu
63 mv -f unproto/README README.unproto
64
65 %build
66 CC="%{__cc}" \
67 %{__make} -j1 all other \
68         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
69 5
70 quit
71 !FooBar!
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -j1 install-all \
77         DIST=$RPM_BUILD_ROOT \
78         LIBDIR=%{_libdir}/bcc \
79         INCLDIR=%{_libdir}/bcc \
80         LOCALPREFIX=%{_prefix} \
81         MANDIR=%{_mandir}
82
83 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
84
85 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
86 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
87
88 # these are separated in bin86 package
89 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
90 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{as,ld}86.1*
91
92 %ifnarch %{ix86}
93 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/elks*.1
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc Changes Contributors README*
102 %attr(755,root,root) %{_bindir}/ar86
103 %attr(755,root,root) %{_bindir}/bcc
104 %attr(755,root,root) %{_bindir}/dis86
105 %ifarch %{ix86}
106 %attr(755,root,root) %{_bindir}/elksemu
107 %endif
108 %attr(755,root,root) %{_bindir}/makeboot
109 %attr(755,root,root) %{_bindir}/nm86
110 %attr(755,root,root) %{_bindir}/objdump86
111 %attr(755,root,root) %{_bindir}/size86
112 %dir %{_libdir}/bcc
113 %attr(755,root,root) %{_libdir}/bcc/as86_encap
114 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
115 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
116 %attr(755,root,root) %{_libdir}/bcc/copt
117 %attr(755,root,root) %{_libdir}/bcc/unproto
118 %{_libdir}/bcc/i386
119 %{_libdir}/bcc/include
120 %{_libdir}/bcc/kinclude
121 %{_libdir}/bcc/crt*.o
122 %{_libdir}/bcc/lib*.a
123 %{_libdir}/bcc/rules.*
124 %{_mandir}/man1/bcc.1*
125 %{_mandir}/man1/dis86.1*
126 %ifarch %{ix86}
127 %{_mandir}/man1/elks.1*
128 %{_mandir}/man1/elksemu.1*
129 %endif
This page took 0.075403 seconds and 3 git commands to generate.