]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- release 4
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.17
5 Release:        4
6 License:        GPL
7 Group:          Development/Languages
8 #Source0Download: http://www.cix.co.uk/~mayday/
9 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
10 # Source0-md5:  e7bbfdbe61c2fb964994a087e29b0087
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-opt.patch
13 URL:            http://homepage.ntlworld.com/robert.debath/
14 Requires:       bin86
15 ExclusiveArch:  %{ix86}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # don't try to strip Linux-8086 objects
19 # TODO: use _noautostrip
20 %define         no_install_post_strip   1
21
22 %description
23 Bcc is a simple C compiler that produces 8086 assembler, in addition
24 compiler compile time options allow 80386 or 6809 versions. The
25 compiler understands traditional K&R C with just the restriction that
26 bit fields are mapped to one of the other integer types.
27
28 %description -l pl.UTF-8
29 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
30 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
31 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
32 są odwzorowywane do jednego z innych typów całkowitych.
33
34 %prep
35 %setup -q -n dev86-%{version}
36 %patch0 -p1
37 %patch1 -p1
38
39 mv -f bootblocks/README README.bootblocks
40 mv -f copt/README README.copt
41 mv -f dis88/README README.dis88
42 mv -f elksemu/README README.elksemu
43 mv -f unproto/README README.unproto
44
45 %build
46 CC="%{__cc}" \
47 %{__make} -j1 all other \
48         OPT="%{rpmcflags}" <<!FooBar!
49 5
50 quit
51 !FooBar!
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} -j1 install-all \
57         DIST=$RPM_BUILD_ROOT
58
59 # FFU (dis88/Makefile is not ready)
60 #       MANDIR=%{_mandir}
61
62 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
63
64 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
65 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
66
67 # these are separated in bin86 package
68 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
69 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
70 # move man pages where they belong
71 install -d $RPM_BUILD_ROOT%{_mandir}
72 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
73
74 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
75 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc Changes Contributors README*
83 %attr(755,root,root) %{_bindir}/ar86
84 %attr(755,root,root) %{_bindir}/bcc
85 %attr(755,root,root) %{_bindir}/dis86
86 %attr(755,root,root) %{_bindir}/elksemu
87 %attr(755,root,root) %{_bindir}/makeboot
88 %attr(755,root,root) %{_bindir}/nm86
89 %attr(755,root,root) %{_bindir}/objdump86
90 %attr(755,root,root) %{_bindir}/size86
91 %dir %{_libdir}/bcc
92 %attr(755,root,root) %{_libdir}/bcc/as86_encap
93 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
94 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
95 %attr(755,root,root) %{_libdir}/bcc/copt
96 %attr(755,root,root) %{_libdir}/bcc/unproto
97 %{_libdir}/bcc/i386
98 %{_libdir}/bcc/include
99 %{_libdir}/bcc/kinclude
100 %{_libdir}/bcc/crt*.o
101 %{_libdir}/bcc/lib*.a
102 %{_libdir}/bcc/rules.*
103 %{_mandir}/man1/*
This page took 0.064223 seconds and 3 git commands to generate.