]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- 0.16.11
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.11
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
9 Patch0:         Dev86src-noroot.patch
10 Patch1:         Dev86src-nobcc.patch
11 Patch2:         Dev86src-opt.patch
12 URL:            http://www.cix.co.uk/~mayday/
13 Requires:       bin86
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 ExclusiveArch:  %{ix86}
16
17 # don't try to strip Linux-8086 objects
18 %define         no_install_post_strip   1
19
20 %description
21 Bcc is a simple C compiler that produces 8086 assembler, in addition
22 compiler compile time options allow 80386 or 6809 versions. The
23 compiler understands traditional K&R C with just the restriction that
24 bit fields are mapped to one of the other integer types.
25
26 %description -l pl
27 Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
28 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
29 rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
30 s± odwzorowywane do jednego z innych typów ca³kowitych.
31
32 %prep
33 %setup -q -n dev86-%{version}
34 %patch0 -p1
35 %patch1 -p1
36 %patch2 -p1
37
38 %build
39 CC="%{__cc}" %{__make} all other OPT="%{rpmcflags}" <<!FooBar!
40 5
41 quit
42 !FooBar!
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install-all \
48         DIST=$RPM_BUILD_ROOT
49
50 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
51 #rm -rf $RPM_BUILD_ROOT/lib/
52 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
53
54 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
55 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
56
57 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
58 mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
59
60 # move man pages where they belong
61 install -d $RPM_BUILD_ROOT%{_mandir}
62 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
63 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
64 # these are separated in bin86 package
65 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
66
67 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
68 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
69
70 mv -f bootblocks/README README.bootblocks
71 mv -f copt/README README.copt
72 mv -f dis88/README README.dis88
73 mv -f elksemu/README README.elksemu
74 mv -f unproto/README README.unproto
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes Contributors README*
82 %attr(755,root,root) %{_bindir}/bcc
83 %attr(755,root,root) %{_bindir}/ar86
84 %attr(755,root,root) %{_bindir}/as86_encap
85 %attr(755,root,root) %{_bindir}/dis86
86 %attr(755,root,root) %{_bindir}/objdump86
87 %attr(755,root,root) %{_bindir}/nm86
88 %attr(755,root,root) %{_bindir}/size86
89 %{_libdir}/liberror.txt
90 %dir %{_libdir}/bcc
91 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
92 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
93 %attr(755,root,root) %{_libdir}/bcc/copt
94 %attr(755,root,root) %{_libdir}/bcc/unproto
95 %{_libdir}/bcc/i86
96 %{_libdir}/bcc/i386
97 %{_libdir}/bcc/include
98 %{_libdir}/bcc/kinclude
99 %attr(755,root,root) %{_bindir}/elksemu
100 %{_mandir}/man1/*
This page took 0.059175 seconds and 3 git commands to generate.