]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompiler C Bruce'a
3 Name:           bcc
4 Version:        0.16.0
5 Release:        3
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
9 Patch0:         Dev86src-noroot.patch
10 Patch1:         Dev86src-nobcc.patch
11 Patch2:         Dev86src-bccpaths.patch
12 Patch3:         Dev86src-opt.patch
13 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14 ExclusiveArch:  %{ix86}
15 Requires:       bin86
16
17 %description
18 Bcc is a simple C compiler that produces 8086 assembler, in addition
19 compiler compile time options allow 80386 or 6809 versions. The
20 compiler understands traditional K&R C with just the restriction that
21 bit fields are mapped to one of the other integer types.
22
23 %description -l pl
24 Bcc jest prostym kompilatorem C produkuj±cym pliki asemblerowe 8086,
25 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
26 rozumie tradycyjne K&R C z takim ograniczeniem, ¿e pola bitowe
27 s± odwzorowywane do jednego z innych typów ca³kowitych.
28
29 %prep
30 %setup -q -n dev86-%{version}
31 %patch0 -p1
32 %patch1 -p1
33 %patch2 -p1
34 %patch3 -p1
35
36 %build
37 CC="%{__cc}" %{__make} OPT="%{rpmcflags}" <<!FooBar!
38 5
39 quit
40 !FooBar!
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DIST=$RPM_BUILD_ROOT
47
48 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
49 #rm -rf $RPM_BUILD_ROOT/lib/
50 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
51
52 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
53 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
54
55 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
56 mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
57
58 # move man pages where they belong
59 install -d $RPM_BUILD_ROOT%{_mandir}
60 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
61
62 gzip -9nf README MAGIC Contributors bootblocks/README copt/README \
63         dis88/README elksemu/README unproto/README bin86/README-0.4 \
64         bin86/README bin86/ChangeLog
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc *.gz */*.gz
72 %dir %{_libdir}/bcc
73 %dir %{_libdir}/bcc/i86
74 %dir %{_libdir}/bcc/i386
75 %dir %{_libdir}/bcc/include
76 %dir %{_libdir}/bcc/kinclude
77 %attr(755,root,root) %{_bindir}/bcc
78 #%attr(755,root,root) %{_bindir}/as86
79 %attr(755,root,root) %{_bindir}/as86_encap
80 #%attr(755,root,root) %{_bindir}/ld86
81 %attr(755,root,root) %{_bindir}/objdump86
82 %attr(755,root,root) %{_bindir}/nm86
83 %attr(755,root,root) %{_bindir}/size86
84 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
85 %attr(755,root,root) %{_libdir}/bcc/copt
86 %attr(755,root,root) %{_libdir}/bcc/unproto
87 %{_libdir}/bcc/i86/*
88 %{_libdir}/bcc/i386/*
89 %{_libdir}/liberror.txt
90 %{_libdir}/bcc/include/*
91 %{_libdir}/bcc/kinclude/*
92 %attr(755,root,root) %{_bindir}/elksemu
93 %{_mandir}/man1/*
This page took 0.061898 seconds and 3 git commands to generate.