]> git.pld-linux.org Git - packages/bcc.git/blame - bcc.spec
- rel 6
[packages/bcc.git] / bcc.spec
CommitLineData
ad7c69fa 1Summary: Bruce's C compiler
57604c05 2Summary(pl.UTF-8): Kompilator C Bruce'a
ad7c69fa 3Name: bcc
549a0d65 4Version: 0.16.17
f24e9fd9 5Release: 6
ad7c69fa
AM
6License: GPL
7Group: Development/Languages
1331657a 8Source0: http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
549a0d65 9# Source0-md5: e7bbfdbe61c2fb964994a087e29b0087
ad7c69fa 10Patch0: Dev86src-noroot.patch
726244e8 11Patch1: Dev86src-opt.patch
45c7a6c2
AM
12Patch2: dev86-0.16.17-fortify.patch
13Patch3: dev86-pic.patch
14Patch4: dev86-0.16.17-make382.patch
f24e9fd9
JR
15Patch5: dev86-64bit.patch
16Patch6: dev86-noelks.patch
17Patch7: dev86-long.patch
18Patch8: dev86-nostrip.patch
19Patch9: dev86-print-overflow.patch
79386f7d 20URL: http://homepage.ntlworld.com/robert.debath/
75215f97 21Requires: bin86
f274ed64 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ad7c69fa 23
4aacfb22 24# don't try to strip Linux-8086 objects
7d6c1aee 25# TODO: use _noautostrip
4aacfb22
JB
26%define no_install_post_strip 1
27
ad7c69fa
AM
28%description
29Bcc is a simple C compiler that produces 8086 assembler, in addition
30compiler compile time options allow 80386 or 6809 versions. The
31compiler understands traditional K&R C with just the restriction that
32bit fields are mapped to one of the other integer types.
33
8c14594a
JR
34%description -l pl.UTF-8
35Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
ad7c69fa 36a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
8c14594a
JR
37rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
38są odwzorowywane do jednego z innych typów całkowitych.
ad7c69fa
AM
39
40%prep
41%setup -q -n dev86-%{version}
6b452b5b 42%patch0 -p1
43%patch1 -p1
45c7a6c2
AM
44%patch2 -p1
45%patch3 -p0
46%patch4 -p0
f24e9fd9
JR
47%ifarch %{x8664}
48%patch5 -p1
49%patch6 -p1
50%endif
51%patch7 -p1
52%patch8 -p1
53%patch9 -p1
ad7c69fa 54
02103d98
ER
55mv -f bootblocks/README README.bootblocks
56mv -f copt/README README.copt
57mv -f dis88/README README.dis88
58mv -f elksemu/README README.elksemu
59mv -f unproto/README README.unproto
60
ad7c69fa 61%build
63acc6f4 62CC="%{__cc}" \
4cc830eb 63%{__make} -j1 all other \
45c7a6c2 64 OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
ad7c69fa
AM
655
66quit
67!FooBar!
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
4cc830eb 72%{__make} -j1 install-all \
f24e9fd9
JR
73 DIST=$RPM_BUILD_ROOT \
74 LIBDIR=%{_libdir}/bcc \
75 INCLDIR=%{_libdir}/bcc \
76 LOCALPREFIX=%{_prefix}
ad7c69fa 77
726244e8
JB
78# FFU (dis88/Makefile is not ready)
79# MANDIR=%{_mandir}
80
6b452b5b 81cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
ad7c69fa 82
6b452b5b 83ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
84ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
ad7c69fa 85
726244e8 86# these are separated in bin86 package
f24e9fd9
JR
87%{__rm} $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
88%{__rm} $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
0af5fdb9 89# move man pages where they belong
6b452b5b 90install -d $RPM_BUILD_ROOT%{_mandir}
b1e1f518 91mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
4aacfb22 92
f24e9fd9 93%ifnarch %{x8664}
4aacfb22 94%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
f24e9fd9
JR
95%else
96%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,objdump86}}
97%endif
4aacfb22 98%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
6b452b5b 99
ad7c69fa 100%clean
6b452b5b 101rm -rf $RPM_BUILD_ROOT
ad7c69fa
AM
102
103%files
104%defattr(644,root,root,755)
4aacfb22 105%doc Changes Contributors README*
4aacfb22 106%attr(755,root,root) %{_bindir}/ar86
726244e8 107%attr(755,root,root) %{_bindir}/bcc
4aacfb22 108%attr(755,root,root) %{_bindir}/dis86
f24e9fd9 109%ifnarch %{x8664}
726244e8 110%attr(755,root,root) %{_bindir}/elksemu
f24e9fd9 111%endif
726244e8 112%attr(755,root,root) %{_bindir}/makeboot
ad7c69fa 113%attr(755,root,root) %{_bindir}/nm86
726244e8 114%attr(755,root,root) %{_bindir}/objdump86
ad7c69fa 115%attr(755,root,root) %{_bindir}/size86
4aacfb22 116%dir %{_libdir}/bcc
726244e8 117%attr(755,root,root) %{_libdir}/bcc/as86_encap
0af5fdb9 118%attr(755,root,root) %{_libdir}/bcc/bcc-cc1
726244e8 119%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
0af5fdb9
AM
120%attr(755,root,root) %{_libdir}/bcc/copt
121%attr(755,root,root) %{_libdir}/bcc/unproto
4aacfb22
JB
122%{_libdir}/bcc/i386
123%{_libdir}/bcc/include
124%{_libdir}/bcc/kinclude
726244e8
JB
125%{_libdir}/bcc/crt*.o
126%{_libdir}/bcc/lib*.a
127%{_libdir}/bcc/rules.*
ad7c69fa 128%{_mandir}/man1/*
This page took 0.082024 seconds and 4 git commands to generate.