]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 4.1.9 auto/th/bash-4_1_9-1 auto/ti/bash-4_1_9-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 6 Nov 2010 20:18:10 +0000 (20:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash.spec -> 1.209
    bash41-008 -> 1.1
    bash41-009 -> 1.1

bash.spec
bash41-008 [new file with mode: 0644]
bash41-009 [new file with mode: 0644]

index 5d6bb3cab90888a40066166093bcf0613a02cbc7..cd91ae4697cc3b5b9793471abe2290d5e35049cd 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             4.1
-%define                patchlevel      7
+%define                patchlevel      9
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
diff --git a/bash41-008 b/bash41-008
new file mode 100644 (file)
index 0000000..2bec4de
--- /dev/null
@@ -0,0 +1,49 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-008
+
+Bug-Reported-by:       Dennis van Dok <dvandok@gmail.com>
+Bug-Reference-ID:      <4BBF2501.5050703@gmail.com>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-04/msg00038.html
+
+Bug-Description:
+
+When declaring an associative array and implicitly assigning a value
+to element "0", bash does not correctly allocate memory, leading to
+a segmentation violation when that element or the array itself is
+unset.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/builtins/declare.def   2009-11-25 19:42:00.000000000 -0500
+--- builtins/declare.def       2010-05-30 18:25:21.000000000 -0400
+***************
+*** 513,517 ****
+             /* let bind_{array,assoc}_variable take care of this. */
+             if (assoc_p (var))
+!              bind_assoc_variable (var, name, "0", value, aflags);
+             else
+               bind_array_variable (name, 0, value, aflags);
+--- 519,523 ----
+             /* let bind_{array,assoc}_variable take care of this. */
+             if (assoc_p (var))
+!              bind_assoc_variable (var, name, savestring ("0"), value, aflags);
+             else
+               bind_array_variable (name, 0, value, aflags);
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 7
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 8
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash41-009 b/bash41-009
new file mode 100644 (file)
index 0000000..ae0f1e3
--- /dev/null
@@ -0,0 +1,48 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-009
+
+Bug-Reported-by:       Tomas Trnka <tomastrnka@gmx.com>
+Bug-Reference-ID:      <201003242030.02166.tomastrnka@gmx.com>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-03/msg00090.html
+
+Bug-Description:
+
+An arriving SIGCHLD will interrupt `slow' system calls such as write(2) to
+or read(2) from a terminal.  This results in an error message and truncated
+input or output.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/sig.c  Fri Aug 14 16:31:52 2009
+--- sig.c      Fri Mar 26 22:34:11 2010
+***************
+*** 655,660 ****
+--- 655,663 ----
+      act.sa_flags |= SA_INTERRUPT;    /* XXX */
+    else
+      act.sa_flags |= SA_RESTART;              /* XXX */
++ #else
++   if (sig == SIGCHLD)
++     act.sa_flags |= SA_RESTART;
+  #endif
+    sigemptyset (&act.sa_mask);
+    sigemptyset (&oact.sa_mask);
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 8
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 9
+  
+  #endif /* _PATCHLEVEL_H_ */
+
This page took 0.139458 seconds and 4 git commands to generate.