]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- up to 4.3.29; fixes invalid memory access sometimes
[packages/bash.git] / bash.spec
index 6c1d9e04a22a21fecb4003084db6e6a323a96110..e768e8532fbafca72b125b7bb926195746f7603e 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -3,10 +3,11 @@
 %bcond_without static          # don't build static version
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
-#
-%define                ver             4.2
-#%%define              patchlevel      1
-%define                rel             2
+
+# NOTE: when updating patchleve, do not forget to update 'sources' file!
+%define                ver             4.3
+%define                patchlevel      29
+%define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -16,7 +17,7 @@ Release:      %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 3fb927c7c33022f1c327f14a81c0d4b0
+# Source0-md5: 81348932d5da294953e15d4814c74dd1
 Source1:       %{name}rc
 Source2:       %{name}-skel-.bash_logout
 Source3:       %{name}-skel-.bash_profile
@@ -35,13 +36,13 @@ Patch9:             %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
 Patch12:       %{name}-pl.po-update.patch
-%{?patchlevel:%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash41-%03g 1 %{patchlevel}}
+%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 6.2
+BuildRequires: readline-devel >= 6.3
 BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
@@ -49,9 +50,9 @@ BuildRequires:        texinfo
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 6.2
+BuildRequires: readline-static >= 6.3
 %endif
-Requires:      readline >= 6.2
+Requires:      readline >= 6.3
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -194,6 +195,8 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch11 -p1
 %patch12 -p1
 
+sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
+
 %build
 cp -f /usr/share/automake/config.* support
 %{__autoconf}
@@ -210,13 +213,13 @@ for mode in %{?with_static:static} shared; do
        --enable-dparen-arithmetic \
        --enable-separate-helpfiles \
        --without-bash-malloc \
-       `[ "$mode" = "static" ] && echo "--enable-static-link"` \
+       $([ "$mode" = "static" ] && echo "--enable-static-link") \
        --with-installed-readline
 
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static || :
+[ "$mode" = "static" ] && mv -f bash bash.static
 done
 
 %{?with_tests:%{__make} tests}
This page took 0.0828 seconds and 4 git commands to generate.