]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- up to 4.3.29; fixes invalid memory access sometimes
[packages/bash.git] / bash.spec
index 3ff99c0935baf03c0c411d1c784960be6b3d3b68..e768e8532fbafca72b125b7bb926195746f7603e 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -3,29 +3,27 @@
 %bcond_without static          # don't build static version
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
-#
-%define                ver             3.2
-%define                patchlevel      39
+
+# NOTE: when updating patchleve, do not forget to update 'sources' file!
+%define                ver             4.3
+%define                patchlevel      29
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
 Name:          bash
-Version:       %{ver}.%{patchlevel}
+Version:       %{ver}%{?patchlevel:.%{patchlevel}}
 Release:       %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 00bfa16d58e034e3c2aa27f390390d30
+# Source0-md5: 81348932d5da294953e15d4814c74dd1
 Source1:       %{name}rc
-Source2:       %{name}-skel-.%{name}_logout
-Source3:       %{name}-skel-.%{name}_profile
-Source4:       %{name}-skel-.%{name}rc
+Source2:       %{name}-skel-.bash_logout
+Source3:       %{name}-skel-.bash_profile
+Source4:       %{name}-skel-.bashrc
 Source5:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source5-md5: d2aacf89c4a444c5da648da69afdb01a
-# based on GNU TP; omitted: eo (not supported), rw (empty)
-Source6:       %{name}-translations.tar.bz2
-# Source6-md5: 99701bc1f919cfc527cb95fadbc66c93
 Patch0:                %{name}-paths.patch
 Patch1:                %{name}-security.patch
 Patch2:                %{name}-autoconf.patch
@@ -37,13 +35,14 @@ Patch8:             %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
+Patch12:       %{name}-pl.po-update.patch
+%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 5.2
+BuildRequires: readline-devel >= 6.3
 BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
@@ -51,9 +50,9 @@ BuildRequires:        texinfo
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 5.2
+BuildRequires: readline-static >= 6.3
 %endif
-Requires:      readline >= 5.2
+Requires:      readline >= 6.3
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -182,7 +181,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %prep
 %setup -q -n %{name}-%{ver} -a5
 # official patches
-%patchset_patch 1 %{patchlevel}
+%{?patchlevel:%patchset_patch 1 %{patchlevel}}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -194,8 +193,9 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
-tar xjf %SOURCE6 -C po
-sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
+%patch12 -p1
+
+sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
 %build
 cp -f /usr/share/automake/config.* support
@@ -213,13 +213,13 @@ for mode in %{?with_static:static} shared; do
        --enable-dparen-arithmetic \
        --enable-separate-helpfiles \
        --without-bash-malloc \
-       `[ "$mode" = "static" ] && echo "--enable-static-link"` \
+       $([ "$mode" = "static" ] && echo "--enable-static-link") \
        --with-installed-readline
 
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static || :
+[ "$mode" = "static" ] && mv -f bash bash.static
 done
 
 %{?with_tests:%{__make} tests}
@@ -301,7 +301,8 @@ end
 %lang(ko) %{_mandir}/ko/man1/*
 %lang(nl) %{_mandir}/nl/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+%doc %{_datadir}/%{name}/*
 
 %if %{with static}
 %files static
This page took 0.045856 seconds and 4 git commands to generate.