]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- up to 4.0.33
[packages/bash.git] / bash.spec
index fd77b0edda16776245c31a2cadbe79fad3f2005d..ba7f9643be0393935f56bd9ad018b9abb02bd85c 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -4,8 +4,8 @@
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
 #
-%define                ver             3.2
-%define                patchlevel      39
+%define                ver             4.0
+%define                patchlevel      33
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
@@ -16,7 +16,7 @@ Release:      %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 00bfa16d58e034e3c2aa27f390390d30
+# Source0-md5: a90a1b5a6db4838483f05438e05e8eb9
 Source1:       %{name}rc
 Source2:       %{name}-skel-.%{name}_logout
 Source3:       %{name}-skel-.%{name}_profile
@@ -37,23 +37,23 @@ Patch8:             %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
+%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.429
+BuildRequires: readline-devel >= 6.0
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 5.2
+BuildRequires: readline-static >= 6.0
 %endif
-Requires:      readline >= 5.2
+Requires:      readline >= 6.0
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -194,7 +194,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
-tar xjf %SOURCE6 -C po
+%{__tar} xjf %{SOURCE6} -C po
 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
 
 %build
@@ -259,16 +259,25 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p %add_etc_shells -p /bin/sh /bin/ksh
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 
-%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post static -p %add_etc_shells -p /bin/bash.static
-%preun static -p %remove_etc_shells -p /bin/bash.static
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
This page took 0.139646 seconds and 4 git commands to generate.