]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- up to 4.3.25; fixes (sometimes remotely exploitable) CVE-2014-6271
[packages/bash.git] / bash.spec
index 235466a9738edc3af8115865b9c7d8e7c178296d..81d2dc6023ba36dd9621571230329c5216bbe6bb 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -3,29 +3,27 @@
 %bcond_without static          # don't build static version
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
-#
-%define                _ver            3.2
-%define                _patchlevel     10
-%define                _rel            1
+
+# NOTE: when updating patchleve, do not forget to update 'sources' file!
+%define                ver             4.3
+%define                patchlevel      25
+%define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
 Name:          bash
-Version:       %{_ver}.%{_patchlevel}
-Release:       %{_rel}%{?with_bash_history:inv}
+Version:       %{ver}%{?patchlevel:.%{patchlevel}}
+Release:       %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
-Source0:       ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
-# Source0-md5: 00bfa16d58e034e3c2aa27f390390d30
+Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
+# Source0-md5: 81348932d5da294953e15d4814c74dd1
 Source1:       %{name}rc
-Source2:       %{name}-skel-.%{name}_logout
-Source3:       %{name}-skel-.%{name}_profile
-Source4:       %{name}-skel-.%{name}rc
+Source2:       %{name}-skel-.bash_logout
+Source3:       %{name}-skel-.bash_profile
+Source4:       %{name}-skel-.bashrc
 Source5:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source5-md5: d2aacf89c4a444c5da648da69afdb01a
-# based on GNU TP; omitted: eo (not supported), rw (empty)
-Source6:       %{name}-translations.tar.bz2
-# Source6-md5: 99701bc1f919cfc527cb95fadbc66c93
 Patch0:                %{name}-paths.patch
 Patch1:                %{name}-security.patch
 Patch2:                %{name}-autoconf.patch
@@ -36,26 +34,25 @@ Patch6:             %{name}-compat.patch
 Patch8:                %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
-%patchset_source -f ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{_patchlevel}
+Patch11:       %{name}-elinks_cont.patch
+Patch12:       %{name}-pl.po-update.patch
+%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.353
+BuildRequires: readline-devel >= 6.3
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 5.2
+BuildRequires: readline-static >= 6.3
 %endif
-Requires(post,preun):  grep
-Requires(preun):       fileutils
-Requires:      grep
-Requires:      readline >= 5.2
+Requires:      readline >= 6.3
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -158,8 +155,6 @@ Tools specification (IEEE Working Group 1003.2).
 Summary:       Statically linked GNU Bourne Again Shell (bash)
 Summary(pl.UTF-8):     Statycznie skonsolidowany GNU Bourne Again Shell (bash)
 Group:         Applications/Shells
-Requires(post,preun):  grep
-Requires(preun):       fileutils
 Requires:      %{name} = %{version}-%{release}
 
 %description static
@@ -184,9 +179,9 @@ Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
 tym pakiecie jest wersja basha skonsolidowana statycznie.
 
 %prep
-%setup -q -n %{name}-%{_ver} -a5
+%setup -q -n %{name}-%{ver} -a5
 # official patches
-%patchset_patch 1 %{_patchlevel}
+%{?patchlevel:%patchset_patch 1 %{patchlevel}}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -197,8 +192,10 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch8 -p1
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
-tar xjf %SOURCE6 -C po
-sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
+%patch11 -p1
+%patch12 -p1
+
+sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
 %build
 cp -f /usr/share/automake/config.* support
@@ -216,13 +213,13 @@ for mode in %{?with_static:static} shared; do
        --enable-dparen-arithmetic \
        --enable-separate-helpfiles \
        --without-bash-malloc \
-       `[ "$mode" = "static" ] && echo "--enable-static-link"` \
+       $([ "$mode" = "static" ] && echo "--enable-static-link") \
        --with-installed-readline
 
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static || :
+[ "$mode" = "static" ] && mv -f bash bash.static
 done
 
 %{?with_tests:%{__make} tests}
@@ -254,53 +251,33 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
+# use our bugtracker, upstream will ignore reports from this anyway
+rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash" > /etc/shells
-       echo "/bin/rbash" >> /etc/shells
-else
-       if ! grep -q '^/bin/bash$' /etc/shells; then
-               echo "/bin/bash" >> /etc/shells
-       fi
-       if ! grep -q '^/bin/rbash$' /etc/shells; then
-               echo "/bin/rbash" >> /etc/shells
-       fi
-fi
-
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%preun
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
-
-%post static
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash.static" > /etc/shells
-else
-       if ! grep -q '^/bin/bash.static$' /etc/shells; then
-               echo "/bin/bash.static" >> /etc/shells
-       fi
-fi
-
-%preun static
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash.static /etc/shells > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
-
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
+os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
+
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
+
+%postun        -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
@@ -313,7 +290,6 @@ fi
 
 %attr(755,root,root) /bin/bash
 %attr(755,root,root) /bin/rbash
-%attr(755,root,root) %{_bindir}/bashbug
 
 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
 %{_infodir}/bash.info*
@@ -325,7 +301,8 @@ fi
 %lang(ko) %{_mandir}/ko/man1/*
 %lang(nl) %{_mandir}/nl/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+%doc %{_datadir}/%{name}/*
 
 %if %{with static}
 %files static
This page took 0.111137 seconds and 4 git commands to generate.