]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- release 2
[packages/bash.git] / bash.spec
index 44272e754af4c1dbe7047c39b6cea7311a10c813..6c1d9e04a22a21fecb4003084db6e6a323a96110 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -4,28 +4,25 @@
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
 #
-%define                ver             3.2
-%define                patchlevel      39
-%define                rel             1
+%define                ver             4.2
+#%%define              patchlevel      1
+%define                rel             2
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
 Name:          bash
-Version:       %{ver}.%{patchlevel}
+Version:       %{ver}%{?patchlevel:.%{patchlevel}}
 Release:       %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 00bfa16d58e034e3c2aa27f390390d30
+# Source0-md5: 3fb927c7c33022f1c327f14a81c0d4b0
 Source1:       %{name}rc
-Source2:       %{name}-skel-.%{name}_logout
-Source3:       %{name}-skel-.%{name}_profile
-Source4:       %{name}-skel-.%{name}rc
+Source2:       %{name}-skel-.bash_logout
+Source3:       %{name}-skel-.bash_profile
+Source4:       %{name}-skel-.bashrc
 Source5:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source5-md5: d2aacf89c4a444c5da648da69afdb01a
-# based on GNU TP; omitted: eo (not supported), rw (empty)
-Source6:       %{name}-translations.tar.bz2
-# Source6-md5: 99701bc1f919cfc527cb95fadbc66c93
 Patch0:                %{name}-paths.patch
 Patch1:                %{name}-security.patch
 Patch2:                %{name}-autoconf.patch
@@ -37,26 +34,24 @@ Patch8:             %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
+Patch12:       %{name}-pl.po-update.patch
+%{?patchlevel:%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash41-%03g 1 %{patchlevel}}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.429
+BuildRequires: readline-devel >= 6.2
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
 # Require static library only for static build
 BuildRequires: glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
-BuildRequires: readline-static >= 5.2
+BuildRequires: readline-static >= 6.2
 %endif
-Requires(post,preun):  grep
-Requires(preun):       fileutils
-Requires:      grep
-Requires:      readline >= 5.2
+Requires:      readline >= 6.2
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
 Obsoletes:     bash2
@@ -159,8 +154,6 @@ Tools specification (IEEE Working Group 1003.2).
 Summary:       Statically linked GNU Bourne Again Shell (bash)
 Summary(pl.UTF-8):     Statycznie skonsolidowany GNU Bourne Again Shell (bash)
 Group:         Applications/Shells
-Requires(post,preun):  grep
-Requires(preun):       fileutils
 Requires:      %{name} = %{version}-%{release}
 
 %description static
@@ -187,7 +180,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %prep
 %setup -q -n %{name}-%{ver} -a5
 # official patches
-%patchset_patch 1 %{patchlevel}
+%{?patchlevel:%patchset_patch 1 %{patchlevel}}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -199,8 +192,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
-tar xjf %SOURCE6 -C po
-sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
+%patch12 -p1
 
 %build
 cp -f /usr/share/automake/config.* support
@@ -256,21 +248,33 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
+# use our bugtracker, upstream will ignore reports from this anyway
+rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p %add_etc_shells -p /bin/sh /bin/ksh
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 
-%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post static -p %add_etc_shells -p /bin/bash.static
-%preun static -p %remove_etc_shells -p /bin/bash.static
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
@@ -283,7 +287,6 @@ os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 
 %attr(755,root,root) /bin/bash
 %attr(755,root,root) /bin/rbash
-%attr(755,root,root) %{_bindir}/bashbug
 
 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
 %{_infodir}/bash.info*
@@ -295,7 +298,8 @@ os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 %lang(ko) %{_mandir}/ko/man1/*
 %lang(nl) %{_mandir}/nl/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+%doc %{_datadir}/%{name}/*
 
 %if %{with static}
 %files static
This page took 0.032598 seconds and 4 git commands to generate.