]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
Up to 5.2.26
[packages/bash.git] / bash.spec
index b525f66633ba83e7e790100e64a2ae8f015892ed..50da2ab235a6fcb2e664b0b36c882d8e5d1b15a1 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -2,14 +2,14 @@
 # $ md5sum bash44-??? > sources
 #
 # Conditional build:
-%bcond_without static          # don't build static version
-%bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
-%bcond_without tests   # do not perform "make test"
+%bcond_without static          # static version
+%bcond_with    bash_history    # additional history in /var/log/bash_hist ;)
+%bcond_without tests           # unit testing
 
-%define                ver             5.0
-%define                patchlevel      18
+%define                ver             5.2
+%define                patchlevel      26
 %define                rel             1
-%define                min_readline    8.0
+%define                min_readline    8.2
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -18,8 +18,8 @@ Version:      %{ver}%{?patchlevel:.%{patchlevel}}
 Release:       %{rel}%{?with_bash_history:inv}
 License:       GPL v3+
 Group:         Applications/Shells
-Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 2b44b47b905be16f45709648f671820b
+Source0:       https://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
+# Source0-md5: cfb4cf795fc239667f187b3d6b3d396f
 Source1:       %{name}rc
 Source2:       %{name}-skel-.bash_logout
 Source3:       %{name}-skel-.bash_profile
@@ -38,9 +38,9 @@ Patch8:               %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
+%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.2-patches/bash52-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
-BuildRequires: autoconf >= 2.61
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
@@ -57,11 +57,13 @@ BuildRequires:      readline-static >= %{min_readline}
 Requires:      readline >= %{min_readline}
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
-Obsoletes:     bash2
-Obsoletes:     bash2-doc
+Obsoletes:     bash2 < 3
+Obsoletes:     bash2-doc < 3
 Obsoletes:     etcskel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoprovfiles        %{_libdir}/%{name}
+
 %description
 Bash is a GNU project sh-compatible shell or command language
 interpreter. Bash (Bourne Again shell) incorporates useful features
@@ -209,7 +211,7 @@ Pliki nagłówkowe do tworzenia wtyczek basha.
 %patch10 -p1
 %patch11 -p1
 
-sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
+%{__sed} -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
 %build
 cp -f /usr/share/automake/config.* support
@@ -233,7 +235,9 @@ for mode in %{?with_static:static} shared; do
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static
+if [ "$mode" = "static" ]; then
+       %{__mv} bash bash.static
+fi
 done
 
 %{?with_tests:%{__make} tests}
@@ -326,25 +330,34 @@ end
 
 # loadables
 %dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/accept
 %attr(755,root,root) %{_libdir}/%{name}/basename
+%attr(755,root,root) %{_libdir}/%{name}/csv
+%attr(755,root,root) %{_libdir}/%{name}/cut
 %attr(755,root,root) %{_libdir}/%{name}/dirname
+%attr(755,root,root) %{_libdir}/%{name}/dsv
 %attr(755,root,root) %{_libdir}/%{name}/fdflags
 %attr(755,root,root) %{_libdir}/%{name}/finfo
+%attr(755,root,root) %{_libdir}/%{name}/getconf
 %attr(755,root,root) %{_libdir}/%{name}/head
 %attr(755,root,root) %{_libdir}/%{name}/id
 %attr(755,root,root) %{_libdir}/%{name}/ln
 %attr(755,root,root) %{_libdir}/%{name}/logname
 %attr(755,root,root) %{_libdir}/%{name}/mkdir
+%attr(755,root,root) %{_libdir}/%{name}/mkfifo
+%attr(755,root,root) %{_libdir}/%{name}/mktemp
 %attr(755,root,root) %{_libdir}/%{name}/mypid
 %attr(755,root,root) %{_libdir}/%{name}/pathchk
 %attr(755,root,root) %{_libdir}/%{name}/print
 %attr(755,root,root) %{_libdir}/%{name}/printenv
 %attr(755,root,root) %{_libdir}/%{name}/push
 %attr(755,root,root) %{_libdir}/%{name}/realpath
+%attr(755,root,root) %{_libdir}/%{name}/rm
 %attr(755,root,root) %{_libdir}/%{name}/rmdir
 %attr(755,root,root) %{_libdir}/%{name}/seq
 %attr(755,root,root) %{_libdir}/%{name}/setpgid
 %attr(755,root,root) %{_libdir}/%{name}/sleep
+%attr(755,root,root) %{_libdir}/%{name}/stat
 %attr(755,root,root) %{_libdir}/%{name}/strftime
 %attr(755,root,root) %{_libdir}/%{name}/sync
 %attr(755,root,root) %{_libdir}/%{name}/tee
@@ -365,5 +378,6 @@ end
 %{_includedir}/bash
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/Makefile.inc
+%{_libdir}/%{name}/Makefile.sample
 %{_libdir}/%{name}/loadables.h
 %{_pkgconfigdir}/bash.pc
This page took 0.085337 seconds and 4 git commands to generate.