]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- updated to 3.2.48
[packages/bash.git] / bash.spec
index fd77b0edda16776245c31a2cadbe79fad3f2005d..4696d9bd945c1927c2fb8195b10dfca2d33a9aa1 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             3.2
-%define                patchlevel      39
+%define                patchlevel      48
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
@@ -44,7 +44,7 @@ BuildRequires:        automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.429
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
@@ -259,16 +259,25 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p %add_etc_shells -p /bin/sh /bin/ksh
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 
-%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post static -p %add_etc_shells -p /bin/bash.static
-%preun static -p %remove_etc_shells -p /bin/bash.static
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
This page took 0.037293 seconds and 4 git commands to generate.