]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- updated to 3.2.48
[packages/bash.git] / bash.spec
index 982986f25d1edc6a8a61d4ebf00e73ecfe44e9aa..4696d9bd945c1927c2fb8195b10dfca2d33a9aa1 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,8 +5,8 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             3.2
-%define                patchlevel      33
-%define                rel             2
+%define                patchlevel      48
+%define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -36,6 +36,7 @@ Patch6:               %{name}-compat.patch
 Patch8:                %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
+Patch11:       %{name}-elinks_cont.patch
 %patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
@@ -43,7 +44,7 @@ BuildRequires:        automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.353
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
@@ -52,9 +53,6 @@ BuildRequires:        glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
 BuildRequires: readline-static >= 5.2
 %endif
-Requires(post,preun):  grep
-Requires(preun):       fileutils
-Requires:      grep
 Requires:      readline >= 5.2
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
@@ -158,8 +156,6 @@ Tools specification (IEEE Working Group 1003.2).
 Summary:       Statically linked GNU Bourne Again Shell (bash)
 Summary(pl.UTF-8):     Statycznie skonsolidowany GNU Bourne Again Shell (bash)
 Group:         Applications/Shells
-Requires(post,preun):  grep
-Requires(preun):       fileutils
 Requires:      %{name} = %{version}-%{release}
 
 %description static
@@ -197,6 +193,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch8 -p1
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
+%patch11 -p1
 tar xjf %SOURCE6 -C po
 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
 
@@ -254,54 +251,34 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
+# use our bugtracker, upstream will ignore reports from this anyway
+rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash" > /etc/shells
-       echo "/bin/rbash" >> /etc/shells
-else
-       if ! grep -q '^/bin/bash$' /etc/shells; then
-               echo "/bin/bash" >> /etc/shells
-       fi
-       if ! grep -q '^/bin/rbash$' /etc/shells; then
-               echo "/bin/rbash" >> /etc/shells
-       fi
-fi
-
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%preun
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
-
-%post static
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash.static" > /etc/shells
-else
-       if ! grep -q '^/bin/bash.static$' /etc/shells; then
-               echo "/bin/bash.static" >> /etc/shells
-       fi
-fi
-
-%preun static
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash.static /etc/shells > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
+os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
+
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc CHANGES NEWS README doc/{FAQ,INTRO}
@@ -313,7 +290,6 @@ fi
 
 %attr(755,root,root) /bin/bash
 %attr(755,root,root) /bin/rbash
-%attr(755,root,root) %{_bindir}/bashbug
 
 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
 %{_infodir}/bash.info*
This page took 0.056739 seconds and 4 git commands to generate.