]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- updated to 3.2.48
[packages/bash.git] / bash.spec
index 043431d79896c6c5926b3239a0508cf058f39393..4696d9bd945c1927c2fb8195b10dfca2d33a9aa1 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             3.2
-%define                patchlevel      39
+%define                patchlevel      48
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
@@ -44,7 +44,7 @@ BuildRequires:        automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.429
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
@@ -53,9 +53,6 @@ BuildRequires:        glibc-static >= 2.2
 BuildRequires: ncurses-static >= 5.2
 BuildRequires: readline-static >= 5.2
 %endif
-Requires(post,preun):  grep
-Requires(preun):       fileutils
-Requires:      grep
 Requires:      readline >= 5.2
 Requires:      setup >= 2.4.6-2
 Obsoletes:     bash-doc
@@ -159,8 +156,6 @@ Tools specification (IEEE Working Group 1003.2).
 Summary:       Statically linked GNU Bourne Again Shell (bash)
 Summary(pl.UTF-8):     Statycznie skonsolidowany GNU Bourne Again Shell (bash)
 Group:         Applications/Shells
-Requires(post,preun):  grep
-Requires(preun):       fileutils
 Requires:      %{name} = %{version}-%{release}
 
 %description static
@@ -256,35 +251,33 @@ install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
+# use our bugtracker, upstream will ignore reports from this anyway
+rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash" > /etc/shells
-       echo "/bin/rbash" >> /etc/shells
-else
-       if ! grep -q '^/bin/bash$' /etc/shells; then
-               echo "/bin/bash" >> /etc/shells
-       fi
-       if ! grep -q '^/bin/rbash$' /etc/shells; then
-               echo "/bin/rbash" >> /etc/shells
-       fi
-fi
-
-# XXX need this in lua
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
+os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
+
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post static -p %add_etc_shells -p /bin/bash.static
-%preun static -p %remove_etc_shells -p /bin/bash.static
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
@@ -297,7 +290,6 @@ fi
 
 %attr(755,root,root) /bin/bash
 %attr(755,root,root) /bin/rbash
-%attr(755,root,root) %{_bindir}/bashbug
 
 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
 %{_infodir}/bash.info*
This page took 0.085048 seconds and 4 git commands to generate.