]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- partial /etc/shells edit with lua
[packages/bash.git] / bash.spec
index eddc34ba684afee1b994676be9fe1c4e3ea78856..043431d79896c6c5926b3239a0508cf058f39393 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -4,18 +4,18 @@
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
 #
-%define                _ver            3.2
-%define                _patchlevel     25
-%define                _rel            2
+%define                ver             3.2
+%define                patchlevel      39
+%define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
 Name:          bash
-Version:       %{_ver}.%{_patchlevel}
-Release:       %{_rel}%{?with_bash_history:inv}
+Version:       %{ver}.%{patchlevel}
+Release:       %{rel}%{?with_bash_history:inv}
 License:       GPL
 Group:         Applications/Shells
-Source0:       ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
+Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
 # Source0-md5: 00bfa16d58e034e3c2aa27f390390d30
 Source1:       %{name}rc
 Source2:       %{name}-skel-.%{name}_logout
@@ -36,14 +36,15 @@ Patch6:             %{name}-compat.patch
 Patch8:                %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
-%patchset_source -f ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{_patchlevel}
+Patch11:       %{name}-elinks_cont.patch
+%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.353
+BuildRequires: rpmbuild(macros) >= 1.429
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
@@ -184,9 +185,9 @@ Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
 tym pakiecie jest wersja basha skonsolidowana statycznie.
 
 %prep
-%setup -q -n %{name}-%{_ver} -a5
+%setup -q -n %{name}-%{ver} -a5
 # official patches
-%patchset_patch 1 %{_patchlevel}
+%patchset_patch 1 %{patchlevel}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -197,6 +198,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch8 -p1
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
+%patch11 -p1
 tar xjf %SOURCE6 -C po
 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
 
@@ -273,35 +275,17 @@ else
        fi
 fi
 
+# XXX need this in lua
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
-
-%post static
-umask 022
-if [ ! -f /etc/shells ]; then
-       echo "/bin/bash.static" > /etc/shells
-else
-       if ! grep -q '^/bin/bash.static$' /etc/shells; then
-               echo "/bin/bash.static" >> /etc/shells
-       fi
-fi
-
-%preun static
-if [ "$1" = "0" ]; then
-       umask 022
-       grep -v /bin/bash.static /etc/shells > /etc/shells.new
-       mv -f /etc/shells.new /etc/shells
-fi
+%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post static -p %add_etc_shells -p /bin/bash.static
+%preun static -p %remove_etc_shells -p /bin/bash.static
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc CHANGES NEWS README doc/{FAQ,INTRO}
This page took 0.049626 seconds and 4 git commands to generate.