]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
Up to 5.2.26
[packages/bash.git] / bash.spec
1 # NOTE: when updating patchlevel, do not forget to update 'sources' file:
2 # $ md5sum bash44-??? > sources
3 #
4 # Conditional build:
5 %bcond_without  static          # don't build static version
6 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
7 %bcond_without  tests   # do not perform "make test"
8
9 %define         ver             4.4
10 %define         patchlevel      23
11 %define         rel             1
12 Summary:        GNU Bourne Again Shell (bash)
13 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
14 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
15 Name:           bash
16 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
17 Release:        %{rel}%{?with_bash_history:inv}
18 License:        GPL v3+
19 Group:          Applications/Shells
20 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
21 # Source0-md5:  148888a7c95ac23705559b6f477dfe25
22 Source1:        %{name}rc
23 Source2:        %{name}-skel-.bash_logout
24 Source3:        %{name}-skel-.bash_profile
25 Source4:        %{name}-skel-.bashrc
26 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
27 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
28 Patch0:         %{name}-paths.patch
29 Patch1:         %{name}-security.patch
30 Patch2:         %{name}-autoconf.patch
31 Patch3:         %{name}-info.patch
32 Patch4:         %{name}-profile.patch
33 Patch5:         %{name}-requires.patch
34 Patch6:         %{name}-compat.patch
35 Patch8:         %{name}-sighup.patch
36 Patch9:         %{name}-backup_history.patch
37 Patch10:        %{name}-act_like_sh.patch
38 Patch11:        %{name}-elinks_cont.patch
39 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.4-patches/bash44-%03g 1 %{patchlevel}
40 URL:            http://www.gnu.org/software/bash/
41 BuildRequires:  autoconf >= 2.61
42 BuildRequires:  automake
43 BuildRequires:  bison
44 BuildRequires:  ncurses-devel >= 5.2
45 BuildRequires:  readline-devel >= 7.0
46 BuildRequires:  rpmbuild(macros) >= 1.462
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  texinfo
49 %if %{with static}
50 # Require static library only for static build
51 BuildRequires:  glibc-static >= 2.2
52 BuildRequires:  ncurses-static >= 5.2
53 BuildRequires:  readline-static >= 7.0
54 %endif
55 Requires:       readline >= 7.0
56 Requires:       setup >= 2.4.6-2
57 Obsoletes:      bash-doc
58 Obsoletes:      bash2
59 Obsoletes:      bash2-doc
60 Obsoletes:      etcskel
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Bash is a GNU project sh-compatible shell or command language
65 interpreter. Bash (Bourne Again shell) incorporates useful features
66 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
67 be run by bash without modification. Bash offers several improvements
68 over sh, including command line editing, unlimited size command
69 history, job control, shell functions and aliases, indexed arrays of
70 unlimited size and integer arithmetic in any base from two to 64. Bash
71 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
72 Shell and Tools standard. Bash is the default shell for Linux
73 Mandrake. You should install bash because of its popularity and power.
74 You'll probably end up using it.
75
76 %description -l es.UTF-8
77 Bash es un interpretador de comandos compatible con sh, que ejecuta
78 comandos leídos de la entrada padrón o de un archivo. Bash también
79 incorpora características útiles de las shells Korn y C (ksh y csh).
80 Bash ha sido desarrollado para ser una adición compatible con la
81 especificación IEEE Posix para shells y herramientas (IEEE Working
82 Group 1003.2).
83
84 %description -l de.UTF-8
85 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
86 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
87 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
88 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
89 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
90 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
91 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
92 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
93 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
94 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
95 Mandrake.
96
97 %description -l fr.UTF-8
98 Bash est un shell (interpréteur de commande) du projet GNU, compatible
99 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
100 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
101 plupart des scripts sh sont exécutables sans modifications. Bash
102 comprend nombre d'améliorations par rapport à sh : édition de la ligne
103 de commande, historique illimité, contrôle des processus
104 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
105 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
106 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
107 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
108 l'installer du fait de sa puissance et de sa popularité. Vous finirez
109 probablement par l'utiliser.
110
111 %description -l pl.UTF-8
112 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
113 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
114 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
115 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
116 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
117 historii poleceń, funkcje i aliasy, indeksowane tablice
118 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
119 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
120 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
121
122 %description -l pt_BR.UTF-8
123 Bash é um interpretador de comandos compatível com sh, que executa
124 comandos lidos da entrada padrão ou de um arquivo. Bash também
125 incorpora características úteis das shells Korn e C (ksh e csh). Bash
126 tem sido desenvolvido para ser uma implementação compatível com a
127 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
128 1003.2).
129
130 %description -l ru.UTF-8
131 Bash - это sh-совместимый интерпретатор командного языка (shell),
132 исполняющий команды, поступающие со стандартного ввода или из файла.
133 Bash включает полезные расширения из интерпретаторов Korn и C shell
134 (ksh и csh).
135
136 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
137 Tools specification (IEEE Working Group 1003.2).
138
139 %description -l tr.UTF-8
140 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
141 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
142 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
143 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
144 uyumlu bir uygulama olarak tasarlanmıştır.
145
146 %description -l uk.UTF-8
147 Bash - це sh-сумістний інтерпретатор командної мови (shell),
148 виконуючий команди зі стандартного вводу або з файла. Bash містить
149 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
150
151 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
152 Tools specification (IEEE Working Group 1003.2).
153
154 %package static
155 Summary:        Statically linked GNU Bourne Again Shell (bash)
156 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
157 Group:          Applications/Shells
158 Requires:       %{name} = %{version}-%{release}
159
160 %description static
161 Bash is a GNU project sh-compatible shell or command language
162 interpreter. Bash (Bourne Again shell) incorporates useful features
163 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
164 be run by bash without modification. Bash offers several improvements
165 over sh, including command line editing, unlimited size command
166 history, job control, shell functions and aliases, indexed arrays of
167 unlimited size and integer arithmetic in any base from two to 64. Bash
168 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
169 Shell and Tools standard. Bash is the default shell for Linux
170 Mandrake. You should install bash because of its popularity and power.
171 You'll probably end up using it. This package contains statically
172 linked version of bash.
173
174 %description static -l pl.UTF-8
175 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
176 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
177 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
178 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
179 tym pakiecie jest wersja basha skonsolidowana statycznie.
180
181 %package devel
182 Summary:        Header files for bash plugins development
183 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek basha
184 Group:          Development/Libraries
185 # doesn't require base
186
187 %description devel
188 Header files for bash plugins development.
189
190 %description devel -l pl.UTF-8
191 Pliki nagłówkowe do tworzenia wtyczek basha.
192
193 %prep
194 %setup -q -n %{name}-%{ver} -a5
195 # official patches
196 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
197 %patch0 -p1
198 %patch1 -p1
199 %patch2 -p1
200 %patch3 -p1
201 %patch4 -p1
202 %patch5 -p1
203 %patch6 -p1
204 %patch8 -p1
205 %{?with_bash_history:%patch9 -p1}
206 %patch10 -p1
207 %patch11 -p1
208
209 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
210
211 %build
212 cp -f /usr/share/automake/config.* support
213 %{__autoconf}
214 for mode in %{?with_static:static} shared; do
215 %configure \
216         --enable-alias \
217         --enable-help-builtin \
218         --enable-history \
219         --enable-job-control \
220         --enable-restricted \
221         --enable-readline \
222         --with-curses \
223         --enable-extended-glob \
224         --enable-dparen-arithmetic \
225         --enable-separate-helpfiles \
226         --without-bash-malloc \
227         $([ "$mode" = "static" ] && echo "--enable-static-link") \
228         --with-installed-readline
229
230 %{__make} \
231         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
232
233 [ "$mode" = "static" ] && mv -f bash bash.static
234 done
235
236 %{?with_tests:%{__make} tests}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
241 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
242
243 %{__make} install \
244         DESTDIR=$RPM_BUILD_ROOT
245
246 %{__mv} $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
247 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
248
249 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
250 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
251
252 for d in es fr it ja ko nl pl ; do
253         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
254         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
255         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
256 done
257
258 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
259
260 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
261 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
262 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
263
264 # use our bugtracker, upstream will ignore reports from this anyway
265 %{__rm} $RPM_BUILD_ROOT%{_bindir}/bashbug \
266         $RPM_BUILD_ROOT%{_mandir}/man1/bashbug.1 \
267         $RPM_BUILD_ROOT%{_mandir}/*/man1/bashbug.1
268 # packaged as %doc
269 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bash
270
271 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
272
273 %find_lang %{name}
274
275 %clean
276 rm -rf $RPM_BUILD_ROOT
277
278 %post   -p <lua>
279 %lua_add_etc_shells /bin/bash /bin/rbash
280 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
281
282 %preun  -p <lua>
283 if arg[2] == 0 then
284         %lua_remove_etc_shells /bin/bash /bin/rbash
285 end
286
287 %postun -p /sbin/postshell
288 -/usr/sbin/fix-info-dir -c %{_infodir}
289
290 %post static -p <lua>
291 %lua_add_etc_shells /bin/bash.static
292
293 %preun static -p <lua>
294 if arg[2] == 0 then
295         %lua_remove_etc_shells /bin/bash.static
296 end
297
298 %files -f %{name}.lang
299 %defattr(644,root,root,755)
300 %doc AUTHORS CHANGES COMPAT NEWS POSIX README RBASH doc/{FAQ,INTRO,bash.html,bashref.html} 
301
302 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
303 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
304 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
305 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
306
307 %attr(755,root,root) /bin/bash
308 %attr(755,root,root) /bin/rbash
309
310 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
311 %{_infodir}/bash.info*
312 %{_mandir}/man1/bash.1*
313 %{_mandir}/man1/rbash.1*
314 %lang(es) %{_mandir}/es/man1/*
315 %lang(fr) %{_mandir}/fr/man1/*
316 %lang(it) %{_mandir}/it/man1/*
317 %lang(ja) %{_mandir}/ja/man1/*
318 %lang(ko) %{_mandir}/ko/man1/*
319 %lang(nl) %{_mandir}/nl/man1/*
320 %lang(pl) %{_mandir}/pl/man1/*
321 %dir %{_datadir}/%{name}
322 %doc %{_datadir}/%{name}/*
323
324 # loadables
325 %dir %{_libdir}/%{name}
326 %attr(755,root,root) %{_libdir}/%{name}/basename
327 %attr(755,root,root) %{_libdir}/%{name}/dirname
328 %attr(755,root,root) %{_libdir}/%{name}/finfo
329 %attr(755,root,root) %{_libdir}/%{name}/head
330 %attr(755,root,root) %{_libdir}/%{name}/id
331 %attr(755,root,root) %{_libdir}/%{name}/ln
332 %attr(755,root,root) %{_libdir}/%{name}/logname
333 %attr(755,root,root) %{_libdir}/%{name}/mkdir
334 %attr(755,root,root) %{_libdir}/%{name}/mypid
335 %attr(755,root,root) %{_libdir}/%{name}/pathchk
336 %attr(755,root,root) %{_libdir}/%{name}/print
337 %attr(755,root,root) %{_libdir}/%{name}/printenv
338 %attr(755,root,root) %{_libdir}/%{name}/push
339 %attr(755,root,root) %{_libdir}/%{name}/realpath
340 %attr(755,root,root) %{_libdir}/%{name}/rmdir
341 %attr(755,root,root) %{_libdir}/%{name}/setpgid
342 %attr(755,root,root) %{_libdir}/%{name}/sleep
343 %attr(755,root,root) %{_libdir}/%{name}/strftime
344 %attr(755,root,root) %{_libdir}/%{name}/sync
345 %attr(755,root,root) %{_libdir}/%{name}/tee
346 %attr(755,root,root) %{_libdir}/%{name}/truefalse
347 %attr(755,root,root) %{_libdir}/%{name}/tty
348 %attr(755,root,root) %{_libdir}/%{name}/uname
349 %attr(755,root,root) %{_libdir}/%{name}/unlink
350 %attr(755,root,root) %{_libdir}/%{name}/whoami
351
352 %if %{with static}
353 %files static
354 %defattr(644,root,root,755)
355 %attr(755,root,root) /bin/bash.static
356 %endif
357
358 %files devel
359 %defattr(644,root,root,755)
360 %{_includedir}/bash
361 %dir %{_libdir}/%{name}
362 %dir %{_libdir}/%{name}/Makefile.inc
363 %{_pkgconfigdir}/bash.pc
This page took 0.080083 seconds and 3 git commands to generate.