]> git.pld-linux.org Git - packages/bash-completion.git/commitdiff
- skip sed run for ps output filtering auto/th/bash-completion-1_0-3
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 23 May 2009 22:14:15 +0000 (22:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash-completion-psheader.patch -> 1.1
    bash-completion.spec -> 1.149

bash-completion-psheader.patch [new file with mode: 0644]
bash-completion.spec

diff --git a/bash-completion-psheader.patch b/bash-completion-psheader.patch
new file mode 100644 (file)
index 0000000..70d481b
--- /dev/null
@@ -0,0 +1,31 @@
+--- bash-completion/bash_completion~   2009-05-24 01:07:50.000000000 +0300
++++ bash-completion/bash_completion    2009-05-24 01:12:42.638288264 +0300
+@@ -447,7 +447,7 @@
+ } ||
+ _pids()
+ {
+-      COMPREPLY=( $( compgen -W '$( command ps axo pid | sed 1d )' -- $cur ) )
++      COMPREPLY=( $( compgen -W '$( command ps axo pid= )' -- $cur ) )
+ }
+ # This function completes on process group IDs.
+@@ -459,7 +459,7 @@
+ } ||
+ _pgids()
+ {
+-      COMPREPLY=( $( compgen -W '$( command ps axo pgid | sed 1d )' -- $cur ))
++      COMPREPLY=( $( compgen -W '$( command ps axo pgid= )' -- $cur ))
+ }
+ # This function completes on process names.
+@@ -482,8 +482,8 @@
+       # for now.
+       # Not using "ps axo comm" because under some Linux kernels, it
+       # truncates command names (see e.g. http://bugs.debian.org/497540#19)
+-      COMPREPLY=( $( compgen -W '$( command ps axo command | \
+-                                 sed -e "1d; s/ .*//; s:.*/::; s/:$//;" \
++      COMPREPLY=( $( compgen -W '$( command ps axo command= | \
++                                 sed -e "s/ .*//; s:.*/::; s/:$//;" \
+                                      -e "s/^[[(-]//; s/[])]$//" \
+                                      -e "s/^<defunct>$//")' \
+                                  -- $cur ) )
index f17b84e26b78a08c65af574b7e0d6c6b011831f6..cedfba1dafc5c357f650785bb11186aee993c378 100644 (file)
@@ -18,6 +18,7 @@ Source2:      %{name}.sh
 Patch0:                %{name}-rpm-cache.patch
 Patch1:                %{name}-mplayer.patch
 Patch2:                %{name}-service.patch
+Patch3:                %{name}-psheader.patch
 URL:           http://bash-completion.alioth.debian.org/
 Requires(triggerpostun):       sed >= 4.0
 Requires:      bash >= 2.05a-3
@@ -40,6 +41,7 @@ kompletowanie parametrów linii poleceń.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 cp -a %{SOURCE1} contrib/poldek
 
 # cleanup backups after patching
This page took 0.115172 seconds and 4 git commands to generate.