]> git.pld-linux.org Git - packages/bash-completion-vserver.git/commitdiff
- fixed formerly broken completion function auto/th/bash-completion-vserver-0.4.1-2
authorAdam Osuchowski <adwol@pld-linux.org>
Fri, 31 Mar 2017 18:28:21 +0000 (20:28 +0200)
committerAdam Osuchowski <adwol@pld-linux.org>
Fri, 31 Mar 2017 18:28:21 +0000 (20:28 +0200)
bash-completion-vserver.sh
bash-completion-vserver.spec

index 21153c5130e0c7d5239665c2f109d573ddc0a18b..1541161f8bab80aa0172f2df126ab6bc8507eebe 100644 (file)
@@ -182,7 +182,7 @@ _vserver() {
                                COMPREPLY=( $( compgen -W "build" -- $cur ) )
                        fi
                else
-                       COMPREPLY=( $( compgen -W "${names[@]} $cmdOpts" -- $cur ) )
+                       COMPREPLY=( $( compgen -W "${names[*]} $cmdOpts" -- $cur ) )
                fi
                return 0
        fi
@@ -240,10 +240,10 @@ _vapt_rpm_yum()
                                COMPREPLY=( $( compgen -W "$cmdOpts" -- $cur ) )
                        else
                                cmdOpts='--'
-                               COMPREPLY=( $( compgen -W "${names[@]} $cmdOpts" -- $cur ) )
+                               COMPREPLY=( $( compgen -W "${names[*]} $cmdOpts" -- $cur ) )
                        fi
                else
-                       COMPREPLY=( $( compgen -W "${names[@]} $cmdOpts" -- $cur ) )
+                       COMPREPLY=( $( compgen -W "${names[*]} $cmdOpts" -- $cur ) )
                fi
        fi
        return 0
@@ -292,7 +292,7 @@ _vserver_copy()
        if (( $i < ${#COMP_WORDS[@]}-1 )) ; then
                return 0
        else
-               COMPREPLY=( $( compgen -W "${names[@]} $cmdOpts" -- $cur ) )
+               COMPREPLY=( $( compgen -W "${names[*]} $cmdOpts" -- $cur ) )
        fi
        return 0
 }
index 514f64bd6015d2e52584d91b9453f61a8e74ed1a..b16e983224d480d59f4c4f3d81174451c88369a7 100644 (file)
@@ -3,7 +3,7 @@
 Summary:       bash-completion for vserver command
 Name:          bash-completion-vserver
 Version:       0.4.1
-Release:       1
+Release:       2
 License:       GPL
 Group:         Applications/Shells
 Source0:       %{name}.sh
This page took 0.144219 seconds and 4 git commands to generate.