]> git.pld-linux.org Git - packages/barnyard2.git/commitdiff
- avoid epoch bump when 1.10 release is made (move beta component to release)
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 27 Oct 2011 15:46:37 +0000 (15:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- /etc/{sysconfig,rc.d/init.d} may not macroized with sysconfdir
- cleanup clean
- config noreplace and verify not attrs for config file
- undepend on github hash in prep
- normalize tarball name for distfiles

Changed files:
    barnyard2.spec -> 1.3

barnyard2.spec

index 1ef51b464514d72491984e51501f541f9368d8d4..0fc674a3f5ac075982e397719a5274d8ac050e9a 100644 (file)
@@ -3,13 +3,15 @@
 %bcond_without  mysql          # don't build support for MySQL
 %bcond_without postgresql      # don't build support for PostgreSQL
 
+%define                subver  beta2
+%define                rel             1
 Summary:       Snort Log Backend
 Name:          barnyard2
-Version:       1.10beta2
-Release:       1
+Version:       1.10
+Release:       0.%{subver}.%{rel}
 License:       GPL
 Group:         Networking
-Source0:       https://github.com/firnsy/barnyard2/tarball/v2-1.10-beta2
+Source0:       https://github.com/firnsy/barnyard2/tarball/v2-%{version}-%{subver}/%{name}-%{version}.tar.gz
 # Source0-md5: af417a3491c5a4e5605c8fbd529f2255
 Source2:       %{name}.config
 Source3:       %{name}
@@ -27,18 +29,20 @@ appears. Continual mode w/ checkpointing will also use a checkpoint
 file (or waldo file in the snort world) to track where it is. In the
 event the barnyard process ends while a waldo file is in use, barnyard
 will resume processing at the last entry as listed in the waldo file.
+
 %{?with_mysql:barnyard2 binary compiled with mysql support.}
 %{?with_postgresql:barnyard2 binary compiled with postgresql support.}
 
 %prep
-%setup -q -n firnsy-%{name}-5832a85
-
+%setup -qc
+mv firnsy-%{name}-*/* .
 
 %build
 ./autogen.sh
-%configure --sysconfdir=%{_sysconfdir}/snort  \
+%configure \
+       --sysconfdir=%{_sysconfdir}/snort \
        %{?with_postgresql:--with-postgresql} \
-       %{?with_mysql:--with-mysql-libraries=/usr/%{_lib}} \
+       %{?with_mysql:--with-mysql-libraries=%{_libdir}} \
 
 %{__make}
 
@@ -48,24 +52,22 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,rc.d/init.d,snort}
-install -d -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/contrib
+install -d -p $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
+install -d -p $RPM_BUILD_ROOT%{_sysconfdir}/snort
+install -d -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{doc,contrib}
 install -d -p $RPM_BUILD_ROOT%{_mandir}/man8
-install -d -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc
-install etc/barnyard2.conf $RPM_BUILD_ROOT%{_sysconfdir}/snort/
-install $RPM_SOURCE_DIR/barnyard2.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/barnyard2
-install $RPM_SOURCE_DIR/barnyard2 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/barnyard2
-install doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/
+cp -p etc/barnyard2.conf $RPM_BUILD_ROOT%{_sysconfdir}/snort
+cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/barnyard2
+install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/barnyard2
+cp -p doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc
 
 %clean
-if [ -d $RPM_BUILD_ROOT ] && [ "$RPM_BUILD_ROOT" != "/"  ] ; then
-       rm -rf $RPM_BUILD_ROOT
-fi
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE doc/
-%attr(755,root,root) %{_bindir}/barnyard2
-%attr(640,root,root) %config %{_sysconfdir}/snort/barnyard2.conf
-%attr(754,root,root) %config /etc/rc.d/init.d/barnyard2
+%doc LICENSE doc
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snort/barnyard2.conf
+%attr(754,root,root) /etc/rc.d/init.d/barnyard2
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/barnyard2
+%attr(755,root,root) %{_bindir}/barnyard2
This page took 0.114867 seconds and 4 git commands to generate.