]> git.pld-linux.org Git - packages/balsa.git/blobdiff - balsa.spec
- build balsa without id lang; msgfmt id.po throws:
[packages/balsa.git] / balsa.spec
index b18e59eb28c9291200d26d6cc29d66331952f391..21f63a4d385fc51670fcc5cf16ae841eb76e2588 100644 (file)
@@ -1,81 +1,93 @@
 #
 # Conditional build:
-# --without ldap
-# --without gpgme              # experimental.
-# --without esmtp
-# --without gtkhtml
-
-%define                snap    20030630
-
-Summary:       balsa - GNOME e-Mail program
-Summary(pl):   Klient poczty dla GNOME z silnikiem mutt-a
-Summary(es):   Balsa es un lector de e-mail. Usa el toolkit GTK
-Summary(pt_BR):        Balsa é um leitor de e-mail. Usa o toolkit GTK
+%bcond_without ldap            # build without LDAP support
+%bcond_with    gpgme           # build with GPG support (experimental)
+%bcond_without esmtp           # build without ESMTP support
+%bcond_without gtkhtml         # build without HTML support
+#
+Summary:       Balsa Mail Client
+Summary(es.UTF-8):     Balsa es un lector de e-mail
+Summary(pl.UTF-8):     Balsa - klient poczty
+Summary(pt_BR.UTF-8):  Balsa é um leitor de e-mail
 Name:          balsa
-Version:       2.0.15
-#Release:      1.%{snap}
-Release:       1
+Version:       2.3.5
+Release:       2
 License:       GPL
 Group:         X11/Applications
 Source0:       http://balsa.gnome.org/%{name}-%{version}.tar.bz2
-# Source0-md5: dc00a4bd622c4a0c5d6b7dca397d4371
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
-#Patch0:               %{name}-libtool_hack.patch
+# Source0-md5: ccc5f1f11028dd604c6dac97017a1274
+Patch0:                %{name}-locale-names.patch
 Patch1:                %{name}-desktop.patch
+Patch2:                %{name}-includes.patch
+Patch3:                %{name}-no_hooks.patch
 URL:           http://balsa.gnome.org/
-BuildRequires: autoconf
+BuildRequires: ORBit2-devel >= 1:2.12.4
+BuildRequires: aspell-devel >= 2:0.50
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
-%{!?_without_esmtp:BuildRequires:      libesmtp-devel}
+BuildRequires: heimdal-devel
+%{?with_esmtp:BuildRequires:   libesmtp-devel}
 BuildRequires: libgnomeprintui-devel >= 1.106.0
-%{!?_without_gpgme:BuildRequires:      gpgme-devel >= 0.3.14}
-BuildRequires: gtk+2-devel >= 2.2.0
-%{!?_without_gtkhtml:BuildRequires:    libgtkhtml-devel}
+BuildRequires: glib2-devel >= 2.6.4-1
+BuildRequires: gmime-devel >= 2.1.9
+%{?with_gpgme:BuildRequires:   gpgme-devel >= 1:0.9.0}
+BuildRequires: gtk+2-devel >= 2:2.2.0
+BuildRequires: intltool
+%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.0}
 BuildRequires: libltdl-devel
-BuildRequires: libgnome-devel
+BuildRequires: libgnomeprintui-devel >= 2.1.4
 BuildRequires: libgnomeui-devel >= 2.3.3.1-2
-%{!?_without_ldap:BuildRequires:       openldap-devel}
-BuildRequires: aspell-devel >= 0.50
-BuildRequires: xft-devel
-Requires:      gpgme >= 0.3.14
+BuildRequires: libtool
+%{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: pcre-devel >= 3.0
+BuildRequires: rpmbuild(macros) >= 1.197
+BuildRequires: scrollkeeper >= 0.1.4
+%{?with_gpgme:Requires:        gpgme >= 1:0.9.0}
+Requires(post,postun): scrollkeeper
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-e-Mail program for the GNOME desktop, supporting local mailboxes, POP3
-and IMAP. GNOME is the GNU Network Object Model Environment. That's a
-fancy name but really GNOME is a nice GUI desktop environment. It
-makes using your computer easy, powerful, and easy to configure.
+Balsa is an e-mail reader.  This client is part of the GNOME
+desktop environment.  It supports local mailboxes, POP3 and
+IMAP.
 
-%description -l es
+%description -l es.UTF-8
 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
-cajas de correo electrónico locales, POP3 y IMAP.
+cajas de correo electrónico locales, POP3 y IMAP.
 
-%description -l pl
-Balsa to klient e-mail dla ¶rodowiska GNOME. Obs³uguje POP3, IMAP oraz
-lokalne skrzynki pocztowe. GNOME to Network Object Model Environment.
-Mimo osobliwej nazwy jest to naprawdê estetyczne ¶rodowisko graficzne.
-Dziêki niemu u¿ywanie komputera jest ³atwiejsze; system jest
-potê¿niejszy i ³atwo go skonfigurowaæ.
+%description -l pl.UTF-8
+Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
+IMAP oraz lokalne skrzynki pocztowe. 
 
-%description -l pt_BR
-Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
+%description -l pt_BR.UTF-8
+Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
 Suporta caixas de correio locais, POP3 a IMAP.
 
 %prep
 %setup -q
-#%patch0 -p1
+%patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+rm -f po/no.{po,gmo}
 
 %build
-#./autogen.sh
+%{__intltoolize}
+%{__glib_gettextize}
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__autoconf}
 %configure \
+       --with-gss \
        --with-ssl \
-       %{?_without_esmtp:--without-esmtp} \
-       %{!?_without_gtkhtml:--enable-gtkhtml} \
-       %{?_without_gtkhtml:--disable-gtkhtml}\
-       %{?_without_gpgme:--without-gpgme} \
-       %{!?_without_ldap:--with-ldap} \
-       %{?_without_ldap:--without-ldap}
-
+       %{!?with_esmtp:--without-esmtp} \
+       %{!?with_gtkhtml:--disable-gtkhtml}\
+       %{?with_gpgme:--with-gpgme} \
+       %{?with_ldap:--with-ldap}
 %{__make}
 
 %install
@@ -89,7 +101,11 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /usr/bin/scrollkeeper-update
+%post
+%scrollkeeper_update_post
+
+%postun
+%scrollkeeper_update_postun
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
@@ -98,7 +114,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/sound/events/*
 %{_datadir}/%{name}
 %{_datadir}/sounds/%{name}
+%{_libdir}/bonobo/servers/*.server
+%{_datadir}/idl/*.idl
 %{_mandir}/man1/*
 %{_omf_dest_dir}/%{name}
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
+%{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.196028 seconds and 4 git commands to generate.