]> git.pld-linux.org Git - packages/bakefile.git/commitdiff
- added versioncompare patch (to fix 0.2.10 >= 0.2.9 comparision) auto/th/bakefile-0.2.10-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Apr 2017 05:59:12 +0000 (07:59 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Apr 2017 05:59:12 +0000 (07:59 +0200)
- release 2

bakefile-versioncompare.patch [new file with mode: 0644]
bakefile.spec

diff --git a/bakefile-versioncompare.patch b/bakefile-versioncompare.patch
new file mode 100644 (file)
index 0000000..6aa399b
--- /dev/null
@@ -0,0 +1,14 @@
+--- bakefile-0.2.10/src/utils.py.orig  2017-01-04 11:52:30.000000000 +0100
++++ bakefile-0.2.10/src/utils.py       2017-04-08 07:45:43.920622017 +0200
+@@ -40,7 +40,10 @@
+        e.g. '0.1.4'."""
+     vcur = mk.vars['BAKEFILE_VERSION'].split('.')
+     vreq = version.split('.')
+-    return vcur >= vreq
++    try:
++        return map(int, vcur) >= map(int, vreq)
++    except:
++        return vcur >= vreq
+ def isoption(name):
+     return name in mk.options
index 47360abb258d6f52682bae7ea8fd62f70edaf388..75cff2f990e50bf8f25e5cf175ebb5a631f8c68c 100644 (file)
@@ -3,13 +3,14 @@ Summary:      Native makefiles generator
 Summary(pl.UTF-8):     Generator natywnych plików typu Makefile
 Name:          bakefile
 Version:       0.2.10
-Release:       1
+Release:       2
 License:       MIT
 Group:         Development/Building
 #SourceDownload: https://github.com/vslavik/bakefile/releases
 Source0:       https://github.com/vslavik/bakefile/releases/download/v%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: f980cdd36268b5d2b23602d454bdf0a4
 Patch0:                %{name}-empy.patch
+Patch1:                %{name}-versioncompare.patch
 URL:           http://bakefile.org/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1.6
@@ -36,6 +37,7 @@ dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.101357 seconds and 4 git commands to generate.