]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- new, patched to use system empy
[packages/bakefile.git] / bakefile.spec
1
2 %include        /usr/lib/rpm/macros.python
3
4 Summary:        Native makefiles generator
5 Name:           bakefile
6 Version:        0.1.1
7 %define         snap 20030921
8 Release:        0.%{snap}.1
9 License:        GPL v2+
10 Group:          Applications/Text
11 Source0:        http://bakefile.sourceforge.net/snapshot/bakefile-%{version}.%{snap}.tar.gz
12 # Source0-md5:  6c8d21e2d73440b6da9be6d75b568f9e
13 URL:            http://bakefile.sourceforge.net/
14 BuildRequires:  rpm-pythonprov
15 %pyrequires_eq  python-modules
16 Requires:       python-libxml2
17 Requires:       empy >= 3.1
18 Requires:       python-optik >= 1.2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Bakefile is cross-platform, cross-compiler native makefiles generator. It takes
23 compiler-independent description of build tasks as input and generate native
24 makefile (autoconf's Makefile.in, Visual C++ project, bcc makefile etc.).
25
26 %prep
27 %setup -q -n %{name}-%{version}.%{snap}
28
29 %build
30 %configure
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
35
36 %{__make} \
37         DESTDIR=$RPM_BUILD_ROOT \
38         install
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc README THANKS doc/html
46 %attr(755,root,root) %{_bindir}/*
47 %{_aclocaldir}/*.m4
48 %dir %{_datadir}/%{name}
49 %{_datadir}/%{name}/output
50 %{_datadir}/%{name}/rules
51 %dir %{_datadir}/%{name}/src
52 %{_datadir}/%{name}/src/*.py[oc]
53 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile.py
54 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile_gen.py
This page took 0.063486 seconds and 4 git commands to generate.