]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
d64049abf850471fcfec4ee32ffb49ab9c9d9dc6
[packages/bakefile.git] / bakefile.spec
1
2 %include        /usr/lib/rpm/macros.python
3
4 Summary:        Native makefiles generator
5 Name:           bakefile
6 Version:        0.1.1
7 %define         snap 20031009
8 Release:        0.%{snap}.1
9 License:        GPL v2+
10 Group:          Applications/Text
11 Source0:        http://bakefile.sourceforge.net/snapshot/bakefile-%{version}.%{snap}.tar.gz
12 # Source0-md5:  e4c3359d61b927dc1856f6e65a1dd86b
13 Patch0:         %{name}-empy.patch
14 Patch1:         %{name}-typo.patch
15 URL:            http://bakefile.sourceforge.net/
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-modules
18 Requires:       python-libxml2
19 Requires:       empy >= 3.1
20 Requires:       python-optik >= 1.2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Bakefile is cross-platform, cross-compiler native makefiles generator. It takes
25 compiler-independent description of build tasks as input and generate native
26 makefile (autoconf's Makefile.in, Visual C++ project, bcc makefile etc.).
27
28 %prep
29 %setup -q -n %{name}-%{version}.%{snap}
30 %patch0 -p1
31 %patch1 -p1
32
33 %build
34 %{__aclocal}
35 %{__autoconf}
36 %{__automake}
37 %configure
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
42
43 %{__make} \
44         DESTDIR=$RPM_BUILD_ROOT \
45         install
46
47 # use system available modules
48 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/src/{empy,optik}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README THANKS doc/html
56 %attr(755,root,root) %{_bindir}/*
57 %{_aclocaldir}/*.m4
58 %dir %{_datadir}/%{name}
59 %{_datadir}/%{name}/output
60 %{_datadir}/%{name}/rules
61 %dir %{_datadir}/%{name}/src
62 %{_datadir}/%{name}/src/*.py[oc]
63 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile.py
64 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile_gen.py
65 %{_mandir}/man1/bakefile.1*
This page took 0.078312 seconds and 2 git commands to generate.