]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
c950859fbd52468b534f0bd2d483d50277f5df71
[packages/bakefile.git] / bakefile.spec
1 %define         pre     _pre1
2
3 Summary:        Native makefiles generator
4 Summary(pl):    Generator natywnych plików typu Makefile
5 Name:           bakefile
6 Version:        0.2.1
7 Release:        0.%{pre}.1
8 License:        GPL v2+
9 Group:          Applications/Text
10 Source0:        http://dl.sourceforge.net/bakefile/bakefile-%{version}%{pre}.tar.gz
11 # Source0-md5:  bf4b78fb2afd9f34cb2f845174fc32d0
12 Patch0:         %{name}-empy.patch
13 URL:            http://bakefile.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  python-devel
18 %pyrequires_eq  python-modules
19 Requires:       python-libxml2
20 Requires:       empy >= 3.1
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Bakefile is cross-platform, cross-compiler native makefiles generator.
25 It takes compiler-independent description of build tasks as input and
26 generate native makefile (autoconf's Makefile.in, Visual C++ project,
27 bcc makefile etc.).
28
29 %description -l pl
30 Bakefile to generator natywnych plików typu Makefile dla wielu
31 platform i kompilatorów. Przyjmuje na wej¶ciu niezale¿ny od
32 kompilatora opis zadañ budowania  i tworzy natywny plik (Makefile.in
33 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
34
35 %prep
36 %setup -q -n %{name}-%{version}%{pre} 
37 %patch0 -p1
38
39 %build
40 %{__aclocal} -I admin
41 %{__autoconf}
42 %{__automake}
43 %configure
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
48
49 %{__make} \
50         DESTDIR=$RPM_BUILD_ROOT \
51         install
52
53 # use system available modules
54 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,optik}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README THANKS doc/html
62 %attr(755,root,root) %{_bindir}/*
63 %{_aclocaldir}/*.m4
64 %{_datadir}/%{name}
65 %dir %{_libdir}/%{name}
66 %{_libdir}/%{name}/*.py[oc]
67 %attr(755,root,root) %{_libdir}/%{name}/*.so
68 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
69 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
70 %{_mandir}/man1/bakefil*.1*
This page took 0.057324 seconds and 2 git commands to generate.