]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- fix format string warning
[packages/bakefile.git] / bakefile.spec
1 Summary:        Native makefiles generator
2 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
3 Name:           bakefile
4 Version:        0.2.9
5 Release:        2
6 License:        MIT
7 Group:          Development/Building
8 Source0:        http://downloads.sourceforge.net/bakefile/%{name}-%{version}.tar.gz
9 # Source0-md5:  b53813d155df1a45371abc8f781e6d88
10 Patch0:         %{name}-empy.patch
11 Patch1:         format-security.patch
12 URL:            http://bakefile.sourceforge.net/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1.6
15 BuildRequires:  libtool
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python-modules
19 Requires:       empy >= 3.1
20 Requires:       python-libxml2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Bakefile is cross-platform, cross-compiler native makefiles generator.
25 It takes compiler-independent description of build tasks as input and
26 generate native makefile (autoconf's Makefile.in, Visual C++ project,
27 bcc makefile etc.).
28
29 %description -l pl.UTF-8
30 Bakefile to generator natywnych plików typu Makefile dla wielu
31 platform i kompilatorów. Przyjmuje na wejściu niezależny od
32 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
33 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
34
35 %prep
36 %setup -q
37 %patch0 -p1
38 %patch1 -p1
39
40 %build
41 %{__libtoolize}
42 %{__aclocal} -I admin
43 %{__autoconf}
44 %{__automake}
45 %configure
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 # use system available modules
54 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
55
56 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
57 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS COPYING NEWS README THANKS doc/html
65 %attr(755,root,root) %{_bindir}/bakefile
66 %attr(755,root,root) %{_bindir}/bakefile_gen
67 %attr(755,root,root) %{_bindir}/bakefilize
68 %{_datadir}/%{name}
69 %dir %{_libdir}/%{name}
70 %{_libdir}/%{name}/*.py[oc]
71 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
72 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
73 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
74 %{_aclocaldir}/bakefile*.m4
75 %{_mandir}/man1/bakefile.1*
76 %{_mandir}/man1/bakefile_gen.1*
77 %{_mandir}/man1/bakefilize.1*
This page took 0.040024 seconds and 3 git commands to generate.