]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- up to 0.2.12
[packages/bakefile.git] / bakefile.spec
1 # NOTE: for 1.x versions see DEVEL branch; it's not compatible with 0.x, and (according to web site) still work in progress.
2 Summary:        Native makefiles generator
3 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
4 Name:           bakefile
5 Version:        0.2.10
6 Release:        2
7 License:        MIT
8 Group:          Development/Building
9 #SourceDownload: https://github.com/vslavik/bakefile/releases
10 Source0:        https://github.com/vslavik/bakefile/releases/download/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  f980cdd36268b5d2b23602d454bdf0a4
12 Patch0:         %{name}-empy.patch
13 Patch1:         %{name}-versioncompare.patch
14 URL:            http://bakefile.org/
15 BuildRequires:  autoconf >= 2.53
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  libtool
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rpm-pythonprov
20 %pyrequires_eq  python-modules
21 Requires:       empy >= 3.1
22 Requires:       python-libxml2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Bakefile is cross-platform, cross-compiler native makefiles generator.
27 It takes compiler-independent description of build tasks as input and
28 generate native makefile (autoconf's Makefile.in, Visual C++ project,
29 bcc makefile etc.).
30
31 %description -l pl.UTF-8
32 Bakefile to generator natywnych plików typu Makefile dla wielu
33 platform i kompilatorów. Przyjmuje na wejściu niezależny od
34 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
35 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
36
37 %prep
38 %setup -q
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 %{__libtoolize}
44 %{__aclocal} -I admin
45 %{__autoconf}
46 %{__automake}
47 %configure
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 # use system available modules
56 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
57
58 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
59 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS COPYING NEWS README THANKS doc/html
67 %attr(755,root,root) %{_bindir}/bakefile
68 %attr(755,root,root) %{_bindir}/bakefile_gen
69 %attr(755,root,root) %{_bindir}/bakefilize
70 %{_datadir}/%{name}
71 %dir %{_libdir}/%{name}
72 %{_libdir}/%{name}/*.py[oc]
73 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
74 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
75 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
76 %{_aclocaldir}/bakefile*.m4
77 %{_mandir}/man1/bakefile.1*
78 %{_mandir}/man1/bakefile_gen.1*
79 %{_mandir}/man1/bakefilize.1*
This page took 0.132259 seconds and 3 git commands to generate.