]> git.pld-linux.org Git - packages/bacula.git/commitdiff
- build process doesn't fail when something fails to build - catch errors from log...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 1 Nov 2011 20:57:30 +0000 (20:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bacula-wxconsole.patch -> 1.1
    bacula.spec -> 1.186

bacula-wxconsole.patch [new file with mode: 0644]
bacula.spec

diff --git a/bacula-wxconsole.patch b/bacula-wxconsole.patch
new file mode 100644 (file)
index 0000000..f5403e1
--- /dev/null
@@ -0,0 +1,20 @@
+--- bacula-5.2.1/src/wx-console/console_thread.cpp.org 2011-11-01 21:39:04.664311911 +0100
++++ bacula-5.2.1/src/wx-console/console_thread.cpp     2011-11-01 21:52:51.874066263 +0100
+@@ -483,7 +483,7 @@
+          csprint(UA_sock->msg);
+       }
+       else if (stat == BNET_SIGNAL) {
+-         if (UA_sock->msglen == BNET_PROMPT) {
++         if (UA_sock->msglen == BNET_SUB_PROMPT) {
+             csprint(NULL, CS_PROMPT);
+          } else if (UA_sock->msglen == BNET_EOD) {
+             last_is_eod = 1;
+@@ -534,7 +534,7 @@
+    if (UA_sock) {
+       UA_sock->msglen = (int32_t)strlen(str);
+       pm_strcpy(&UA_sock->msg, str);
+-      UA_sock->_send();
++      UA_sock->send();
+    } else if (choosingdirector) {
+ //      wxString number = str;
+ //      number.RemoveLast(); /* Removes \n */
index cd6eaae1b51c3ec95aad978412be7c826a81039d..5704bf2a55e16a2b06d4be7ce76263e355f2651e 100644 (file)
@@ -45,6 +45,7 @@ Patch2:               %{name}-conf.patch
 Patch3:                %{name}-desktop.patch
 Patch4:                make_catalog_backup-setup-home.patch
 Patch5:                %{name}-mysql_thread.patch
+Patch6:                %{name}-wxconsole.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -440,6 +441,7 @@ Nagios plugin to check bacula.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 
@@ -496,7 +498,9 @@ qmake-qt4 bat.pro
 cd ../..
 %endif
 
-%{__make}
+%{__make} 2>&1 | tee log
+# check for build errors
+grep "Error in" log && exit 1
 
 %if %{with nagios}
 # nagios plugin
@@ -914,8 +918,8 @@ ln -sf libbaccats-%{1}-%{version}.so %{_libdir}/libbaccats-%{version}.so || : \
 %doc LICENSE
 %{_pixmapsdir}/%{name}.png
 %{_desktopdir}/bacula-wx.desktop
-#%attr(640,root,bacula) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bwx-console.conf
-#%attr(755,root,root) %{_sbindir}/bwx-console
+%attr(640,root,bacula) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bwx-console.conf
+%attr(755,root,root) %{_sbindir}/bwx-console
 %{_mandir}/man1/bacula-bwxconsole.1*
 %endif
 
This page took 0.10883 seconds and 4 git commands to generate.