]> git.pld-linux.org Git - packages/bacula.git/commitdiff
- fix deps that are incorrect in rpm 4 auto/th/bacula-9.4.2-4
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Sep 2021 07:58:20 +0000 (09:58 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Sep 2021 07:58:20 +0000 (09:58 +0200)
- rediff patches
- fix for new configure trying to find its files before BUILD_DIR is set
- rel 4

bacula-mtx-changer.patch
bacula.spec
make_catalog_backup-setup-home.patch

index c40c6cf340d00afaeca2a1ebf3c93cca2e0164c3..12022fff21c4bb7afea3e25ebda557600f0d1015 100644 (file)
@@ -1,7 +1,8 @@
---- bacula-5.0.1/scripts/mtx-changer.in~       2010-02-24 17:33:48.000000000 +0200
-+++ bacula-5.0.1/scripts/mtx-changer.in        2010-02-25 11:49:14.545143118 +0200
-@@ -47,13 +47,13 @@
- #
+diff -urNp -x '*.orig' bacula-9.4.2.org/scripts/mtx-changer.in bacula-9.4.2/scripts/mtx-changer.in
+--- bacula-9.4.2.org/scripts/mtx-changer.in    2019-02-04 17:47:31.000000000 +0100
++++ bacula-9.4.2/scripts/mtx-changer.in        2021-09-26 09:47:51.139744008 +0200
+@@ -65,13 +65,13 @@
+ myversion=2
  
  # source our conf file
 -if test ! -f @scriptdir@/mtx-changer.conf ; then
@@ -15,5 +16,5 @@
 -. @scriptdir@/mtx-changer.conf
 +. /etc/bacula/mtx-changer.conf
  
- MTX=@MTX@
+ if test "${version}" != "${myversion}" ; then
+   echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
index 90935a6f09734c655ec67b11832555575a185e66..cc1fb6992ebbf041832696707fb2a872e8ea5a64 100644 (file)
@@ -23,7 +23,7 @@ Summary:      Bacula - The Network Backup Solution
 Summary(pl.UTF-8):     Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
 Name:          bacula
 Version:       9.4.2
-Release:       3
+Release:       4
 License:       AGPL v3
 Group:         Networking/Utilities
 Source0:       http://downloads.sourceforge.net/bacula/%{name}-%{version}.tar.gz
@@ -165,7 +165,7 @@ Summary(pl.UTF-8):  Usługi Bacula Director i Catalog
 Group:         Networking/Utilities
 Requires(post):        sed >= 4.0
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      bacula(db) = %{version}-%{release}
+Requires:      bacula-db = %{version}-%{release}
 Requires:      systemd-units >= 38
 Obsoletes:     bacula-updatedb
 
@@ -329,8 +329,8 @@ Summary(pl.UTF-8):  Sterownik bazy PostgreSQL dla Baculi
 Group:         Networking/Utilities
 Requires(post):        /sbin/ldconfig
 Requires:      %{name}-common = %{version}-%{release}
-Provides:      bacula(db) = %{version}-%{release}
-Obsoletes:     bacula(db)
+Provides:      bacula-db = %{version}-%{release}
+Obsoletes:     bacula-db
 
 %description db-postgresql
 PostgreSQL database driver for Bacula.
@@ -344,8 +344,8 @@ Summary(pl.UTF-8):  Sterownik bazy MySQL dla Baculi
 Group:         Networking/Utilities
 Requires(post):        /sbin/ldconfig
 Requires:      %{name}-common = %{version}-%{release}
-Provides:      bacula(db) = %{version}-%{release}
-Obsoletes:     bacula(db)
+Provides:      bacula-db = %{version}-%{release}
+Obsoletes:     bacula-db
 
 %description db-mysql
 MySQL database driver for Bacula.
@@ -359,8 +359,8 @@ Summary(pl.UTF-8):  Sterownik bazy SQLite dla Baculi
 Group:         Networking/Utilities
 Requires(post):        /sbin/ldconfig
 Requires:      %{name}-common = %{version}-%{release}
-Provides:      bacula(db) = %{version}-%{release}
-Obsoletes:     bacula(db)
+Provides:      bacula-db = %{version}-%{release}
+Obsoletes:     bacula-db
 
 %description db-sqlite3
 SQLite database driver for Bacula.
@@ -418,6 +418,7 @@ cd ..
 
 CPPFLAGS="-I/usr/include/ncurses -I%{_includedir}/readline"
 
+BUILD_DIR=$(pwd) \
 QMAKE=%{_bindir}/qmake-qt5 \
 %configure \
        DISTNAME=pld-linux \
index 68d76a4265f93aae0bbfefa9335d910d42e37056..983a695b8d0a13a04e38fdd0e9ad87abd749f623 100644 (file)
@@ -1,6 +1,7 @@
---- bacula-5.2.1/src/cats/make_catalog_backup.in~      2011-10-30 13:03:42.000000000 +0100
-+++ bacula-5.2.1/src/cats/make_catalog_backup.in       2011-11-01 17:27:38.863760358 +0100
-@@ -13,12 +13,15 @@
+diff -urNp -x '*.orig' bacula-9.4.2.org/src/cats/make_catalog_backup.in bacula-9.4.2/src/cats/make_catalog_backup.in
+--- bacula-9.4.2.org/src/cats/make_catalog_backup.in   2019-02-04 17:47:31.000000000 +0100
++++ bacula-9.4.2/src/cats/make_catalog_backup.in       2021-09-26 09:47:52.123078492 +0200
+@@ -16,12 +16,15 @@
  #     line arguments and the environment using ps.  Please consult your
  #     MySQL or PostgreSQL manual for secure methods of specifying the
  #     password.
@@ -14,5 +15,5 @@
 +HOME=@working_dir@
 +
  default_db_type=@DEFAULT_DB_TYPE@
+ user=${2:-@db_user@}
  
- #
This page took 0.100041 seconds and 4 git commands to generate.