]> git.pld-linux.org Git - packages/bacula-web.git/commitdiff
- use external libs, add cachedir auto/ac/bacula-web-5_2_2-1 auto/th/bacula-web-5_2_2-1
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 7 Apr 2012 12:00:10 +0000 (12:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache.conf -> 1.3
    bacula-web.spec -> 1.10
    sys-libs.patch -> 1.1

apache.conf
bacula-web.spec
sys-libs.patch [new file with mode: 0644]

index 63105bf8fce8d18db48d143ab6b1bcb2dca69123..21d9a78ecbbdd11ac5fd46cbdc31ffe1c30d159d 100644 (file)
@@ -1,8 +1,16 @@
+Alias /bacula-web/templates_c/ /var/cache/bacula-web/
 Alias /bacula-web /usr/share/bacula-web
 <Directory /usr/share/bacula-web>
        allow from all
 </Directory>
 
+<Directory /var/cache/bacula-web>
+       deny from all
+       <Files *.png>
+               allow from all
+       </Files>
+</Directory>
+
 <Directory /usr/share/bacula-web/config>
        order deny,allow
        deny from all
index 193ae3969a32f3a99c5e9923c81612c6c02f3a69..01fe4a120679c215ca50fe36b62b2ff1582fe638 100644 (file)
@@ -1,25 +1,26 @@
 %define                php_min_version 5.2.4
-#%include      /usr/lib/rpm/macros.php
+%include       /usr/lib/rpm/macros.php
 Summary:       Open source monitoring and reporting tool for Bacula
 Name:          bacula-web
 Version:       5.2.2
-Release:       0.3
+Release:       1
 License:       GPL v2
 Group:         Applications/WWW
 URL:           http://www.bacula-web.org/
 Source0:       http://www.bacula-web.org/tl_files/downloads/%{name}.%{version}.tar.gz
 # Source0-md5: b52253963cc6edb6437a0dbe59c6051f
 Source1:       apache.conf
+Patch0:                sys-libs.patch
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: sed >= 4.0
-#Requires:     php-Smarty
+Requires:      Smarty
+Requires:      Smarty-plugin-gettext
 Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-gd
 Requires:      php-gettext
 Requires:      php-pdo
 Requires:      phplot
-Requires:      smarty-gettext
 Requires:      webserver(php)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -28,6 +29,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _webapp         %{name}
 %define                _sysconfdir     %{_webapps}/%{_webapp}
 %define                _appdir         %{_datadir}/%{_webapp}
+%define                cachedir        /var/cache/%{name}
 %define                _smartyplugindir        %{php_data_dir}/Smarty/plugins
 
 # bad depsolver
@@ -42,32 +44,37 @@ information from your bacula catalog's database.
 
 %prep
 %setup -qc
+%patch0 -p1
 
 mv config/config.php{.sample,}
 rm locale/*/LC_MESSAGES/*.po
-
-# nonstandard plugins
-install -d smarty-plugins
-#mv core/external/smarty/libs/plugins/modifier.fsize_format.php smarty-plugins
-
-%{__rm} -r templates_c
-#external_packages
+mv core/external .
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir},%{cachedir}}
 cp -a *.php core locale style templates $RPM_BUILD_ROOT%{_appdir}
-#cp -a smarty-plugins/* $RPM_BUILD_ROOT%{_smartyplugindir}
 
 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
 
+ln -s %{cachedir} $RPM_BUILD_ROOT%{_appdir}/templates_c
+
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+# cleanup cache from previous rpm
+echo %{cachedir}/* | xargs rm -f
+
+%preun
+if [ "$1" = 0 ]; then
+       echo %{cachedir}/* | xargs rm -f
+fi
+
 %triggerin -- apache1 < 1.3.37-3, apache1-base
 %webapp_register apache %{_webapp}
 
@@ -99,6 +106,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_appdir}/config
 %{_appdir}/style
 %{_appdir}/templates
+%{_appdir}/templates_c
 
 %dir %{_appdir}/core
 %{_appdir}/core/bweb.inc.php
@@ -117,9 +125,4 @@ rm -rf $RPM_BUILD_ROOT
 %lang(it) %{_appdir}/locale/it_IT
 %lang(sv) %{_appdir}/locale/sv_SV
 
-%dir %{_appdir}/core/external
-%{_appdir}/core/external/phplot
-%{_appdir}/core/external/smarty
-%{_appdir}/core/external/smarty_gettext-0.9
-
-#%{_appdir}/templates_c
+%dir %attr(775,root,http) %{cachedir}
diff --git a/sys-libs.patch b/sys-libs.patch
new file mode 100644 (file)
index 0000000..3f9af8a
--- /dev/null
@@ -0,0 +1,23 @@
+--- bacula-web-5.2.2/config/global.inc.php~    2011-12-04 15:14:21.000000000 +0200
++++ bacula-web-5.2.2/config/global.inc.php     2012-04-07 14:43:17.230952000 +0300
+@@ -18,8 +18,8 @@
+  define( 'BW_OBJ', BW_ROOT . '/core/' ); 
+  define( 'BW_EXTERNAL', BW_OBJ . 'external' );
+  
+- define( 'BW_PHPLOT', BW_EXTERNAL . '/phplot/'  );                                    
+- define( 'BW_SMARTY', BW_EXTERNAL . '/smarty/libs/' );                                
++ define( 'BW_PHPLOT', '/usr/share/php/phplot/'  );                                    
++ define( 'BW_SMARTY', '/usr/share/php/Smarty/' );                             
+  define( 'BW_SMARTY_GETTEXT', BW_EXTERNAL . '/smarty_gettext-0.9/' );
+  
+  
+@@ -27,8 +27,7 @@
+  require_once BW_OBJ . "bweb.inc.php";
+  
+  // Template engine
+- require_once( BW_SMARTY . "Smarty.class.php");                       
+- require_once( BW_SMARTY_GETTEXT . "smarty_gettext.php" );            
++ require_once( "Smarty.class.php");                   
+  
+  // Configuration 
+  require_once BW_OBJ . "cfg/config.class.php";
This page took 0.080196 seconds and 4 git commands to generate.