]> git.pld-linux.org Git - packages/babl.git/blob - babl.spec
BR: pkgconfig
[packages/babl.git] / babl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Library for pixel-format agnosticism
6 Summary(pl.UTF-8):      Biblioteka niezależności od formatu piksela
7 Name:           babl
8 Version:        0.1.38
9 Release:        1
10 License:        LGPL v3+
11 Group:          Libraries
12 Source0:        https://download.gimp.org/pub/babl/0.1/%{name}-%{version}.tar.bz2
13 # Source0-md5:  eb814d37e70aaf896243b105eea2b1a3
14 URL:            http://www.gegl.org/babl/
15 BuildRequires:  autoconf >= 2.54
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  libtool >= 2:2.2
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Babl is a dynamic, any to any, pixel format conversion library. It
22 provides conversions between the myriad of buffer types images can be
23 stored in. Babl doesn't only help with existing pixel formats, but
24 also facilitates creation of new and uncommon ones.
25
26 %description -l pl.UTF-8
27 Babl to biblioteka dynamicznych przekształceń między dowolnymi
28 formatami pikseli. Udostępnia konwersje między wieloma różnymi typami
29 buforów obrazów. Babl nie tylko pomaga przy istniejących formatach
30 pikseli, ale także ułatwia tworzenie nowych i niestandardowych.
31
32 %package devel
33 Summary:        Header files for babl library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki babl
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for babl library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki babl.
43
44 %package static
45 Summary:        Static babl library
46 Summary(pl.UTF-8):      Statyczna biblioteka babl
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static babl library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka babl.
55
56 %package -n vala-babl
57 Summary:        Vala API for babl library
58 Summary(pl.UTF-8):      API języka Vala dla biblioteki babl
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61 Requires:       vala
62
63 %description -n vala-babl
64 Vala API for babl library.
65
66 %description -n vala-babl -l pl.UTF-8
67 API języka Vala dla biblioteki babl.
68
69 %prep
70 %setup -q
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         --disable-silent-rules \
80         %{?with_static_libs:--enable-static}
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 # dlopened modules
90 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babl-0.1/*.la
91 %if %{with static_libs}
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babl-0.1/*.a
93 %endif
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS NEWS README TODO
104 %attr(755,root,root) %{_libdir}/libbabl-0.1.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libbabl-0.1.so.0
106 %dir %{_libdir}/babl-0.1
107 %attr(755,root,root) %{_libdir}/babl-0.1/*.so
108
109 %files devel
110 %defattr(644,root,root,755)
111 %doc docs/{*.html,*.css}
112 %attr(755,root,root) %{_libdir}/libbabl-0.1.so
113 %{_libdir}/libbabl-0.1.la
114 %{_includedir}/babl-0.1
115 %{_pkgconfigdir}/babl.pc
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libbabl-0.1.a
121 %endif
122
123 %if 0
124 %files -n vala-babl
125 %defattr(644,root,root,755)
126 %{_datadir}/vala/vapi/babl-0.1.vapi
127 %endif
This page took 0.109369 seconds and 3 git commands to generate.