]> git.pld-linux.org Git - packages/babeltrace.git/blame - babeltrace.spec
BR: swig-python for python bindings
[packages/babeltrace.git] / babeltrace.spec
CommitLineData
14af0f70
JB
1#
2# Conditional build:
3%bcond_without python # Python binding
4#
6e41d93e
JB
5Summary: Trace Format Babel Tower
6Summary(pl.UTF-8): Wieża Babel formatów narzędzi śledzących
7Name: babeltrace
13508583 8# keep 1.x here, babeltrace2 is separate project (see babeltrace2.spec)
a7fb3a1f
JB
9Version: 1.5.11
10Release: 1
6e41d93e
JB
11License: MIT
12Group: Applications/System
ecc61248 13Source0: https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
a7fb3a1f 14# Source0-md5: ca6b23633a78d3dbcc2aec2cbdc99838
ecc61248 15Patch0: %{name}-python.patch
eacdc6bb 16URL: https://babeltrace.org/
14af0f70
JB
17BuildRequires: autoconf >= 2.50
18BuildRequires: automake
eacdc6bb 19BuildRequires: elfutils-devel >= 0.154
6e41d93e 20BuildRequires: glib2-devel >= 1:2.22.0
14af0f70 21BuildRequires: libtool >= 2:2
6e41d93e
JB
22BuildRequires: libuuid-devel
23BuildRequires: pkgconfig
24BuildRequires: popt-devel
ecc61248 25%{?with_python:BuildRequires: python3-devel >= 1:3.2}
14af0f70 26BuildRequires: rpm-pythonprov
eacdc6bb 27BuildRequires: rpmbuild(macros) >= 1.507
0e2e19dc 28%{?with_python:BuildRequires: swig-python >= 2.0.0}
eacdc6bb 29Requires: elfutils >= 0.154
6e41d93e
JB
30Requires: glib2 >= 1:2.22.0
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This project provides trace read and write libraries, as well as a
35trace converter. A plugin can be created for any trace format to allow
36its conversion to/from another trace format.
37
38%description -l pl.UTF-8
39Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
40konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
41aby umożliwić konwersję do/z innego formatu.
42
43%package devel
44Summary: Header files for Babeltrace libraries
45Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Babeltrace
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
eacdc6bb 48Requires: elfutils-devel >= 0.154
6e41d93e
JB
49Requires: glib2-devel >= 1:2.22.0
50Requires: libuuid-devel
51Requires: popt-devel
52
53%description devel
54Header files for Babeltrace libraries.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe bibliotek Babeltrace.
58
59%package static
60Summary: Static Babeltrace libraries
61Summary(pl.UTF-8): Statyczne biblioteki Babeltrace
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static Babeltrace libraries.
67
68%description static -l pl.UTF-8
69Statyczne biblioteki Babeltrace.
70
ecc61248
JB
71%package -n python3-babeltrace
72Summary: Python 3 binding to Babeltrace library
73Summary(pl.UTF-8): Wiązanie Pythona 3 do biblioteki Babeltrace
14af0f70
JB
74Group: Libraries/Python
75Requires: %{name} = %{version}-%{release}
ecc61248 76Obsoletes: python-babeltrace < 1.5.3
14af0f70 77
ecc61248
JB
78%description -n python3-babeltrace
79Python 3 binding to Babeltrace library.
14af0f70 80
ecc61248
JB
81%description -n python3-babeltrace -l pl.UTF-8
82Wiązanie Pythona 3 do biblioteki Babeltrace.
14af0f70 83
6e41d93e
JB
84%prep
85%setup -q
14af0f70 86%patch0 -p1
6e41d93e
JB
87
88%build
14af0f70
JB
89%{__libtoolize}
90%{__aclocal} -I m4
91%{__autoconf}
92%{__autoheader}
93%{__automake}
6e41d93e 94%configure \
14af0f70 95 %{?with_python:--enable-python-bindings} \
6e41d93e
JB
96 --disable-silent-rules
97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
14af0f70 105# lib*.la kept - no .pc files for individual libraries
6e41d93e
JB
106
107# packaged as %doc
108%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
118%doc ChangeLog LICENSE README std-ext-lib.txt
119%attr(755,root,root) %{_bindir}/babeltrace
120%attr(755,root,root) %{_bindir}/babeltrace-log
121%attr(755,root,root) %{_libdir}/libbabeltrace.so.*.*.*
14af0f70 122%attr(755,root,root) %ghost %{_libdir}/libbabeltrace.so.1
6e41d93e 123%attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so.*.*.*
14af0f70 124%attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf.so.1
6e41d93e 125%attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so.*.*.*
14af0f70 126%attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-metadata.so.1
6e41d93e 127%attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so.*.*.*
14af0f70 128%attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-text.so.1
6e41d93e 129%attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so.*.*.*
14af0f70
JB
130%attr(755,root,root) %ghost %{_libdir}/libbabeltrace-dummy.so.1
131%attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so.*.*.*
132%attr(755,root,root) %ghost %{_libdir}/libbabeltrace-lttng-live.so.1
6e41d93e
JB
133%{_mandir}/man1/babeltrace.1*
134%{_mandir}/man1/babeltrace-log.1*
135
136%files devel
137%defattr(644,root,root,755)
138%doc doc/{API,development}.txt
139%attr(755,root,root) %{_libdir}/libbabeltrace.so
140%attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so
141%attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so
142%attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so
143%attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so
14af0f70 144%attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so
6e41d93e
JB
145%{_libdir}/libbabeltrace.la
146%{_libdir}/libbabeltrace-ctf.la
147%{_libdir}/libbabeltrace-ctf-metadata.la
148%{_libdir}/libbabeltrace-ctf-text.la
149%{_libdir}/libbabeltrace-dummy.la
14af0f70 150%{_libdir}/libbabeltrace-lttng-live.la
6e41d93e
JB
151%{_includedir}/babeltrace
152%{_pkgconfigdir}/babeltrace.pc
14af0f70 153%{_pkgconfigdir}/babeltrace-ctf.pc
6e41d93e
JB
154
155%files static
156%defattr(644,root,root,755)
157%{_libdir}/libbabeltrace.a
158%{_libdir}/libbabeltrace-ctf.a
159%{_libdir}/libbabeltrace-ctf-metadata.a
160%{_libdir}/libbabeltrace-ctf-text.a
161%{_libdir}/libbabeltrace-dummy.a
14af0f70
JB
162%{_libdir}/libbabeltrace-lttng-live.a
163
164%if %{with python}
ecc61248 165%files -n python3-babeltrace
14af0f70 166%defattr(644,root,root,755)
ecc61248
JB
167%dir %{py3_sitedir}/babeltrace
168%attr(755,root,root) %{py3_sitedir}/babeltrace/_babeltrace.cpython-*.so
169%{py3_sitedir}/babeltrace/*.py
170%{py3_sitedir}/babeltrace/__pycache__
171%{py3_sitedir}/babeltrace-%{version}-py*.egg-info
14af0f70 172%endif
This page took 0.20334 seconds and 4 git commands to generate.