]> git.pld-linux.org Git - packages/ax25-tools.git/commitdiff
- patches set for current build tools, separated -gui; release 9 master auto/th/ax25-tools-0.0.8-9
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Mar 2023 19:25:36 +0000 (20:25 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Mar 2023 19:25:36 +0000 (20:25 +0100)
ax25-tools-format.patch [new file with mode: 0644]
ax25-tools-gcc.patch [new file with mode: 0644]
ax25-tools-glibc.patch [new file with mode: 0644]
ax25-tools.spec

diff --git a/ax25-tools-format.patch b/ax25-tools-format.patch
new file mode 100644 (file)
index 0000000..0db1ab2
--- /dev/null
@@ -0,0 +1,98 @@
+--- ax25-tools-0.0.8/ax25/axparms.c.orig       2001-04-10 04:09:25.000000000 +0200
++++ ax25-tools-0.0.8/ax25/axparms.c    2023-03-24 18:00:48.184284391 +0100
+@@ -147,7 +147,7 @@ PROC_AX25_ROUTE_FILE);
+                       return 1;
+               }
+               while (fgets(routebuf,80,fp))
+-                      printf(routebuf);
++                      fputs(routebuf, stdout);
+               puts("");
+       }
+--- ax25-tools-0.0.8/kiss/mkiss.c.orig 2001-05-03 04:11:53.000000000 +0200
++++ ax25-tools-0.0.8/kiss/mkiss.c      2023-03-24 19:04:26.286933287 +0100
+@@ -433,17 +433,17 @@ int main(int argc, char *argv[])
+                       return 1;
+               case ':':
+               case '?':
+-                      fprintf(stderr, usage_string);
++                      fputs(usage_string, stderr);
+                       return 1;
+               }
+       }
+       if ((argc - optind) < 2) {
+-              fprintf(stderr, usage_string);
++              fputs(usage_string, stderr);
+               return 1;
+       }
+       if ((numptys = argc - optind - 1) > 16) {
+-              fprintf(stderr, "mkiss: max 16 pty interfaces allowed.\n");
++              fputs("mkiss: max 16 pty interfaces allowed.\n", stderr);
+               return 1;
+       }
+--- ax25-tools-0.0.8/netrom/nrparms.c.orig     2001-04-10 04:18:31.000000000 +0200
++++ ax25-tools-0.0.8/netrom/nrparms.c  2023-03-24 19:06:04.896399074 +0100
+@@ -222,7 +222,7 @@ int main(int argc, char *argv[])
+       
+       if (strncmp(argv[1], "-n", 2) == 0) {
+               if (argc < 9) {
+-                      fprintf(stderr, nodes_usage);
++                      fputs(nodes_usage, stderr);
+                       close(s);
+                       return 1;
+               }
+@@ -233,7 +233,7 @@ int main(int argc, char *argv[])
+       if (strncmp(argv[1], "-r", 2) == 0) {
+               if (argc < 6) {
+-                      fprintf(stderr, routes_usage);
++                      fputs(routes_usage, stderr);
+                       close(s);
+                       return 1;
+               }
+@@ -242,7 +242,7 @@ int main(int argc, char *argv[])
+               return 0;
+       }
+-      fprintf(stderr, "usage: nrparms -nodes|-routes|-version ...\n");
++      fputs("usage: nrparms -nodes|-routes|-version ...\n", stderr);
+       
+       close(s);
+       
+--- ax25-tools-0.0.8/rose/rsparms.c.orig       2001-04-10 04:18:36.000000000 +0200
++++ ax25-tools-0.0.8/rose/rsparms.c    2023-03-24 19:07:46.705847525 +0100
+@@ -74,12 +74,12 @@ void nodes(int s, int argc, char *argv[]
+       int args;
+       if (argc < 3) {
+-              fprintf(stderr, nodes_usage);
++              fputs(nodes_usage, stderr);
+               exit(1);
+       }
+       if (ax25_config_load_ports() == 0) {
+-              fprintf(stderr, "rsparms: nodes: no AX.25 ports configured\n");
++              fputs("rsparms: nodes: no AX.25 ports configured\n", stderr);
+               exit(1);
+       }
+@@ -120,7 +120,7 @@ void nodes(int s, int argc, char *argv[]
+       }
+       if (argc < 6) {
+-              fprintf(stderr, nodes_usage);
++              fputs(nodes_usage, stderr);
+               exit(1);
+       }
+@@ -129,7 +129,7 @@ void nodes(int s, int argc, char *argv[]
+               mask++;
+               if (sscanf(mask, "%hd", &rs_node.mask) != 1) {
+-                      fprintf(stderr, "rsparms: nodes: no mask supplied!\n");
++                      fputs("rsparms: nodes: no mask supplied!\n", stderr);
+                       close(s);
+                       exit(1);
+               }
diff --git a/ax25-tools-gcc.patch b/ax25-tools-gcc.patch
new file mode 100644 (file)
index 0000000..006dea5
--- /dev/null
@@ -0,0 +1,62 @@
+--- ax25-tools-0.0.8/tcpip/rip98d.c.orig       2001-05-03 04:03:38.000000000 +0200
++++ ax25-tools-0.0.8/tcpip/rip98d.c    2023-03-24 19:09:19.852009575 +0100
+@@ -32,7 +32,7 @@ struct dest_struct dest_list[50];
+ int dest_count = 0;
+ int debug      = FALSE;
+-int restrict   = FALSE;
++int restrict_  = FALSE;
+ int logging    = FALSE;
+ struct route_struct *first_route = NULL;
+@@ -202,7 +202,7 @@ static int read_routes(void)
+                       continue;
+               }
+-              if (restrict) {
++              if (restrict_) {
+                       if (inet_netof(address) != 44) {
+                               if (debug && logging)
+                                       syslog(LOG_DEBUG, "rejecting route to %s/%ld - not ampr.org\n", inet_ntoa(address), netmask);
+@@ -285,7 +285,7 @@ int main(int argc, char **argv)
+                               logging = TRUE;
+                               break;
+                       case 'r':
+-                              restrict = TRUE;
++                              restrict_ = TRUE;
+                               break; 
+                       case 't':
+                               interval = atoi(optarg) * 60;
+--- ax25-tools-0.0.8/tcpip/rip98d.h.orig       2001-04-10 04:18:40.000000000 +0200
++++ ax25-tools-0.0.8/tcpip/rip98d.h    2023-03-24 19:10:37.668254675 +0100
+@@ -44,7 +44,7 @@ extern struct dest_struct dest_list[];
+ extern int dest_count;
+ extern int debug;
+-extern int restrict;
++extern int restrict_;
+ extern int logging;
+ /* In rip98d.c */
+--- ax25-tools-0.0.8/tcpip/rip98r.c.orig       2001-05-03 03:58:33.000000000 +0200
++++ ax25-tools-0.0.8/tcpip/rip98r.c    2023-03-24 19:11:37.947928112 +0100
+@@ -127,7 +127,7 @@ void receive_routes(int s)
+                       continue;
+               }
+-              if (restrict) {
++              if (restrict_) {
+                       if (network != 44) {
+                               if (debug && logging)
+                                       syslog(LOG_DEBUG, "    route to %s/%d metric %d - rejected\n", inet_ntoa(addr), bits, metric);
+--- ax25-tools-0.0.8/dmascc/dmascc_cfg.c.orig  2001-05-10 12:44:45.000000000 +0200
++++ ax25-tools-0.0.8/dmascc/dmascc_cfg.c       2023-03-24 19:32:51.854360102 +0100
+@@ -99,7 +99,7 @@ int main(int argc, char *argv[])
+   memset(&param, 0, sizeof(param));
+   param.txpause = -1;
+-  if strncmp(argv[1], "dmascc", 6) {
++  if (strncmp(argv[1], "dmascc", 6)) {
+     fprintf(stderr, "invalid interface name.\n");
+     return 5;
+   }
diff --git a/ax25-tools-glibc.patch b/ax25-tools-glibc.patch
new file mode 100644 (file)
index 0000000..a923446
--- /dev/null
@@ -0,0 +1,20 @@
+--- ax25-tools-0.0.8/kiss/kissnetd.c.orig      2001-04-10 04:10:39.000000000 +0200
++++ ax25-tools-0.0.8/kiss/kissnetd.c   2023-03-24 18:06:09.899208178 +0100
+@@ -104,7 +104,7 @@ static void ReopenPort(int PortNumber)
+       PortList[PortNumber]->Fd = open(PortList[PortNumber]->Name, O_RDWR | O_NONBLOCK);
+       if (PortList[PortNumber]->Fd < 0) {
+               syslog(LOG_WARNING, "kissnetd : Error opening port %s : %s\n", 
+-                      PortList[PortNumber]->Name, sys_errlist[errno]);
++                      PortList[PortNumber]->Name, strerror(errno));
+               if (VerboseMode) {
+                       sprintf(MyString, "cannot reopen %s", PortList[PortNumber]->Name);
+                       perror(MyString);
+@@ -160,7 +160,7 @@ static void ProcessInput(int PortNumber)
+       if (!Length) return;
+       if (Length < 0) {
+               syslog(LOG_WARNING, "kissnetd : Error reading port %s : %s\n", 
+-                      PortList[PortNumber]->Name, sys_errlist[errno]);
++                      PortList[PortNumber]->Name, strerror(errno));
+               if (VerboseMode) perror("read");
+               close(MyPort->Fd);
+               MyPort->Fd = -1;
index e1b44ee3f275fc436d3c8885b2db2519140b2853..7811ac760a78373d8cad6763db345980994aa9d6 100644 (file)
@@ -2,25 +2,33 @@ Summary:      ax25 tools for hamradio
 Summary(pl.UTF-8):     Narzędzia ax25 dla hamradio
 Name:          ax25-tools
 Version:       0.0.8
-Release:       8
-License:       LGPL
+Release:       9
+License:       GPL v2+
 Group:         Applications/Communications
-Source0:       http://dl.sourceforge.net/ax25/%{name}-%{version}.tar.gz
+Source0:       https://downloads.sourceforge.net/ax25/%{name}-%{version}.tar.gz
 # Source0-md5: 70172b979b38a9434f21d2e8152f0d5e
 Patch0:                %{name}-soundmodem.patch
 Patch1:                %{name}-build.patch
-URL:           http://ax25.sourceforge.net/
+Patch2:                %{name}-format.patch
+Patch3:                %{name}-glibc.patch
+Patch4:                %{name}-gcc.patch
+URL:           https://ax25.sourceforge.net/
+BuildRequires: OpenGL-devel
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libax25-devel
-BuildRequires: zlib-devel
-Requires:      glibc >= 2.2
+BuildRequires: fltk-devel
+BuildRequires: glibc-devel >= 2.2
+BuildRequires: libax25-devel >= 0.0.9
+BuildRequires: ncurses-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXi-devel
+BuildRequires: zlib-devel >= 1.1.3
 Requires:      libax25 >= 0.0.9
 Requires:      zlib >= 1.1.3
 Conflicts:     kernel < 2.2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _noautoreq      libfltk.so.1
 %define                _localstatedir  /var/lib
 
 %description
@@ -29,10 +37,25 @@ Tools for start up ax25 protocol.
 %description -l pl.UTF-8
 Narzędzia inicjalizujące protokół ax25.
 
+%package gui
+Summary:       FLTK-based GUI tools for AX.25 protocol
+Summary(pl.UTF-8):     Oparte na FLTK graficzne narzędzia do protokołu AX.25
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+FLTK-based GUI tools for AX.25 protocol.
+
+%description gui -l pl.UTF-8
+Oparte na FLTK graficzne narzędzia do protokołu AX.25.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
 %{__aclocal}
@@ -51,25 +74,114 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man3,%{_localstatedir}/ax25}
 %{__make} install installconf \
        DESTDIR=$RPM_BUILD_ROOT
 
-install hdlcutil/baycom.9      $RPM_BUILD_ROOT%{_mandir}/man3/baycom.3
-install hdlcutil/hdlcdrv.9     $RPM_BUILD_ROOT%{_mandir}/man3/hdlcdrv.3
+cp -p hdlcutil/baycom.9                $RPM_BUILD_ROOT%{_mandir}/man3/baycom.3
+cp -p hdlcutil/hdlcdrv.9       $RPM_BUILD_ROOT%{_mandir}/man3/hdlcdrv.3
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man9
 
-rm -rf $RPM_BUILD_ROOT%{_mandir}/man9
+# packaged as %doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/ax25-tools
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
 %files
 %defattr(644,root,root,755)
-%doc dmascc/README.dmascc tcpip/ttylinkd.{README,INSTALL}
-%doc user_call/README.user_call
-%{_sysconfdir}/ax25/*
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_sbindir}/*
-%docdir %{_docdir}/ax25-tools
-%dir %{_docdir}/ax25-tools
-%{_mandir}/man[13458]/*
-%{_localstatedir}/ax25/*
+%doc AUTHORS ChangeLog dmascc/README.dmascc tcpip/ttylinkd.{README,INSTALL} user_call/README.user_call yamdrv/README.yamdrv
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/ax25.profile
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/ax25d.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/axspawn.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/nrbroadcast
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/rip98d.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/rxecho.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ax25/ttylinkd.conf
+%attr(755,root,root) %{_bindir}/mheard
+%attr(755,root,root) %{_bindir}/sethdlc
+%attr(755,root,root) %{_bindir}/smmixer
+%attr(755,root,root) %{_sbindir}/ax25_call
+%attr(755,root,root) %{_sbindir}/ax25d
+%attr(755,root,root) %{_sbindir}/axctl
+%attr(755,root,root) %{_sbindir}/axparms
+%attr(755,root,root) %{_sbindir}/axspawn
+%attr(755,root,root) %{_sbindir}/beacon
+%attr(755,root,root) %{_sbindir}/bpqparms
+%attr(755,root,root) %{_sbindir}/dmascc_cfg
+%attr(755,root,root) %{_sbindir}/kissattach
+%attr(755,root,root) %{_sbindir}/kissnetd
+%attr(755,root,root) %{_sbindir}/kissparms
+%attr(755,root,root) %{_sbindir}/mcs2h
+%attr(755,root,root) %{_sbindir}/mheardd
+%attr(755,root,root) %{_sbindir}/mkiss
+%attr(755,root,root) %{_sbindir}/net2kiss
+%attr(755,root,root) %{_sbindir}/netrom_call
+%attr(755,root,root) %{_sbindir}/netromd
+%attr(755,root,root) %{_sbindir}/nodesave
+%attr(755,root,root) %{_sbindir}/nrattach
+%attr(755,root,root) %{_sbindir}/nrparms
+%attr(755,root,root) %{_sbindir}/nrsdrv
+%attr(755,root,root) %{_sbindir}/rip98d
+%attr(755,root,root) %{_sbindir}/rose_call
+%attr(755,root,root) %{_sbindir}/rsattach
+%attr(755,root,root) %{_sbindir}/rsdwnlnk
+%attr(755,root,root) %{_sbindir}/rsmemsiz
+%attr(755,root,root) %{_sbindir}/rsparms
+%attr(755,root,root) %{_sbindir}/rsuplnk
+%attr(755,root,root) %{_sbindir}/rsusers.sh
+%attr(755,root,root) %{_sbindir}/rxecho
+%attr(755,root,root) %{_sbindir}/spattach
+%attr(755,root,root) %{_sbindir}/tcp_call
+%attr(755,root,root) %{_sbindir}/ttylinkd
+%attr(755,root,root) %{_sbindir}/yamcfg
+%{_mandir}/man1/dmascc_cfg.1*
+%{_mandir}/man1/mheard.1*
+%{_mandir}/man3/baycom.3*
+%{_mandir}/man3/hdlcdrv.3*
+%{_mandir}/man4/ax25.4*
+%{_mandir}/man4/netrom.4*
+%{_mandir}/man4/rose.4*
+%{_mandir}/man5/ax25d.conf.5*
+%{_mandir}/man5/axspawn.conf.5*
+%{_mandir}/man5/nrbroadcast.5*
+%{_mandir}/man5/rip98d.conf.5*
+%{_mandir}/man5/rxecho.conf.5*
+%{_mandir}/man5/ttylinkd.conf.5*
+%{_mandir}/man8/ax25_call.8*
+%{_mandir}/man8/ax25d.8*
+%{_mandir}/man8/axctl.8*
+%{_mandir}/man8/axparms.8*
+%{_mandir}/man8/axspawn.8*
+%{_mandir}/man8/beacon.8*
+%{_mandir}/man8/bpqparms.8*
+%{_mandir}/man8/kissattach.8*
+%{_mandir}/man8/kissnetd.8*
+%{_mandir}/man8/kissparms.8*
+%{_mandir}/man8/mheardd.8*
+%{_mandir}/man8/mkiss.8*
+%{_mandir}/man8/net2kiss.8*
+%{_mandir}/man8/netrom_call.8*
+%{_mandir}/man8/netromd.8*
+%{_mandir}/man8/nodesave.8*
+%{_mandir}/man8/nrattach.8*
+%{_mandir}/man8/nrparms.8*
+%{_mandir}/man8/nrsdrv.8*
+%{_mandir}/man8/rip98d.8*
+%{_mandir}/man8/rose_call.8*
+%{_mandir}/man8/rsattach.8*
+%{_mandir}/man8/rsdwnlnk.8*
+%{_mandir}/man8/rsparms.8*
+%{_mandir}/man8/rsuplnk.8*
+%{_mandir}/man8/rxecho.8*
+%{_mandir}/man8/sethdlc.8*
+%{_mandir}/man8/smdiag.8*
+%{_mandir}/man8/smmixer.8*
+%{_mandir}/man8/spattach.8*
+%{_mandir}/man8/tcp_call.8*
+%{_mandir}/man8/ttylinkd.8*
+%dir %{_localstatedir}/ax25/mheard
+%config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/ax25/mheard/mheard.dat
+
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/xfhdlcchpar
+%attr(755,root,root) %{_sbindir}/xfhdlcst
+%attr(755,root,root) %{_sbindir}/xfsmdiag
+%attr(755,root,root) %{_sbindir}/xfsmmixer
This page took 0.108397 seconds and 4 git commands to generate.