]> git.pld-linux.org Git - packages/awscli.git/blame_incremental - awscli.spec
rebuild with python 3.10
[packages/awscli.git] / awscli.spec
... / ...
CommitLineData
1%define module awscli
2%define egg_name awscli
3%define pypi_name awscli
4Summary: Universal Command Line Environment for AWS
5Name: awscli
6Version: 1.22.68
7Release: 2
8License: ASL 2.0 and MIT
9Group: Applications/Networking
10Source0: https://files.pythonhosted.org/packages/source/a/awscli/%{name}-%{version}.tar.gz
11# Source0-md5: fc606a88ba9d0e8f659c5733311db71d
12Patch0: %{name}-relax_deps.patch
13URL: https://aws.amazon.com/cli/
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.719
16BuildRequires: python3-modules >= 1:3.6
17BuildRequires: python3-setuptools
18Requires: python3-%{pypi_name} = %{version}
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This package provides a unified command line interface to Amazon Web
24Services.
25
26%package -n python3-%{pypi_name}
27Summary: Python 3 package for awscli
28Group: Libraries/Python
29Requires: python3-PyYAML >= 3.10
30Requires: python3-botocore >= 1.23.33
31Requires: python3-colorama >= 0.2.5
32Requires: python3-docutils >= 0.10
33Requires: python3-modules >= 1:3.6
34Requires: python3-rsa >= 3.1.2
35Requires: python3-s3transfer >= 0.5
36Obsoletes: python-awscli < 1.20.40
37
38%description -n python3-%{pypi_name}
39Python 3 package for awscli.
40
41%prep
42%setup -q
43%patch0 -p1
44
45rm -r %{name}.egg-info
46
47%build
48%py3_build
49
50%install
51rm -rf $RPM_BUILD_ROOT
52%py3_install
53
54# We don't need the Windows CMD script
55rm $RPM_BUILD_ROOT%{_bindir}/aws.cmd
56
57# Fix path and permissions for bash completition
58install -d $RPM_BUILD_ROOT%{bash_compdir}
59mv $RPM_BUILD_ROOT%{_bindir}/aws_bash_completer $RPM_BUILD_ROOT%{bash_compdir}
60# Fix path and permissions for zsh completition
61install -d $RPM_BUILD_ROOT%{zsh_compdir}
62mv $RPM_BUILD_ROOT%{_bindir}/aws_zsh_completer.sh $RPM_BUILD_ROOT%{zsh_compdir}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc README.rst LICENSE.txt
70%attr(755,root,root) %{_bindir}/aws
71%attr(755,root,root) %{_bindir}/aws_completer
72%{bash_compdir}/aws_bash_completer
73%{zsh_compdir}/aws_zsh_completer.sh
74
75%files -n python3-%{pypi_name}
76%defattr(644,root,root,755)
77%{py3_sitescriptdir}/%{module}
78%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.025359 seconds and 4 git commands to generate.