]> git.pld-linux.org Git - packages/avr_simulator.git/commitdiff
- 1.3.0, builds here
authorMaciej Pijanka <agaran@pld-linux.org>
Wed, 6 Aug 2008 09:28:43 +0000 (09:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avr_simulator.spec -> 1.1

avr_simulator.spec [new file with mode: 0644]

diff --git a/avr_simulator.spec b/avr_simulator.spec
new file mode 100644 (file)
index 0000000..7498b20
--- /dev/null
@@ -0,0 +1,91 @@
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%bcond_without tests           # build without tests
+#
+Summary:       avr simulator
+Name:          avr_simulator
+Version:       1.3.0
+Release:       0.1
+License:       GPL v2+
+Group:         Applications
+Source0:       http://dl.sourceforge.net/avr/%{name}-%{version}.tar.gz
+# Source0-md5: 2a73a98db3bf97013acc75324eb005f7
+Patch0:                %{name}-quick.patch
+Patch1:                %{name}-DESTDIR.patch
+Patch2:                %{name}-install.patch
+URL:           http://sourceforge.net/projects/avr/
+BuildRequires: motif-devel
+#BuildRequires:        autoconf
+#BuildRequires:        automake
+#BuildRequires:        intltool
+#BuildRequires:        libtool
+#Requires(postun):     -
+#Requires(pre,post):   -
+#Requires(preun):      -
+#Requires:     -
+#Provides:     -
+#Provides:     group(foo)
+#Provides:     user(foo)
+#Obsoletes:    -
+#Conflicts:    -
+#BuildArch:    noarch
+#ExclusiveArch:        %{ix86}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+# undos the source
+#find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
+
+# remove CVS control files
+#find -name CVS -print0 | xargs -0 rm -rf
+
+# you'll need this if you cp -a complete dir in source
+# cleanup backups after patching
+find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
+%build
+# if ac/am/* rebuilding is necessary, do it in this order and add
+# appropriate BuildRequires
+#%%{__intltoolize}
+#%%{__gettextize}
+#%%{__libtoolize}
+#%%{__aclocal}
+#%%{__autoconf}
+#%%{__autoheader}
+#%%{__automake}
+# if not running libtool or automake, but config.sub is too old:
+#cp -f /usr/share/automake/config.sub .
+#%%configure
+%{__make} \
+       CFLAGS="%{rpmcflags}" \
+       LDFLAGS="%{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+# create directories if necessary
+#install -d $RPM_BUILD_ROOT
+#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT%{_datadir}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README doc/*
+%attr(755,root,root) %{_bindir}/%{name}
+%{_datadir}/%{name}
+
+#%{_examplesdir}/%{name}-%{version}
This page took 0.08412 seconds and 4 git commands to generate.