]> git.pld-linux.org Git - packages/avogadro.git/blob - avogadro.spec
- missing BR: python-sip-devel
[packages/avogadro.git] / avogadro.spec
1
2 %define         qtver   4.7.0
3
4 Summary:        An advanced molecular editor for chemical purposes
5 Name:           avogadro
6 Version:        1.0.1
7 Release:        4
8 License:        GPL v2
9 Group:          Applications/Editors
10 Source0:        http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.bz2
11 # Source0-md5:  0d5c391197101f0aab7be6b59f81e6fd
12 # fix build with sip 4.10
13 URL:            http://avogadro.openmolecules.net/
14 Patch0:         %{name}-python2.7.patch
15 Patch1:         %{name}-linguist.patch
16 Patch2:         %{name}-cmake.patch
17 Patch3:         %{name}-sipfix.patch
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtOpenGL-devel
20 BuildRequires:  boost-devel >= 1.35
21 BuildRequires:  boost-python-devel
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  desktop-file-utils
24 BuildRequires:  docbook-utils
25 BuildRequires:  eigen >= 1:2.0.12
26 BuildRequires:  glew-devel >= 1.5.0
27 BuildRequires:  openbabel-devel >= 2.2.2
28 BuildRequires:  python-numpy-devel
29 BuildRequires:  python-sip-devel
30 BuildRequires:  qt4-build >= %{qtver}
31 BuildRequires:  qt4-qmake >= %{qtver}
32 BuildRequires:  sip
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 An advanced molecular editor designed for cross-platform use in
38 computational chemistry, molecular modeling, bioinformatics, materials
39 science, and related areas, which offers flexible rendering and a
40 powerful plugin architecture.
41
42 %package libs
43 Summary:        Shared libraries for Avogadro
44 Group:          Libraries
45
46 %description libs
47 This package contains the shared libraries for the molecular editor
48 Avogadro.
49
50 %package devel
51 Summary:        Development files for Avogadro
52 Group:          Development/Libraries
53 Requires:       %{name}-libs = %{version}-%{release}
54
55 %description devel
56 This package contains files to develop applications using Avogadros
57 libraries.
58
59 %prep
60 %setup -q
61 %patch0 -p0
62 %patch1 -p0
63 %patch2 -p1
64 %patch3 -p0
65
66 %build
67 install -d build
68 cd build
69 %cmake \
70         -DENABLE_GLSL=ON \
71         -DENABLE_PYTHON=ON \
72         -DENABLE_UPDATE_CHECKER=OFF \
73         -DCMAKE_BUILD_TYPE=Release \
74         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
75         -DLIB_INSTALL_DIR=%{_libdir} \
76         ..
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %post libs -p /sbin/ldconfig
86 %postun libs -p /sbin/ldconfig
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS ChangeLog COPYING
94 %attr(755,root,root) %{_bindir}/%{name}
95 %{_datadir}/%{name}
96 %{_pixmapsdir}/%{name}-icon.png
97 %{_desktopdir}/%{name}.desktop
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_datadir}/lib%{name}
102 %{_includedir}/%{name}
103 %{_libdir}/*.so
104
105 %files libs
106 %defattr(644,root,root,755)
107 %{_datadir}/python*/site-packages/Avogadro.so
108 %{_libdir}/%{name}
109 %attr(755,root,root) %{_libdir}/*.so.*
This page took 0.069763 seconds and 4 git commands to generate.