]> git.pld-linux.org Git - packages/avogadro.git/blob - avogadro.spec
- boost-python-devel
[packages/avogadro.git] / avogadro.spec
1
2 %define         qtver   4.7.0
3
4 Summary:        An advanced molecular editor for chemical purposes
5 Name:           avogadro
6 Version:        1.0.1
7 Release:        3
8 License:        GPL v2
9 Group:          Applications/Editors
10 Source0:        http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.bz2
11 # Source0-md5:  0d5c391197101f0aab7be6b59f81e6fd
12 # fix build with sip 4.10
13 URL:            http://avogadro.openmolecules.net/
14 Patch0:         %{name}-python2.7.patch
15 Patch1:         %{name}-linguist.patch
16 Patch2:         %{name}-cmake.patch
17 Patch3:         %{name}-sipfix.patch
18 BuildRequires:  boost-devel >= 1.35
19 BuildRequires:  boost-python-devel
20 BuildRequires:  cmake >= 2.8.0
21 BuildRequires:  desktop-file-utils
22 BuildRequires:  docbook-utils
23 BuildRequires:  eigen >= 1:2.0.12
24 BuildRequires:  glew-devel >= 1.5.0
25 BuildRequires:  python-numpy-devel
26 BuildRequires:  openbabel-devel >= 2.2.2
27 BuildRequires:  qt4-build >= %{qtver}
28 BuildRequires:  qt4-qmake >= %{qtver}
29 BuildRequires:  sip
30 Requires:       %{name}-libs = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 An advanced molecular editor designed for cross-platform use in
35 computational chemistry, molecular modeling, bioinformatics, materials
36 science, and related areas, which offers flexible rendering and a
37 powerful plugin architecture.
38
39 %package libs
40 Summary:        Shared libraries for Avogadro
41 Group:          Libraries
42
43 %description libs
44 This package contains the shared libraries for the molecular editor
45 Avogadro.
46
47 %package devel
48 Summary:        Development files for Avogadro
49 Group:          Development/Libraries
50 Requires:       %{name}-libs = %{version}-%{release}
51
52 %description devel
53 This package contains files to develop applications using Avogadros
54 libraries.
55
56 %prep
57 %setup -q
58 %patch0 -p0
59 %patch1 -p0
60 %patch2 -p1
61 %patch3 -p0
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DENABLE_GLSL=ON \
68         -DENABLE_PYTHON=ON \
69         -DENABLE_UPDATE_CHECKER=OFF \
70         -DCMAKE_BUILD_TYPE=Release \
71         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
72         -DLIB_INSTALL_DIR=%{_libdir} \
73         ..
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} -C build install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %post libs -p /sbin/ldconfig
83 %postun libs -p /sbin/ldconfig
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog COPYING
91 %attr(755,root,root) %{_bindir}/%{name}
92 %{_datadir}/%{name}
93 %{_pixmapsdir}/%{name}-icon.png
94 %{_desktopdir}/%{name}.desktop
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_datadir}/lib%{name}
99 %{_includedir}/%{name}
100 %{_libdir}/*.so
101
102 %files libs
103 %defattr(644,root,root,755)
104 %{_datadir}/python*/site-packages/Avogadro.so
105 %{_libdir}/%{name}
106 %attr(755,root,root) %{_libdir}/*.so.*
This page took 0.145506 seconds and 4 git commands to generate.