]> git.pld-linux.org Git - packages/avogadro.git/blob - avogadro.spec
- release 5 (by relup.sh)
[packages/avogadro.git] / avogadro.spec
1 Summary:        An advanced molecular editor for chemical purposes
2 Name:           avogadro
3 Version:        1.2.0
4 Release:        5
5 License:        GPL v2
6 Group:          Applications/Editors
7 Source0:        http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.gz
8 # Source0-md5:  3206068fc27bd3b717c568ee72f1e5ec
9 Patch0:         %{name}-linguist.patch
10 Patch1:         %{name}-cmake.patch
11 Patch2:         %{name}-moc-boost.patch
12 Patch3:         gcc6.patch
13 Patch4:         python-install.patch
14 URL:            http://avogadro.openmolecules.net/
15 BuildRequires:  QtNetwork-devel
16 BuildRequires:  QtOpenGL-devel
17 BuildRequires:  boost-devel >= 1.35
18 BuildRequires:  boost-python-devel
19 BuildRequires:  cmake >= 2.8.0
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  docbook-utils
22 BuildRequires:  eigen >= 1:2.0.12
23 BuildRequires:  glew-devel >= 1.5.0
24 BuildRequires:  openbabel-devel >= 2.2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  python-numpy-devel
27 BuildRequires:  python-sip-devel
28 BuildRequires:  qt4-build >= 4.8.2-5
29 BuildRequires:  qt4-linguist
30 BuildRequires:  qt4-qmake >= 4.8.2-5
31 BuildRequires:  sip
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 An advanced molecular editor designed for cross-platform use in
37 computational chemistry, molecular modeling, bioinformatics, materials
38 science, and related areas, which offers flexible rendering and a
39 powerful plugin architecture.
40
41 %package libs
42 Summary:        Shared libraries for Avogadro
43 Group:          Libraries
44
45 %description libs
46 This package contains the shared libraries for the molecular editor
47 Avogadro.
48
49 %package devel
50 Summary:        Development files for Avogadro
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53 Requires:       glew-devel
54
55 %description devel
56 This package contains files to develop applications using Avogadros
57 libraries.
58
59 %prep
60 %setup -q
61 %patch0 -p0
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65 %patch4 -p1
66
67 %build
68 install -d build
69 cd build
70 %cmake \
71         -DENABLE_GLSL=ON \
72         -DENABLE_PYTHON=ON \
73         -DENABLE_UPDATE_CHECKER=OFF \
74         -DCMAKE_BUILD_TYPE=Release \
75         ..
76
77 %{__make} -j1
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/features
82
83 %{__make} -C build install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %if "%{_lib}" != "lib"
87 %{__mv} $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}/libmsym.so
88 %endif
89
90 %post libs -p /sbin/ldconfig
91 %postun libs -p /sbin/ldconfig
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS COPYING
99 %attr(755,root,root) %{_bindir}/%{name}
100 %attr(755,root,root) %{_bindir}/avopkg
101 %attr(755,root,root) %{_bindir}/qube
102 %attr(755,root,root) %{_libdir}/libmsym.so
103 %{_datadir}/%{name}
104 %{_pixmapsdir}/%{name}-icon.png
105 %{_desktopdir}/%{name}.desktop
106 %{_mandir}/man1/avogadro.1*
107 %{_mandir}/man1/avopkg.1*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %{_datadir}/lib%{name}
112 %{_includedir}/%{name}
113 %attr(755,root,root) %{_libdir}/libavogadro.so
114 %attr(755,root,root) %{_libdir}/libavogadro_OpenQube.so
115 %{_datadir}/qt4/mkspecs/features/avogadro.prf
116 %{_pkgconfigdir}/avogadro.pc
117
118 %files libs
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{py_sitedir}/Avogadro.so
121 %{_libdir}/%{name}
122 %attr(755,root,root) %{_libdir}/*.so.*
This page took 0.036273 seconds and 3 git commands to generate.