]> git.pld-linux.org Git - packages/avifile.git/commitdiff
- orphaned, outdated
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 21 Apr 2006 23:40:26 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avifile-compilation.patch -> 1.2
    avifile-gcc34.patch -> 1.2
    avifile-home_etc.patch -> 1.2
    avifile-vidix.patch -> 1.2
    avifile-wma2wav.patch -> 1.2
    avifile-xlibs.patch -> 1.2

avifile-compilation.patch [deleted file]
avifile-gcc34.patch [deleted file]
avifile-home_etc.patch [deleted file]
avifile-vidix.patch [deleted file]
avifile-wma2wav.patch [deleted file]
avifile-xlibs.patch [deleted file]

diff --git a/avifile-compilation.patch b/avifile-compilation.patch
deleted file mode 100644 (file)
index 52bf122..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/video/renderer.cpp~    2002-09-12 14:52:51.000000000 -0400
-+++ lib/video/renderer.cpp     2002-09-23 17:27:44.000000000 -0400
-@@ -2169,7 +2169,7 @@
-       Unlock();
-         delete m_pXvRtConfig;
-     }
--    virtual IRtConfig* GetRtConfig() const { return m_pXvRtConfig ? m_pXvRtConfig : m_pSdlgRtConfig; }
-+    virtual IRtConfig* GetRtConfig() const { return m_pXvRtConfig ? (IRtConfig*) m_pXvRtConfig : (IRtConfig*) m_pSdlgRtConfig; }
-     virtual uint_t GetImages() const { return ovlist.size(); }
-     virtual CImage* ImageAlloc(const BITMAPINFOHEADER& bh, uint_t idx)
-     {
diff --git a/avifile-gcc34.patch b/avifile-gcc34.patch
deleted file mode 100644 (file)
index e022fa2..0000000
+++ /dev/null
@@ -1,128 +0,0 @@
-diff -urN aa/avifile-0.7-0.7.38/include/aviplay.h avifile-0.7-0.7.38/include/aviplay.h
---- aa/avifile-0.7-0.7.38/include/aviplay.h    2003-05-25 00:51:30.000000000 +0200
-+++ avifile-0.7-0.7.38/include/aviplay.h       2004-07-02 15:03:57.497990112 +0200
-@@ -12,8 +12,8 @@
- #include "image.h"
- #include "avm_args.h"
--typedef void (*KILLHANDLER)(int, void* p = 0);
--typedef int (*AUDIOFUNC)(void* srcdata, unsigned int size, void* p = 0);
-+typedef void (*KILLHANDLER)(int, void* p);
-+typedef int (*AUDIOFUNC)(void* srcdata, unsigned int size, void* p);
- AVM_BEGIN_NAMESPACE;
-diff -urN aa/avifile-0.7-0.7.38/include/avm_map.h avifile-0.7-0.7.38/include/avm_map.h
---- aa/avifile-0.7-0.7.38/include/avm_map.h    2003-03-27 02:01:22.000000000 +0100
-+++ avifile-0.7-0.7.38/include/avm_map.h       2004-07-02 15:15:04.427601400 +0200
-@@ -198,7 +198,8 @@
- {
-     // cast to the needed type - used to prevent internal compiler error
-     // for old egcc
--    avm_map<Key, Value, Compare, Equal>::_Tnode* node = (avm_map<Key, Value, Compare, Equal>::_Tnode*) n;
-+    //avm_map<Key, Value, Compare, Equal>::_Tnode* node = (avm_map<Key, Value, Compare, Equal>::_Tnode*) n;
-+    _Tnode* node = (_Tnode*) n;
-     if(node->entry)
-     {
-diff -urN aa/avifile-0.7-0.7.38/include/avm_stl.h avifile-0.7-0.7.38/include/avm_stl.h
---- aa/avifile-0.7-0.7.38/include/avm_stl.h    2003-06-08 17:57:05.000000000 +0200
-+++ avifile-0.7-0.7.38/include/avm_stl.h       2004-07-02 15:12:53.351527992 +0200
-@@ -74,6 +74,7 @@
-       m_Type = new Type[m_uiCapacity];
-     }
-     ~qring() { delete[] m_Type; }
-+    qring<Type>(const qring<Type>& t) {}
-     qring<Type>& operator=(const qring<Type>& t)
-     {
-       if (this != &t)
-@@ -149,7 +150,6 @@
-     // disabled for now
-     qring<Type>() {}
--    qring<Type>(const qring<Type>& t) {}
-     uint_t bpos() const { return (m_uiPos > 0) ? m_uiPos - 1 : m_uiCapacity - 1; }
-     uint_t fpos() const { return (m_uiSize > m_uiPos) ? m_uiPos + m_uiCapacity - m_uiSize: m_uiPos - m_uiSize; }
-diff -urN aa/avifile-0.7-0.7.38/lib/aviread/AsfNetworkInputStream.cpp avifile-0.7-0.7.38/lib/aviread/AsfNetworkInputStream.cpp
---- aa/avifile-0.7-0.7.38/lib/aviread/AsfNetworkInputStream.cpp        2003-05-27 17:26:31.000000000 +0200
-+++ avifile-0.7-0.7.38/lib/aviread/AsfNetworkInputStream.cpp   2004-07-02 15:08:12.642202296 +0200
-@@ -793,22 +793,24 @@
-     return -1;
- }
--int AsfNetworkInputStream::write(const void* buffer, uint_t size)
-+int AsfNetworkInputStream::write(const void* b, uint_t size)
- {
-+    const char* buffer = (const char*) b;
-     int wsize = size;
-     while (wsize > 0)
-     {
-       int i = ::write(m_iSocket, buffer, wsize);
-       if (i <= 0)
-             return i;
--      (const char*)buffer += i;
-+      buffer += i;
-         wsize -= i;
-     }
-     return size;
- }
--int AsfNetworkInputStream::dwrite(const void* buffer, uint_t size)
-+int AsfNetworkInputStream::dwrite(const void* b, uint_t size)
- {
-+    const char* buffer = (const char*) b;
-     if (m_lfd < 0)
-     {
-       if (m_lfd == -12345)
-@@ -843,7 +845,7 @@
-       int i = ::write(m_lfd, buffer, size);
-       if (i < 0)
-             return i;
--      (const char*)buffer += i;
-+      buffer += i;
-       size -= i;
-     }
-     fsync(m_lfd);
-diff -urN aa/avifile-0.7-0.7.38/lib/common/image.cpp avifile-0.7-0.7.38/lib/common/image.cpp
---- aa/avifile-0.7-0.7.38/lib/common/image.cpp 2003-05-25 01:00:58.000000000 +0200
-+++ avifile-0.7-0.7.38/lib/common/image.cpp    2004-07-02 15:16:53.695990080 +0200
-@@ -954,7 +954,7 @@
-     fillMembers();
-     if (!copy)
-     {
--      (const uint8_t*) m_pPlane[0] = data;
-+      m_pPlane[0] = (uint8_t*) data;
-     }
-     else
-     {
-diff -urN aa/avifile-0.7-0.7.38/plugins/libvorbis/libvorbis.cpp avifile-0.7-0.7.38/plugins/libvorbis/libvorbis.cpp
---- aa/avifile-0.7-0.7.38/plugins/libvorbis/libvorbis.cpp      2003-05-20 16:33:13.000000000 +0200
-+++ avifile-0.7-0.7.38/plugins/libvorbis/libvorbis.cpp 2004-07-02 15:19:50.622093224 +0200
-@@ -96,7 +96,7 @@
-       op.packet = NULL;
-       op.b_o_s  = 1; /* beginning of stream for first packet */
-       op.bytes  = hdrsizes[0];
--      (const void*) op.packet = vorbishdr;
-+      op.packet = (unsigned char*) vorbishdr;
-       vorbishdr += op.bytes;
-       if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
-       {
-@@ -106,7 +106,7 @@
-       op.b_o_s  = 0;
-       op.bytes  = hdrsizes[1];
--      (const void*) op.packet = vorbishdr;
-+      op.packet = (unsigned char*) vorbishdr;
-       vorbishdr += op.bytes;
-       if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
-       {
-@@ -115,7 +115,7 @@
-       }
-       op.bytes  = hdrsizes[2];
--      (const void*) op.packet = vorbishdr;
-+      op.packet = (unsigned char*) vorbishdr;
-       vorbishdr += op.bytes;
-       if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
-       {
diff --git a/avifile-home_etc.patch b/avifile-home_etc.patch
deleted file mode 100644 (file)
index b7d0203..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Nru avifile0.7-0.7.32/lib/common/Registry.cpp avifile0.7-0.7.32.new/lib/common/Registry.cpp
---- avifile0.7-0.7.32/lib/common/Registry.cpp  Fri Oct  4 09:07:33 2002
-+++ avifile0.7-0.7.32.new/lib/common/Registry.cpp      Sun Mar 23 13:59:08 2003
-@@ -33,15 +33,22 @@
-     if (!config)
-     {
-       char* home;
--      home = getenv("HOME");
--      if (home == 0)
-+      int config_dir_used = 0;
-+      home = getenv("CONFIG_DIR");
-+      if (home) config_dir_used = 1;
-+      else
-       {
--          struct passwd* pwent = getpwuid(getuid());
--          home = pwent->pw_dir;
-+              home = getenv("HOME");
-+              if (home == 0)
-+              {
-+              struct passwd* pwent = getpwuid(getuid());
-+              home = pwent->pw_dir;
-+              }
-       }
-       avm::string s(home);
-       if (!sConfigDir)
--          s += "/.avm";
-+              if (config_dir_used) s+= "/avm";
-+          else s += "/.avm";
-       else
-       {
-           s += "/";
diff --git a/avifile-vidix.patch b/avifile-vidix.patch
deleted file mode 100644 (file)
index b6324e1..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -uNr avifile0.7-0.7.16.orig/lib/video/renderer.cpp avifile0.7-0.7.16/lib/video/renderer.cpp
---- avifile0.7-0.7.16.orig/lib/video/renderer.cpp      Thu Sep 12 20:52:51 2002
-+++ avifile0.7-0.7.16/lib/video/renderer.cpp   Wed Oct  2 21:02:00 2002
-@@ -2766,11 +2766,13 @@
-                                int width, int height,
-                                fourcc_t yuv_fmt, bool sub)
- {
-+#ifdef HAVE_VIDIX
-     //return new XvYUVRenderer(pw, dpy, width, height, yuv_fmt, sub);
-     if (geteuid() == 0)
-       // for root user try to use VIDIX
-       try { return new VidixRenderer(pw, (Display*)dpy, width, height, yuv_fmt, sub);
-       } catch (FatalError& e)  { e.PrintAll(); }
-+#endif
- #if _SDL_VER > 1103
-     return new YUVRenderer(pw, (Display*)dpy, width, height, yuv_fmt, sub);
- #else
diff --git a/avifile-wma2wav.patch b/avifile-wma2wav.patch
deleted file mode 100644 (file)
index 1a6d7ab..0000000
+++ /dev/null
@@ -1,176 +0,0 @@
-diff -urN avifile-0.6.0.20011207/lib/common/util.cpp avifile-0.6.0.20011207-/lib/common/util.cpp
---- avifile-0.6.0.20011207/lib/common/util.cpp Wed Nov 21 23:33:02 2001
-+++ avifile-0.6.0.20011207-/lib/common/util.cpp        Wed Dec 19 01:58:31 2001
-@@ -440,7 +440,7 @@
-     }
-     fclose(f);
--    printf("Available CPU flags: %s\n", flags);
-+    fprintf(stderr, "Available CPU flags: %s\n", flags);
-     have_tsc = (strstr(flags, "tsc") != 0);
-     have_mmx = (strstr(flags, "mmx") != 0);
-     have_sse = (strstr(flags, "sse") != 0);
-@@ -460,7 +460,7 @@
-     if (freq < 0)
-       freq = old_freq();
-     if (have_tsc)
--      printf("%f MHz %s processor detected\n", freq/1000., model);
-+      fprintf(stderr, "%f MHz %s processor detected\n", freq/1000., model);
- }
-diff -urN avifile-0.6.0.20011207/samples/misc/Makefile.am avifile-0.6.0.20011207-/samples/misc/Makefile.am
---- avifile-0.6.0.20011207/samples/misc/Makefile.am    Mon Dec  3 11:38:01 2001
-+++ avifile-0.6.0.20011207-/samples/misc/Makefile.am   Wed Dec 19 01:58:31 2001
-@@ -8,6 +8,7 @@
- avitype_SOURCES=avitype.cpp
- extractor_SOURCES=extractor.cpp
-+wma2wav_SOURCES=wma2wav.cpp
- test_SOURCES=test.cpp
- #plustest_SOURCES=plustest.cpp
- #imtest_SOURCES=imtest.cpp
-@@ -24,6 +25,7 @@
- avitype_LDADD = $(LIBRARY)
- extractor_LDADD = $(LIBRARY)
-+wma2wav_LDADD = $(LIBRARY)
- if AMM_USE_JPEGLIB
- avimake_SOURCES = avimake.cpp
-@@ -33,7 +35,7 @@
- PROG_AVIMAKE =
- endif
--bin_PROGRAMS = avibench avicat avitype $(PROG_AVIMAKE)
-+bin_PROGRAMS = avibench avicat avitype $(PROG_AVIMAKE) wma2wav
- check_PROGRAMS = asfdump asftest avitest extractor test
- EXTRA_DIST =  imtest.cpp plustest.cpp qualtest.cpp test.cpp
-diff -urN avifile-0.6.0.20011207/samples/misc/wma2wav.cpp avifile-0.6.0.20011207-/samples/misc/wma2wav.cpp
---- avifile-0.6.0.20011207/samples/misc/wma2wav.cpp    Thu Jan  1 01:00:00 1970
-+++ avifile-0.6.0.20011207-/samples/misc/wma2wav.cpp   Wed Dec 19 01:58:51 2001
-@@ -0,0 +1,123 @@
-+/*
-+ * Convert .wma files to .wav (so they can be treated with lame to produce
-+ * more reasonable output :^)
-+ * Copyright (c) 2001 Michal Moskal (malekith@pld.org.pl)
-+ *
-+ * I was motivated to write this simple cuple of lines by Piotr Modrzyk,
-+ * and I wish to thank him here ;)
-+ *
-+ * This program could be probably also used to extract soundtrack from 
-+ * movies, but I don't mind and hence the name...
-+ */
-+
-+#include <config.h>
-+#include <default.h>
-+#include <avifile.h>
-+#include <stdio.h>
-+#include <aviplay.h>
-+#include <except.h>
-+#include <version.h>
-+#include <unistd.h>
-+#include <fcntl.h>
-+#include <string.h>
-+
-+#define __MODULE__ "wma2wav"
-+
-+using namespace std;
-+
-+int main(int argc, const char **argv)
-+{
-+      IAviReadFile *ac = 0;
-+      IAviReadStream *as = 0;
-+      uint8_t *zz = 0;
-+      int out_fd;
-+      const char *infile, *outfile;
-+
-+      if (argc != 2 && argc != 3) {
-+              fprintf(stderr, "\n\nUSAGE: %s inputfile [outputfile]\n"
-+                              "If outputfile is not present or is \"-\" "
-+                              "stdout is used.\n\n",  argv[0]);
-+              exit(1);
-+      }
-+
-+      if (GetAvifileVersion() != AVIFILE_VERSION) {
-+              fprintf(stderr,
-+                      "This binary was compiled for Avifile ver. "
-+                      "%f, but the but the library is ver. %f. Aborting.\n",
-+                      AVIFILE_VERSION, GetAvifileVersion());
-+              exit(1);
-+      }
-+
-+      infile = argv[1];
-+      outfile = argv[2];
-+      
-+      if (outfile && strcmp(outfile, "-") == 0)
-+              outfile = NULL;
-+      
-+      if (outfile == NULL) {
-+              // preserve stdout
-+              out_fd = dup(1);
-+              // copy messages to stderr
-+              dup2(2, 1);
-+      } else {
-+              out_fd = open(outfile, O_WRONLY|O_TRUNC|O_CREAT, 0666);
-+              if (out_fd < 0) {
-+                      perror(outfile);
-+                      exit(1);
-+              }
-+      }
-+
-+      try {
-+              ac = CreateIAviReadFile(infile);
-+              if (ac == NULL) {
-+                      fprintf(stderr, "%s: can't read it\n", infile);
-+                      exit(1);
-+              }
-+
-+              as = ac->GetStream(0, AviStream::Audio);
-+              if (ac == NULL) {
-+                      fprintf(stderr, "%s: doesn't contains audio stream\n", 
-+                              infile);
-+                      exit(1);
-+              }
-+
-+              const int buffer_size = 2 * 1024 * 1024;
-+              zz = new uint8_t[buffer_size];
-+              size_t samp_read, bytes_read, sz;
-+              WAVEFORMATEX hdr;
-+
-+              memset(&hdr, 0, sizeof(hdr));
-+              as->GetAudioFormatInfo(&hdr, NULL);
-+
-+              write(out_fd, "RIFF\x0f\xff\xff\xffWAVEfmt \x10\0\0\0", 20);
-+              // override
-+              hdr.wFormatTag = 1;
-+              write(out_fd, &hdr, 16);
-+              write(out_fd, "data\x0f\xff\xff\xff", 8);
-+
-+              as->StopStreaming();
-+              as->StartStreaming();
-+              while (!as->Eof()) {
-+                      sz = as->GetFrameSize();
-+                      if (sz > (size_t)buffer_size)
-+                              sz = buffer_size;
-+                      as->ReadFrames(zz, sz, sz, samp_read, bytes_read);
-+                      if (write(out_fd, zz, bytes_read) != (int)bytes_read) {
-+                              perror("write");
-+                              exit(1);
-+                      }
-+              }
-+
-+              close(out_fd);
-+      } catch(FatalError & error) {
-+              fprintf(stderr, "Fatal error:\n");
-+              error.Print();
-+              exit(1);
-+      }
-+      if (ac)
-+              delete ac;
-+      if (zz)
-+              delete zz;
-+              
-+      return 0;
-+}
diff --git a/avifile-xlibs.patch b/avifile-xlibs.patch
deleted file mode 100644 (file)
index de70224..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur avifile0.7-0.7.7.orig/libavqt/Makefile.am avifile0.7-0.7.7/libavqt/Makefile.am
---- avifile0.7-0.7.7.orig/libavqt/Makefile.am  Wed May 22 22:41:03 2002
-+++ avifile0.7-0.7.7/libavqt/Makefile.am       Thu Jun 13 11:01:28 2002
-@@ -30,7 +30,7 @@
- #order.cpp
--libqavm_la_LDFLAGS = $(QT_LIBS) -release $(LT_RELEASE) -version-info $(LT_VERSION)
-+libqavm_la_LDFLAGS = $(X_LIBS) $(QT_LIBS) -release $(LT_RELEASE) -version-info $(LT_VERSION)
- #libavqt_la_LIBADD = ../lib/libaviplay.la
- #noinst_PROGRAMS = ordertest
This page took 0.101512 seconds and 4 git commands to generate.