]> git.pld-linux.org Git - packages/aview.git/commitdiff
- added asciiview-lame_bashizm.patch, rel. 6 auto/th/aview-1_3_0rc1-6
authorTomasz Pala <gotar@pld-linux.org>
Sun, 7 Mar 2010 18:07:41 +0000 (18:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    asciiview-lame_bashizm.patch -> 1.1
    aview.spec -> 1.39

asciiview-lame_bashizm.patch [new file with mode: 0644]
aview.spec

diff --git a/asciiview-lame_bashizm.patch b/asciiview-lame_bashizm.patch
new file mode 100644 (file)
index 0000000..b11be4a
--- /dev/null
@@ -0,0 +1,69 @@
+--- asciiview  2001-04-25 17:59:22.000000000 +0200
++++ /usr/bin/asciiview 2010-03-07 18:58:25.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # asciiview - an ascii art image browser script. Front end for aview/aaflip
+ clear()
+ {
+@@ -7,9 +7,9 @@
+ }
+ myconvert()
+ {
+-   if anytopnm $1 >/tmp/aview$$.pgm 2>/dev/null ; then
++   if anytopnm "$1" >/tmp/aview$$.pgm 2>/dev/null; then
+      exit
+-   elif convert -colorspace gray $1 pgm:- 2>/dev/null ; then
++   elif convert -colorspace gray "$1" pgm:- 2>/dev/null; then
+      exit
+    fi
+    echo "Failed to convert file format to PNM by both convert and anytopnm" >&2
+@@ -17,7 +17,7 @@
+      echo "0 " 
+    done
+ }
+-filenames=""
++set -A filenames
+ options=""
+ if [ "$1" = "" ]; then
+   echo "$0 - an ascii art image/animation browser.
+@@ -45,29 +45,30 @@
+       shift
+       ;;
+     *) 
+-      filenames="$filenames $1"
++      filenames[${#filenames[@]}]="$1"
+       shift
+       ;;
+   esac
+ done
+-trap clear 0
++trap clear 0 2 3 9 15
+ mkfifo /tmp/aview$$.pgm
+-outfile=/tmp/aview$$.pgm
+-for name in $filenames ; do
+-if test -r $name ; then
+-case $name in
++i=0
++while [ $i -lt ${#filenames[@]} ]; do
++      name=${filenames[$i]}
++      if [ -r "$name" ]; then
++              case "$name" in
+ *.fli | *.lfc | *.flic )
+   PATH="$PATH:."
+-  aaflip $options $name
++  aaflip $options "$name"
+   ;;
+ *)
+-  myconvert $name >/tmp/aview$$.pgm &
++  myconvert "$name" > /tmp/aview$$.pgm &
+   pid=$!
+-  PATH="$PATH:."
+   aview  $options /tmp/aview$$.pgm
+   kill $pid 2>/dev/null
+ esac
+ else
+   echo "$name could not be opended"
+ fi
++      i=$((i+1))
+ done
index ebd67751d9ca5a208ebe2ca46dd44f27ab94b462..24d89ca43f9ed999edc8906483d502b7edce6aba 100644 (file)
@@ -2,11 +2,12 @@ Summary:      ASCII-Art image browser and animation player
 Summary(pl.UTF-8):     Przeglądarka obrazków i animacji jako ASCII Art
 Name:          aview
 Version:       1.3.0rc1
-Release:       5
-License:       GPL
+Release:       6
+License:       GPL v2
 Group:         Applications/Graphics
 Source0:       http://dl.sourceforge.net/aa-project/%{name}-%{version}.tar.gz
 # Source0-md5: 093f298e7787591e229b59d039c72f4d
+Patch0:                asciiview-lame_bashizm.patch
 URL:           http://aa-project.sourceforge.net/aview/
 BuildRequires: aalib-devel
 BuildRequires: autoconf
@@ -38,6 +39,7 @@ trzy poziomy ditheringu, itp. oraz ukryte opcje "bonusowe" :)
 
 %prep
 %setup -q -n %{name}-1.3.0
+%patch0 -p0
 
 %build
 %{__autoconf}
@@ -59,6 +61,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ANNOUNCE ChangeLog AUTHORS NEWS README README.flip TODO
+%doc ANNOUNCE AUTHORS ChangeLog NEWS README README.flip TODO
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
This page took 0.081167 seconds and 4 git commands to generate.