]> git.pld-linux.org Git - packages/avidemux.git/blob - avidemux.spec
- rel 3; fix x264 build
[packages/avidemux.git] / avidemux.spec
1 # TODO:
2 #       - create aften.spec (aften.sf.net) and use it
3 #
4 # Conditional build:
5 %bcond_without  esd     # disable EsounD sound support
6 %bcond_without  arts    # without arts audio output
7 %bcond_with     amr     # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
8 %bcond_with     qt      # build qt4-base interface
9 %bcond_with     ssse3   # use SSSE3 instructions
10 #
11 %ifarch pentium4 %{x8664}
12 %define         with_sse3       1
13 %endif
14
15 Summary:        A small audio/video editing software for Linux
16 Summary(pl.UTF-8):      Mały edytor audio/wideo dla Linuksa
17 Name:           avidemux
18 Version:        2.4.3
19 Release:        4
20 License:        GPL v2+
21 Group:          X11/Applications/Multimedia
22 Source0:        http://download2.berlios.de/avidemux/%{name}_%{version}.tar.gz
23 # Source0-md5:  ff8e6ac186321e7e8bec9f8177df3724
24 Source1:        %{name}.desktop
25 Patch0:         %{name}-autoconf.patch
26 Patch1:         %{name}-dts_internal.patch
27 Patch2:         %{name}-sparc64.patch
28 Patch3:         %{name}-x264.patch
29 URL:            http://fixounet.free.fr/avidemux/
30 BuildRequires:  SDL-devel
31 BuildRequires:  a52dec-libs-devel
32 BuildRequires:  alsa-lib-devel >= 1.0
33 %{?with_amr:BuildRequires:      amrnb-devel}
34 %{?with_arts:BuildRequires:     artsc-devel}
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 %{?with_esd:BuildRequires:      esound-devel}
38 BuildRequires:  faad2-devel
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  freetype-devel >= 2.0.0
41 BuildRequires:  gettext-devel
42 BuildRequires:  gtk+2-devel >= 1:2.6.0
43 BuildRequires:  js-devel(threads)
44 BuildRequires:  lame-libs-devel
45 BuildRequires:  libdts-devel
46 BuildRequires:  libmad-devel
47 BuildRequires:  libmpeg3-devel
48 BuildRequires:  libsamplerate-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool
51 BuildRequires:  libvorbis-devel
52 BuildRequires:  libx264-devel
53 BuildRequires:  libxml2-devel
54 BuildRequires:  pkgconfig
55 %{?with_qt:BuildRequires:       QtGui-devel}
56 %{?with_qt:BuildRequires:       qt4-build}
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  xorg-lib-libXt-devel
59 BuildRequires:  xorg-lib-libXv-devel
60 BuildRequires:  xorg-proto-xextproto-devel
61 BuildRequires:  xvid-devel >= 1:1.0
62 Requires:       js(threads)
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 A small audio/video editing software for Linux.
67
68 %description -l pl.UTF-8
69 Mały edytor audio/wideo dla Linuksa.
70
71 %prep
72 %setup -q -n %{name}_%{version}
73 %patch0 -p1
74 %patch1 -p0
75 %patch2 -p1
76 %patch3 -p1
77
78 echo 'pt_BR' >> po/LINGUAS
79
80 %build
81 %{__cp} /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
82 %{__make} -f admin/Makefile.common cvs
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__automake}
87 %configure \
88         %{!?with_amr:ac_cv_header_amrnb_interf_dec_h=no} \
89         %{!?with_arts:--without-arts} \
90         %{!?with_esd:--without-esd} \
91         --disable-static \
92 %ifarch ppc
93         --enable-altivec \
94 %endif
95         %{?with_ssse3:--enable-ssse3} \
96 %if %{with qt}
97         --with-qt-dir=%{_prefix} \
98         --with-qt-include=%{_includedir}/qt4 \
99         --with-qt-lib=%{_libdir}
100 %endif
101
102 %{__make} -j1 -C po
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
113 install avidemux_icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS History
123 %attr(755,root,root) %{_bindir}/avidemux2_cli
124 %attr(755,root,root) %{_bindir}/avidemux2_gtk
125 %{?with_qt:%attr(755,root,root) %{_bindir}/avidemux2_qt4}
126 %{_desktopdir}/*.desktop
127 %{_pixmapsdir}/*.png
This page took 0.076603 seconds and 4 git commands to generate.